locked
Unable to sequence Firefox v40.0.3 in App-V 4.6 RRS feed

  • Question

  • Application : Mozilla Firefox v40.0.3

    OS : Windows 7 SP1 x64 (recently patched VM)

    Sequencer version : 4.6.0.20200

    With the sequencer running in the background, performed the following steps:

    1. Performed a 'Custom' installation (unchecked 'Install Maintenance Service' check-box)

    2. After installation is completed, copied the following files:

    3. Copied 'local-settings.js' to 'C:\Program Files (x86)\Mozilla Firefox\defaults\pref'

    -----Contents of this file-----

    pref("general.config.obscure_value", 0);
    pref("general.config.filename", "mozilla.cfg");

    --------------------------------

    4. Copied 'mozilla.cfg' to 'C:\Program Files (x86)\Mozilla Firefox'

    -----Contents of this file-----

    //
    pref("browser.startup.homepage", http://intranet/);
    pref("browser.shell.checkDefaultBrowser", false);
    pref("app.update.auto", false);
    pref("app.update.enabled", false);
    pref("app.update.service.enabled", false);
    pref("browser.cache.disk.smart_size.use_old_max", false);
    pref("browser.search.update", false);
    pref("datareporting.healthreport.uploadEnabled", false);
    pref("signon.rememberSignons", false);

    --------------------------------

    Created these files as per stated at http://kb.mozillazine.org/Locking_preferences.

    However, Firefox fails to launch during the monitoring phase and neither thereafter. No error messages displayed.

    What am I doing wrong here ?

    Please help.

    Monday, September 21, 2015 9:13 PM

All replies

  • You need a process monitor trace.


    Steve Thomas, Senior Consultant, Microsoft

    App-V/MED-V/SCVMM/Server App-V/MDOP/AppCompat

    http://blogs.technet.com/gladiatormsft/
    The App-V Team blog: http://blogs.technet.com/appv/
    The MED-V Team Blog: http://blogs.technet.com/medv
    The SCVMM Team blog: http://blogs.technet.com/scvmm/

    “This posting is provided "AS IS" with no warranties, and confers no rights. User assumes all risks.”

    Saturday, October 17, 2015 4:50 AM
  • Don't start firefox during sequence (of first use) phase... Just make sure your default user profile (which is located in a subfolder under installdir) is configured correctly. Let firefox create the profile at first launch on the client.
    Saturday, October 17, 2015 4:40 PM
  • I have sequenced Mozilla firefox a couple of times and haven't faced any issues. Try with the latest App-V sequencer version to get full benefits.

    (Please click on "Vote as Helpful" and/or "Mark as Answer", if it has helped you.)

    app2pack.blogspot.com: app2pack.blogspot.com

    Saturday, October 17, 2015 7:21 PM