locked
How to enable refresh cells in excel connection properties. RRS feed

  • Question

  • Hi Community,

    I have received one query from my user for refreshing data in excel, which downloaded as "Export to spreadsheet" from MOSS2007.

    1. user downloaded exce using "export to spreadsheet" from list.

    2. file saved and opend in local excel.

    3. clicked on Data tab in excel sheet.

    4. queries and connection, double click on connection.

    5. then we get this below window, in that refresh every is disabled. do we have any option to enable below highlighted option.

    Thank you

    Ashwin

    Tuesday, March 13, 2018 7:28 AM

All replies

  • Hi,

    Can you unchecked "Enable background refresh" and see if "Refresh every " will be enabled?


    Best regards,

    Riwut Libinuko
    Principal Architect, Singapore
    Office Servers and Services MVP | Singapore
    Blog : http://blog.libinuko.com

    Tuesday, March 13, 2018 1:06 PM
  • We can't change the option. This is a limitation when using PowerPivot. Check this: https://social.technet.microsoft.com/Forums/en-US/cc7b6cc8-b9b3-472a-b8f9-0e4dbad7443b/how-to-enable-greyeddisabled-option-enable-background-refresh-in-excel-in-data-connection?forum=excel
    Wednesday, March 14, 2018 5:59 AM
  • Hi Mate,

    Thanks for your email. i will try to use this as evidence to convey my user. but to re-frame my query, again i am posting here.

    This is not power pivot. actually, We have a Onprem (Sharepoint 2007) list exported to excel and we require to have the data refresh periodically. The data connection property is showing grayed out. can we check any possibility place to enable "Refresh Every".

    basically. user wants to use onpremises data in online sharepoint. due to some internal limitations, we couldn't achieve migration. so, that's why trying in different way to achieve this by other option. 

    if you can share any alternate option to achieve this, that is really great help for us. 


    Thank you

    Ashwin

    Thursday, March 15, 2018 3:51 AM