locked
Dynamic Disks appear Foreign After Reboot RRS feed

  • Question

  • Setup is some two raw luns passed through ESXi (4.1) to a Server 2008 R2 (No SP at this point). These luns are configured into a spanned dynamic disk. 

    After every reboot the disks appear as foreign. I haven't narrowed down if the guest is moving across hosts, but it shouldn't really matter, they should come back correctly. 

    ideas?

    Wednesday, December 28, 2011 2:25 AM

All replies

  • Hi,

    This could be caused that the lun is not ready yet when system trying to mount it. Please have a try to run a diskpart command after boot up and see if the lun will back. If so you can set a startup script to workaround this issue.


    TechNet Subscriber Support in forum |If you have any feedback on our support, please contact tnmff@microsoft.com.
    Thursday, December 29, 2011 9:03 AM
  • If disks are moving across hosts it will be marked as foreign. Each disk group has a host name stamped to it. Hence on a new host it will be marked as foreign.

     

    You can import foreign disks on new host and can resolve your issue. Only thing is that import all of disks at once. Otherwise there can be a data loss.

    diskpart> sel disk <for-disk>

    diskpart> import

     

    Regards

    Satish

    Thursday, January 12, 2012 11:33 AM
  • Hi!

    I have a problem where my dynamic disks mounted only to one host and on every reboot I see that I need to import these disk because they was marked as foreign.

    Thursday, March 23, 2017 9:04 AM