locked
The Microsoft Exchange administrator has made a change that requires you quit and restart Outlook RRS feed

  • Question

  • Hello,

    I have a problem with some clients on my forest environment.

    The organization is working with a single forest and a single domain. Windows 2012 R2 Active Directory with 2 dc with Windows Server 2012 R2 Standard OS.

    I have exchange 2010 standard on windows 2012 Standard Server as a member of the domain.

    I have outlook 2013 and 2010 on the clients computers,

    I have moved on 04/2015 the 200 mailboxes from exchange 2003 Enterprise to this exchange 2010 Standard.

    I keep getting this message on some clients "   The Microsoft Exchange administrator has made a change that requires you quit and restart Outlook " when the user first do a login to the computer and opens outlook.

    I have enabled logging on the client and this is the output: Please Help.

    2016.01.05 16:38:04 <<<< Logging Started (level is LTF_TRACE) >>>>
    2016.01.05 16:38:04 HELPER::Initialize called
    2016.01.05 16:38:04 Initializing: Finding a Transport
    2016.01.05 16:38:04 MAPI XP Call: XPProviderInit in EMSMDB.DLL, hr = 0x00000000
    2016.01.05 16:38:04 MAPI Status: (-- -- ---/--- -- ---)
    2016.01.05 16:38:04 MAPI XP Call: TransportLogon, hr = 0x00000000
    2016.01.05 16:38:04 Initializing: Found a transport, Error code = 0x00000000
    2016.01.05 16:38:04 MAPI XP Call: AddressTypes, hr = 0x00000000, cAddrs = 3, cUids = 1
    2016.01.05 16:38:04 MAPI Status: (IN -- ---/OUT -- ---)
    2016.01.05 16:38:04 MAPI XP Call: TransportNotify(BEGIN_IN|BEGIN_OUT), hr = 0x00000000
    2016.01.05 16:38:04 HELPER::Initialize done, Error code = 0x00000000
    2016.01.05 16:38:04 HELPER::GetCapabilities called, Error code = 0x00000000 

    Tuesday, January 5, 2016 2:50 PM

Answers

  • Hi,

    According to your description, the issue may be related to the migrated users.

    Can those problematic users access mailboxes fine on OWA?

    Have you tried to recreate a new profile?

    In addition, please check in ADSIEdit > Configuration >CN=Services > CN=Microsoft Exchange > CN=your ORG name > CN=Administrative Groups > CN=Exchange Administrative Group > CN=Databases, check whether the msExchHomePublicMDB value is set to an unavailable value. If you see reference to the old database, please clear the value.

    Regards,

    David 

    • Marked as answer by David Wang_ Monday, January 25, 2016 10:03 AM
    Wednesday, January 6, 2016 6:28 AM

All replies

  • Hi,<o:p></o:p>

    As a starting point, try running the Microsoft Office Configuration Analyzer Tool on an affected client.  This will review your Outlook installation for any known issues (https://www.microsoft.com/en-IE/download/details.aspx?id=36852)<o:p></o:p>




    __________________________________________

    Please mark as Answer if this answers your question

    Regards,

    Shane Jackson

    Blog: https://shanejacksonitpro.wordpress.com/

    Twitter: https://twitter.com/shane00jackson

    Note: Posts are provided “AS IS” without warranty of any kind, either expressed or implied, including but not limited to the implied warranties of merchantability and/or fitness for a particular purpose.

    Tuesday, January 5, 2016 3:08 PM
  • Hello,

    I have a problem with some clients on my forest environment.

    The organization is working with a single forest and a single domain. Windows 2012 R2 Active Directory with 2 dc with Windows Server 2012 R2 Standard OS.

    I have exchange 2010 standard on windows 2012 Standard Server as a member of the domain.

    I have outlook 2013 and 2010 on the clients computers,

    I have moved on 04/2015 the 200 mailboxes from exchange 2003 Enterprise to this exchange 2010 Standard.

    I keep getting this message on some clients "   The Microsoft Exchange administrator has made a change that requires you quit and restart Outlook " when the user first do a login to the computer and opens outlook.

    I have enabled logging on the client and this is the output: Please Help.

    2016.01.05 16:38:04 <<<< Logging Started (level is LTF_TRACE) >>>>
    2016.01.05 16:38:04 HELPER::Initialize called
    2016.01.05 16:38:04 Initializing: Finding a Transport
    2016.01.05 16:38:04 MAPI XP Call: XPProviderInit in EMSMDB.DLL, hr = 0x00000000
    2016.01.05 16:38:04 MAPI Status: (-- -- ---/--- -- ---)
    2016.01.05 16:38:04 MAPI XP Call: TransportLogon, hr = 0x00000000
    2016.01.05 16:38:04 Initializing: Found a transport, Error code = 0x00000000
    2016.01.05 16:38:04 MAPI XP Call: AddressTypes, hr = 0x00000000, cAddrs = 3, cUids = 1
    2016.01.05 16:38:04 MAPI Status: (IN -- ---/OUT -- ---)
    2016.01.05 16:38:04 MAPI XP Call: TransportNotify(BEGIN_IN|BEGIN_OUT), hr = 0x00000000
    2016.01.05 16:38:04 HELPER::Initialize done, Error code = 0x00000000
    2016.01.05 16:38:04 HELPER::GetCapabilities called, Error code = 0x00000000 

    I smell a Public Folder issue. What is the status of the public folders? Have you migrated them to 2010 completely?
    Tuesday, January 5, 2016 3:11 PM
  • Hi,

    Please follow the below article

    http://www.techrid.com/exchange-server-2010/mailbox/the-microsoft-exchange-administrator-has-made-a-change-that-requires-you-quit-and-restart-outlook/

    Regards,

    Praveen

    ----------------------------------------------------------------------

    Remember to mark as helpful if you find my contribution useful or as an answer if it does answer your question.That will encourage me - and others - to take time out to help you Check out my latest blog posts on Exchange 2016 @ Techrid.com

    Tuesday, January 5, 2016 8:25 PM
  • Hi,

    According to your description, the issue may be related to the migrated users.

    Can those problematic users access mailboxes fine on OWA?

    Have you tried to recreate a new profile?

    In addition, please check in ADSIEdit > Configuration >CN=Services > CN=Microsoft Exchange > CN=your ORG name > CN=Administrative Groups > CN=Exchange Administrative Group > CN=Databases, check whether the msExchHomePublicMDB value is set to an unavailable value. If you see reference to the old database, please clear the value.

    Regards,

    David 

    • Marked as answer by David Wang_ Monday, January 25, 2016 10:03 AM
    Wednesday, January 6, 2016 6:28 AM
  • We had the same error show up after a MS Exchange Schema update. The msExchHomePublicMDB attribute for our mailbox databases was referencing deleted/invalid Public Folders.

    After clearing the value and waiting for AD replication, the issue went away.

    You can view/clear this in ADSI edit. You'll need to connect to the Configuration context. The DN of the mailbox databases is something like this:
    CN=Databases,CN=Exchange Administrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=domain,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=domain,DC=com



    Tuesday, April 9, 2019 3:24 AM