none
MDT deployment - Bootstrap.ini not passing network credentials RRS feed

  • Question

  • Hello everyone,

    I have been having issue re-configuring our automated MDT image deployment. We keep getting the network credentials windows appearing at the beginning of the deployment eventough the credentials are included in the rules and bootstrap.ini. I had the exact same issue last time I setted it up before some data loss and now I can't remember for the life of me what I did to fix it.

    Every time I make modification, I update the deployment share choosing the option to completly regenerate the boot image and then I go replace the lighttouch img in WDS to make sure all the change get updated. Still no luck and always get the network credentials windows pop up during deployment.

    We do not use a domain but a workgroup called WORKGROUP. What mm I missing? I tought the UserID and UserPassword line were exactly to bypass that screen, yet the screen keep popping up with only the domain field filled but not the userid and password. It had been driving me crazy, specially that I encountered the same issue a few month ago and managed to solve it but can't remember the solution...

    Thank you for your help!

    The rules and bootstrap have those lines:

    [Settings]
    Priority=Default
    Properties=MyCustomProperty
    _SMSTSORGNAME=OUR NAME

    [Default]
    OSDComputername=%SerialNumber%
    TaskSequenceID=INSTALLIMG
    DeployRoot=\\192.168.*.*\DeploymentShare$
    SkipDomainMembership=YES
    JoinDomain=WORKGROUP
    UserID:***
    UserPassword:***

    SkipBDDWelcome=YES
    SkipWizard=NO
    SkipTaskSequence=NO
    SkipProductKey=YES
    SkipComputerBackup=YES
    SkipUserData=YES
    SkipAdminPassword=YES
    SkipApplications=YES
    SkipCapture=YES
    SkipBitLocker=YES
    SkipFinalSummary=YES
    SkipLocaleSelection=YES
    SkipTimeZone=YES
    SkipPackageDisplay=YES
    SkipComputerName=YES


    ApplyGPOPack=NO
    HideShell=YES


    • Edited by SkinnyV Tuesday, March 6, 2018 8:54 PM typo
    Tuesday, March 6, 2018 5:17 PM

All replies

  • Try change your bootstrap.ini to

    [Settings]
    Priority=Default

    [Default]
    DeployRoot=\\192.168.*.*\DeploymentShare$
    UserID:***
    UserPassword:***
    SkipBDDWelcome=YES

    And your CustomSettings.ini to

    [Settings]
    Priority=Default
    Properties=MyCustomProperty

    [Default]
    OSDComputername=%SerialNumber%
    TaskSequenceID=INSTALLIMG
    SkipDomainMembership=YES
    _SMSTSORGNAME=OUR NAME
    SkipWizard=NO
    SkipTaskSequence=NO
    SkipProductKey=YES
    SkipComputerBackup=YES
    SkipUserData=YES
    SkipAdminPassword=YES
    SkipApplications=YES
    SkipCapture=YES
    SkipBitLocker=YES
    SkipFinalSummary=YES
    SkipLocaleSelection=YES
    SkipTimeZone=YES
    SkipPackageDisplay=YES
    SkipComputerName=YES
    ApplyGPOPack=NO
    HideShell=YES

    Regenerate new bootimage and import bootimage in WDS.

    • Proposed as answer by veera0918 Wednesday, March 7, 2018 2:18 PM
    • Unproposed as answer by SkinnyV Wednesday, March 7, 2018 3:16 PM
    Wednesday, March 7, 2018 12:32 PM
  • could you check the bootstrap.ini can you skip this UserID:***UserPassword:*** and select the option in Complete generate the image 


    Wednesday, March 7, 2018 2:32 PM
  • Thank you for your help, I tried to make the change and regenerate the boot image/update lighttouch image and still get the Netowrk Credential Windows pop up...
    Wednesday, March 7, 2018 3:08 PM
  • I am not sure if I understand your request. You want me to remove the UserPassword line completly?
    Wednesday, March 7, 2018 3:09 PM
  • Try adding UserDomain=192.168.*.* to the bootstrap.ini (set this to the full IP of the MDT deployment share box).


    Regards Mark

    Always learning.
    If replies help, please either vote up or mark as answers.

    Thursday, March 8, 2018 9:16 AM
  • Thank you, I tried to add this to my bootstrap.ini, regenerate the image fully and upddate the lighttouch image  but it still give me the network credentials windows. The only difference is that it now list the ip address in the domain field of the credential windows...
    Friday, March 9, 2018 10:22 PM
  • Are the credentials definitely correct? If you type them in the credential dialog do they work and does the deployment continue?

     

    Regards Mark

    Always learning.
    If replies help, please either vote up or mark as answers.

    • Proposed as answer by veera0918 Monday, March 12, 2018 5:35 PM
    • Unproposed as answer by SkinnyV Monday, March 26, 2018 3:25 PM
    Monday, March 12, 2018 12:33 PM
  • SkinnyV,

    When MDT prompts you for credentials, can you enter in the correct UserID, UserPassword, and UserDomain, click OK, and will it connect to the share and start the task sequence?  If not, you may need to look at checking the permissions on the share and the NTFS permissions on the folder to ensure that the account has access.

    If the MDT server is not part of the enterprise domain, then, like silvermarkg said, you will need to use the IP or Server name as the UserDomain in the bootstrap.ini and make sure the userID is a local account on the server.

    LawsonT

    Monday, March 12, 2018 4:56 PM
  • I am certain of the credential and it work fine if I enter the manually in the network credentials windows.
    Monday, March 12, 2018 8:27 PM
  • In the Bootstrap.ini can you try the following:

    [Settings]

    Priority=Default

    [Default]

    DeployRoot=\\192.168.*.*\DeploymentShare$
    UserDomain:<MDTServerNameGoesHere>
    UserID:<UsernameWithAccessToTheMDTShareHere>
    UserPassword:<PasswordForTheUsername
    WithAccessToTheMDTShareHere>
    SkipBDDWelcome=YES

    LawsonT



    • Edited by LawsonT Tuesday, March 13, 2018 12:02 AM spacing
    Monday, March 12, 2018 11:54 PM
  • When you say UserDomain:<MDTServerNameGoesHere>, you mean the machine name? because we already tried with the ip of the mdt server. Or should I had the full path to the mdr server there too?
    Tuesday, March 13, 2018 2:53 PM
  • You can put either the IPAddress or the ServerName there.  It shouldnt really matter.  I have done this both ways and not had any issue, but my preference is to use the actual servername.
    Tuesday, March 13, 2018 3:25 PM
  • It was already suggested to me in a previous reply and it did not get ride of the network credentials windows...
    Tuesday, March 13, 2018 7:58 PM
  • Can anyone give me a copy of their tested and working bootstrap.ini file so I can try it here and see ? I tried everything and still get the network credentiasl windows poping up even after regenerating the mdt image and lighttouch...
    Friday, March 16, 2018 5:18 PM
  • Has anyone found a plausible solution to this post? I have recently updated to v1903 and testing out PXE booting. My previous rules / bootstrap ini files password along credentials perfectly through the offline media. All rules are the same.

    Monday, June 10, 2019 6:08 PM
  • Hi,

    After you have updated your Deployment share with your new/working boot.ini file

    rename the LiteTouchPE_x86.wim file the WDS boot file) in \\servername\reminst\Boot\x86\Images to OldLiteTouchPE_x86.wim

    then replace that with the newly generated LiteTouchPE_x86.wim file from (MDT Share) \\servername\deploymentshare$\Boot

    That did it for me.

    • Proposed as answer by petefarrell Wednesday, July 10, 2019 1:45 PM
    Wednesday, July 10, 2019 1:41 PM
  • I would imagine the process would be the same with the LiteTouchPE_x64.wim file too. Hope this helps,
    • Proposed as answer by petefarrell Wednesday, July 10, 2019 1:45 PM
    Wednesday, July 10, 2019 1:44 PM