locked
Issues with Streaming app for some users RRS feed

  • Question

  • Guys first of all I am sorry for posting this, it has probably been asked thousands of times and answered each time but I cannot find anything specific to the issue I am seeing.  A lot of issues close to what I am seeing but none of the published fixes are helping me.

    Environment rundown

    • Management/publishing server:  Win Server 2012 R2
    • Appv Database:  Hosted on a dedicated SQL server - Win Server 2008 R2 w/ SQL 2012
    • App Store:  All .appv packages are stored on a NetApp hosted share (all domain users and domain computers have read access to this share and content)
    • AppV Client (RDS):  Installed on Win Server 2008 R2 machine


    Scenario

    Currently only have 1 application being published whilst testing

    1. Domain Admins can run the Appv Client User Interface and pull in applications with no issues at all.
    2. NEWLY created, standard domain users can run the Appv Client User Interface and pull in applications with no issues at all.
    3. However, when logging in with a current, standard domain user we get the following:

    The user can open the AppV Client User Interface and request an update.  The loading bar will pop up just about the taskbar, will attempt to pull in the application(s) but will then fail.

    When checking the Event Viewer I see the following error for these failed attempts:

    - System 
      - Provider 
       [ Name]  Microsoft-AppV-Client 
       [ Guid]  {E4F68870-5AE8-4E5B-9CE7-CA9ED75B0245} 
       EventID 19104 
       Version 1 
       Level 2 
       Task 36 
       Opcode 0 
       Keywords 0x8000000000800000 
      - TimeCreated 
       [ SystemTime]  2016-07-07T16:26:43.560496000Z 
       EventRecordID 69 
      - Correlation 
       [ ActivityID]  {01B13C40-F800-0000-616A-71F6DAD6D101} 
       - Execution 
       [ ProcessID]  2928 
       [ ThreadID]  4120 
       Channel Microsoft-AppV-Client/Admin 
       Computer ctxmastervm.shsgroup.local 
      - Security 
       [ UserID]  S-1-5-21-1248594026-227944680-618671499-5232 
    - EventData 
      Value1 0 
      Value2 1 


    If anyone has any points or tips I would greatly appreciate the feedback.  Have been wrestling with this issue for a few weeks now.

    Thanks for your time guys.

    Thursday, July 7, 2016 4:34 PM

All replies

  • What's the actual error or is there any?

    Did you see this thread: https://social.technet.microsoft.com/Forums/en-US/cabeb040-7723-48b1-b861-5411bed1c54c/published-apps-event-id-19104?forum=mdopappv

    Could be profile related...how do you manage those profiles?

    Alternatively:

    Is it possible that the App-V client settings are applied using a GPO targeted at the user level?

    I would suggest launching PowerShell as a working user and running:

    Set-ExecutionPolicy RemoteSigned
    

    When prompted accept or use the force flag. Then import the appvclient module:

    import-module appvclient

    Assuming you only have one App-V Publishing Server get the AppVPublishing server ID:1

    Get-AppVPublishingServer 1
    You could pipe that or copy it to a text file and then do the same on a non-working user and see if it's different.


    PLEASE MARK ANY ANSWERS TO HELP OTHERS Blog: rorymon.com Twitter: @Rorymon

    Thursday, July 7, 2016 7:53 PM
  • Computer ctxmastervm.shsgroup.local

    Based on your Comptuer Name, I guess you're using Citrix RDS Servers? Are you using the Citrix Profile Manager?


    Simon Dettling | msitproblog.com | @SimonDettling

    Friday, July 8, 2016 6:08 AM
    Moderator
  • Thanks for the feedback guys.

    Rory, when I Get-AppvPublishingServer and Get-AppvClientConfiguration I get identical outputs from both the working users and the also from the users which are not working.  See below:

    With regards to Group Policy I have the following set relating to AppV:

    [Computer]

    Citrix/Profile Management/File system : Exclusion List - Directories

    AppData\Local\Microsoft\AppV

    Appdata\Roaming\Microsoft\Appv

    Citrix/Profile Management/Registry : Exclusion List

    Software\Microsoft\AppV\Client\Integration

    Software\Microsoft\AppV\Client\Publishing

    System/App-V/Publishing

    Enable Publishing Refresh UX:  Enabled

    Publishing Server 1 Settings: (Same settings as fedback in the Get-AppvPublishingServer command)

    System/App-V/Streaming

    Autoload Options:  Enabled

    [User]

    Policies\Admin Templates\System\User Profiles

    Prevent the following directories from roaming with the profile:

    • appdata\local\microsoft\appv
    • appdata\roaming\microsoft\appv

    Simon, as you have probably worked out from the above, you are 100% correct.  Using XenApp 6.5 using the Citrix Profile Manager.  I have also cross-checked between working users and non-working users and the CTXProfile configs appear to be the same also.

    I had initially thought it was a group policy setting getting added to standard users which was causing issues.  Blew this out of the water by creating a new AD account in the same OU as failing user and then adding the account to all same security groups as failing users.  These test accounts worked fine.

    Rory, with regards to the link I have checked or tried most of the mentioned or further linked:

    • The following directories ARE appearing in the non-working users profiles:

    - %APPDATA% \ Microsoft \ AppV \ Client \ VFS 
    - %LOCALAPPDATA% \ Microsoft \ AppV \ Client \ VFS

    • I have deleted the "LocalVFSSecuredUsers" registry entries

    Sorry for the long winded messages but a lot to get out there.

    EDIT:  Another few things to note which I have just noticed.

    1. The Microsoft\AppV\Client\VFS folders are set to be excluded within Group Policy yet they are showing in user profiles?
    2. Working users : within their roaming profiles in the above mentioned directory we have 3 further directories.  Catalog; Integration & VFS.
    3. Non-working users : within their roaming profiles in the above mentioned directory they only have 2 further directories.  Integration & VFS.
    • Edited by dmcdowell Friday, July 8, 2016 9:04 AM
    Friday, July 8, 2016 8:42 AM
  • I haven't compared each an every setting from your Snippet, just make sure you exclude everything which is listed here: http://docs.citrix.com/en-us/profile-management/5/upm-citrix-products-wrapper-den/upm-using-with-app-v.html

    I experienced something similar a few years ago, when the Exclusions weren't set correctly and because of PVS.

    Are you using Provisioning Services or are these Persistent Workers?


    Simon Dettling | msitproblog.com | @SimonDettling

    Friday, July 8, 2016 8:50 AM
    Moderator
  • Thanks Simon I will check this out now.

    We are indeed using Provisioning Services.

    Friday, July 8, 2016 10:23 AM
  • I ran into some issues when using PVS and the Package Installation Root is being placed on the streamed Disk. Due to its default Location of (C:\Program Data) it actually ends up always on the streamed disk.

    You can try if the Problem is solved, by placing the Package Installation Root on a Persistent Drive.

    The following blog post is in German but should contain the Info you're looking for. (If you need some translation, just ask..): http://www.software-virtualisierung.de/entry/app-v-und-citrix-provisioning-services-appcrash.html

    The blog post basically tells to either place the Cache on a Persistent Drive, which is actually not completely supported by MS, or to change the Cache Type of the vDisk to "Cache in Device RAM".

    If you go for the first workaround, you just have to make sure to remove the Cache after evey Restart!

    I ran the first workaround for about Year and we recently changed the Cache Type to the Option mentioned above, as we updated our PVS Server. Since then the Packages are working without any issues on the streamed disk.


    Simon Dettling | msitproblog.com | @SimonDettling

    Friday, July 8, 2016 10:55 AM
    Moderator
  • We are currently running the first "workaround" for almost 2,5 years now (200 PVS servers) without any issues. Also keep in mind to make sure no appv packages are added/published while you're prepping your image as this will break stuff too.

    Roy Essers

    Wednesday, July 13, 2016 11:23 PM