locked
workflow manager 2013 installation???? RRS feed

  • Question

  • We migrated to SP2013 and workflows breaked...on search we found need to install workflow manager.

    Question: Should we install the workflow manager on Front End & Applications? Also is this required configuration wizard and restart of servers after installing it?

    We have 2 Web Front End and 2 Application Servers.

    Wednesday, December 3, 2014 9:35 AM

Answers

  • There's a few options for this, If you are server limited then I would use one of or both of the Application servers. If you can i'd split it out to a separate server, especially if you're going to use it heavily.

    http://technet.microsoft.com/en-us/library/jj658588(v=office.15)#section5

    You shouldn't need WFM for any old 2010 workflows that were upgraded. That system is still intact.

    • Proposed as answer by John NaguibMVP Wednesday, December 3, 2014 11:18 AM
    • Marked as answer by Rebecca Tu Thursday, January 8, 2015 7:44 AM
    Wednesday, December 3, 2014 10:34 AM
  • HI,

    workflow build in SharePoint 2010 is by default supported in SharePoint 2013. It is not compulsory for you to upgrade.

    you should only upgrade if you want the  benefits of SharePoint 2013 workflow.

    in your case you must be hitting some other kind of error.   you should dig deep and figure out why workflow is getting broken in your case. We can surely help you in resolving those issue.

     


    Whenever you see a reply and if you think is helpful,Vote As Helpful! And whenever you see a reply being an answer to the question of the thread, click Mark As Answer

    • Marked as answer by Imran Razaa Wednesday, December 3, 2014 11:20 AM
    Wednesday, December 3, 2014 10:55 AM

All replies

  • There's a few options for this, If you are server limited then I would use one of or both of the Application servers. If you can i'd split it out to a separate server, especially if you're going to use it heavily.

    http://technet.microsoft.com/en-us/library/jj658588(v=office.15)#section5

    You shouldn't need WFM for any old 2010 workflows that were upgraded. That system is still intact.

    • Proposed as answer by John NaguibMVP Wednesday, December 3, 2014 11:18 AM
    • Marked as answer by Rebecca Tu Thursday, January 8, 2015 7:44 AM
    Wednesday, December 3, 2014 10:34 AM
  • HI,

    workflow build in SharePoint 2010 is by default supported in SharePoint 2013. It is not compulsory for you to upgrade.

    you should only upgrade if you want the  benefits of SharePoint 2013 workflow.

    in your case you must be hitting some other kind of error.   you should dig deep and figure out why workflow is getting broken in your case. We can surely help you in resolving those issue.

     


    Whenever you see a reply and if you think is helpful,Vote As Helpful! And whenever you see a reply being an answer to the question of the thread, click Mark As Answer

    • Marked as answer by Imran Razaa Wednesday, December 3, 2014 11:20 AM
    Wednesday, December 3, 2014 10:55 AM
  • Hii Imran,

    Follow this link to install Workflow Manager

    http://ranaictiu-technicalblog.blogspot.in/2013/02/sharepoint-2013-workflow-manager.html

    • Proposed as answer by Soyeb Malek Wednesday, December 3, 2014 10:59 AM
    Wednesday, December 3, 2014 10:58 AM
  • Thanks Alex...but how we will check workflow is upgraded or not?
    Wednesday, December 3, 2014 11:06 AM
  • Sorry, to be more precise: Any workflows that came across when you upgraded your databases should still work. As should any new workflows created post migration in 2010 mode.

    Wednesday, December 3, 2014 11:17 AM
  • No workflows were created using SPD in SP2010....sites are migrated to 2013 only.
    Wednesday, December 3, 2014 11:19 AM
  • Hi Imran,

    As Alex mentioned 2010 workflows don't workflow manager.

    Workflow Manager is needed only for 2013 workflows

    If you want your 2010 SPD workflows to run in 2013 platform, then you have to recreate the workflow as the assemblies and runtime are different now in SP2013. Also, there is a change from XOML to XAML format. The activities which are implementations of activity classes, are implemented declaratively by using XAML.

    This is what is stated in this link

    http://blogs.msdn.com/b/chandru/archive/2013/04/14/upgrading-spd-2010-workflows-to-spd-2013-workflows.aspx



    Kind Regards,

    John Naguib

    Technical Consultant/Architect

    MCITP, MCPD, MCTS, MCT, TOGAF 9 Foundation

    Please remember to mark your question as answered if this solves your problem

    Wednesday, December 3, 2014 11:24 AM
  • Hi John, We need our 2010 SPD workflows should start working with Workflow Manager in 2013.
    Wednesday, December 3, 2014 11:31 AM
  • Hi Imran,

    then you need workflow Interop

    http://technet.microsoft.com/en-us/library/jj670125.aspx


    Kind Regards,

    John Naguib

    Technical Consultant/Architect

    MCITP, MCPD, MCTS, MCT, TOGAF 9 Foundation

    Please remember to mark your question as answered if this solves your problem

    Wednesday, December 3, 2014 11:41 AM