locked
external hard drive sharing RRS feed

  • Question

  • I have two vista 64 computers. I have a external hard drive on one and it works fine, and I set file sharing on and advanced permission to full. on my second computer when I try to get to the external hard drive it comes up with I don't have permission or file sharing.
    Saturday, October 2, 2010 1:12 PM

Answers

  • Hi,

    Thank you for your post!

    Please follow the below instruction and restart computer.

    1. Click Start.
    2. Type regedit, and then click OK.
    3. Navigate to the following key:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanmanServer\Parameters
    4. In the right pane, double-click the IRPStackSize value.
    NOTE: If the IRPStackSize value does not already exist, use the following procedure to create it:
    a) In the Parameters folder of the registry, right-click the right pane.
    b) Point to New, and then click DWord Value.
    c) Type IRPStackSize.

    IMPORTANT: Type "IRPStackSize" exactly as it is displayed because the value name is case-sensitive.
    5. Change the Base to decimal.
    6. In the Value Data box, type a value that is larger than the value that is listed.

    If you created the IRPStackSize value using the procedure described in step 4, the default value is 15. It is recommended that you increase the value by 3. Therefore, if the previous value was 11, type 14, and then click OK.
    7. Close the Registry Editor.
    8. Restart the computer.

    Regards,


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Wednesday, October 6, 2010 9:13 AM
    Moderator

All replies

  • Hi,

    Thank you for your post!

    Please follow the below instruction and restart computer.

    1. Click Start.
    2. Type regedit, and then click OK.
    3. Navigate to the following key:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanmanServer\Parameters
    4. In the right pane, double-click the IRPStackSize value.
    NOTE: If the IRPStackSize value does not already exist, use the following procedure to create it:
    a) In the Parameters folder of the registry, right-click the right pane.
    b) Point to New, and then click DWord Value.
    c) Type IRPStackSize.

    IMPORTANT: Type "IRPStackSize" exactly as it is displayed because the value name is case-sensitive.
    5. Change the Base to decimal.
    6. In the Value Data box, type a value that is larger than the value that is listed.

    If you created the IRPStackSize value using the procedure described in step 4, the default value is 15. It is recommended that you increase the value by 3. Therefore, if the previous value was 11, type 14, and then click OK.
    7. Close the Registry Editor.
    8. Restart the computer.

    Regards,


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Wednesday, October 6, 2010 9:13 AM
    Moderator
  • I have a very similar issue, as described here. Except:

    . The computer owning the XD is W10 Pro. And the computer needing to share the XD is W10 Home.

    . The registry of the XD W10 owner does not contain an IRPStackSize value.

    . I had this simple share arrangement working flawlessly over the last 6 months. It really was pretty simple.

      And, I seem to recall I didn't need any Home Group facilities for support. I guess that's what the warning

      is for. The problem(s) arose when I de-shared everything in preparation for a reported MoBo replacement

      in the computer hospital ER. Full 16GB memory was also fully replaced earlier. But, I wouldn't think those

      replacements would affect this sharing issue.

    Anyway, would you consider this Vista proposal to be applicable to me with the W10's, based on the details

    I've additionally provided?

    Thank you.

    Monday, December 5, 2016 4:09 PM
  • This issue has been resolved. Thank you.

    Wednesday, December 7, 2016 2:20 PM