locked
User preferred name (displayed name) not updating after a name change in Active Directory RRS feed

  • Question

  • Hello All,

    Our intranet portal authentication is provided by Active Directory and profiles are regularly imported.  About a week ago, one of the users name was changed in AD because she married. Her old profile no longer shows up in View User Profiles and her new one does, as expected.  The problem is that all her posts that she has made to discussion groups previous to the name change show up with her maiden name.

     

    How can I correct this so that the posts reflect her new name?

     

    Thanks in advance,

    David


    Wednesday, May 25, 2011 11:02 AM

Answers

  • Hi,

    Did you try to delete and then re add the user to site ?

    Please let us know after performing above task.


    Warm Regards, Pratik Vyas | SharePoint Consultant | http://sharepointpratik.blogspot.com/
    • Marked as answer by MCPSSPA Wednesday, May 25, 2011 4:21 PM
    Wednesday, May 25, 2011 3:51 PM

All replies

  • Changing the display name (of the old user in this case?) will change the Display Name of all the earlier posts too.

    (As far as I can remember - but worth trying as a first quick solution)


    SP 2010 "FAQ" (mainly useful links): http://wssv4faq.mindsharp.com/default.aspx
    WSS3/MOSS FAQ (FAQ and Links) http://wssv3faq.mindsharp.com/default.aspx
    Both also have links to extensive book lists and to (free) on-line chapters
    Wednesday, May 25, 2011 11:30 AM
  • Thanks for the reply, Mike.

    The display name has been changed but it is not reflected in the 'Created by' column in the discussion list for older posts she made.  Ideally, I would like to be able to reflect the changes in those posts.

    Wednesday, May 25, 2011 1:17 PM
  • Hi,

    Did you try to delete and then re add the user to site ?

    Please let us know after performing above task.


    Warm Regards, Pratik Vyas | SharePoint Consultant | http://sharepointpratik.blogspot.com/
    • Marked as answer by MCPSSPA Wednesday, May 25, 2011 4:21 PM
    Wednesday, May 25, 2011 3:51 PM
  • The user listed under the old name was deleted from the site but I did not re-add because she is part of the site's visitors group, which is controlled by an AD security group.  I verified that she is indeed a member of that security group under her new name and not the old one.

    Regardless, I added her by name into the visitors group and it changed the posts!  Removed her from the group again and everything looks fine now.

    Thank you very much, Pratik!

    Wednesday, May 25, 2011 4:20 PM