none
dpm 2012 email notification using a non-exchange smtp mail server RRS feed

  • Question

  • Has anyone successfully been able to configure DPM 2012 to send email notifications to a standard SMTP mail server (NON-EXCHANGE)?
    Tuesday, October 2, 2012 9:15 PM

Answers

  • Hi Stephanie,

    Thanks for your suggestion. I double-checked with the network team to insure that the smtp server allows the dpm server to relay through it. After that it was a matter of trial end error to find the "credentials" that dpm needed. It seems as though DPM needs you to use the account it creates when installing DPM, i.e., <server name>\MICROSOFT$DPM$Acct. The Logon message is misleading in that it doesn't specify what its trying to authenticate against.

    The solution is

    1. make sure your smtp server is configured to allow DPM server to relay,

    2. use the <server name>\MICROSOFT$DPM$Acct

    Worked for me. Thanks for everyone's help.

    Happy,

    • Marked as answer by BullTopia Thursday, October 4, 2012 9:28 PM
    Thursday, October 4, 2012 9:28 PM

All replies

  • Hi Happycamper999

    Are you using a linux server in your environment? If you specify the smtp server name and port, are you able to send a test notification?

    You can also look here:

    http://bennettadelson.wordpress.com/tag/dpm-2012/

    for ref: http://social.technet.microsoft.com/Forums/en-US/dataprotectionmanager/thread/3e258692-4f22-49c1-a751-dbbadbe91281/

    Wednesday, October 3, 2012 5:09 AM
  • Hello DareDevil57,

    The SMTP mail server is linux (a non-exchange server). I am able to use telnet to send email using the credentials that I would put into DPM. Apparently DPM tries to authenticate to something as I get Login failure: unknown username or bad password ID 2013 trying to send a test message. This happens using a login name and password or leaving the fields blank.

    No one seems to know thins but the question is "What is DPM trying to authenticate to?"

    Thanks,

    Wednesday, October 3, 2012 2:26 PM
  • Hi Happy,

    What kind of credential are you using ?

    If you use a DPM local account by clicking on button "Send test E-mail..." you should see the "Send Test E-mail - Enter the e-mail address to send a test message to:" pop up ?

    Another link on this issue : http://social.technet.microsoft.com/Forums/en-US/dataprotectionmanager/thread/777fb122-a49e-409b-8181-a7b40e4d8d6e/

    Stephane


    Please remember to click “Mark as Answer” on the post that helps you. This posting is provided "AS IS" with no warranties. knowledge is valid only if it is shared by All.

    My DPM blog Yet Another DPM Blog


    Wednesday, October 3, 2012 3:10 PM
  • Wouldn't the the "thing" (for lack of a more technical name) that dpm is trying to authenticate to determine what credential to use?

    To answer your immediate question, I tried blank, the local server account that dpm creates (DPMR$NLM-BAK-MS11) and runs under and a linux admin account on the target mail server. Same error -  Login failure: unknown username or bad password ID 2013. I'm able to use telnet to send email through the smtp server.

    Happy

    Wednesday, October 3, 2012 3:19 PM
  • Hi Happy,

    I try with IIS6 SMTP server with Anonymous Access.

    From DPM side, settings for "Authentificated SMTP Server: Username/password" :

    1- Leave blank =>ID 2013 : logon failure : unknow user name or bad password.

    2- DPMServerName\UserAccount => Works :)

    Network trace with Wireshark :

    1- Nothing => Most likely blocked by DPM console : Authentificated SMTP Server must be fill.

    2- See full SMTP connection, mail send.

    Could you do network trace to see what's happen ?

    Stephane


    Please remember to click “Mark as Answer” on the post that helps you. This posting is provided "AS IS" with no warranties. knowledge is valid only if it is shared by All.

    My DPM blog Yet Another DPM Blog




    Wednesday, October 3, 2012 9:19 PM
  • Hi Stephanie,

    Thanks for your suggestion. I double-checked with the network team to insure that the smtp server allows the dpm server to relay through it. After that it was a matter of trial end error to find the "credentials" that dpm needed. It seems as though DPM needs you to use the account it creates when installing DPM, i.e., <server name>\MICROSOFT$DPM$Acct. The Logon message is misleading in that it doesn't specify what its trying to authenticate against.

    The solution is

    1. make sure your smtp server is configured to allow DPM server to relay,

    2. use the <server name>\MICROSOFT$DPM$Acct

    Worked for me. Thanks for everyone's help.

    Happy,

    • Marked as answer by BullTopia Thursday, October 4, 2012 9:28 PM
    Thursday, October 4, 2012 9:28 PM
  • Hi, Just thought id add my 2 cents, and thanks for pointing me in the right direction.

    I created a new user, for sending SCDPM alerts out, in AD and then tried to authenticate with that user, constantly failed with error 2013.

    I then added the new user account to the local admins group and all is now working.

    Thursday, February 13, 2014 7:18 AM
  • This worked and seemed to be the way of giving the account the least privileges:

    1) Create a new local user on DPM server and make sure it is not a member of any groups. We'll call it dpmserver\dpmsmtpacct.

    2) Give it "Allow Logon Locally" rights through Group Policy or Local Security Policy.

    3) In notifications options, type in dpmserver\dpmsmtpacct for account name and password you created for it.

    It looks like the only rights it needs is to log on locally.  Very poor documentation on this unfortunately.

    • Proposed as answer by JoelM7 Thursday, August 18, 2016 3:38 PM
    • Unproposed as answer by JoelM7 Thursday, August 18, 2016 3:39 PM
    • Proposed as answer by JoelM7 Thursday, August 18, 2016 3:39 PM
    Friday, April 15, 2016 11:19 PM
  • Hello JPUCB. I am trying to setup an smtp server (smtp.gmail.com) on DPM 2012 R2 but i am having the same problem. I was wondering if you could help me with this. The way I've configured the fields is the next:

    SMTP SERVER: ssl://smtp.gmail.com

    port: 465

    notification email: monitoreo@crefal.edu.mx

    username: monitoreo@crefal.edu.mx

    password: The password from the email address above...

    I am logged in the DPM server with an AD account which is ssinformatica. I has local administrator rights.

    Thursday, August 18, 2016 3:38 PM
  • Hello.

    I had same problem.  My resolve.

    I created local user on server with SC DPM and after i created user with same name and password on my email server .

    Friday, July 12, 2019 2:27 PM