locked
ActiveSync URL in xml response? RRS feed

  • Question

  • Hi all

    I have exch 2007 sp3 env. in win 2008 domain.

    the ActiveSync is published on ISA 2006, I have an issue where the ActiveSych Url retrived in the Autodiscover XML response is wrong?

    as shown below in the ExRCA test for ActiveSync AutoDiscover , the URL should be   mail.mydomain.com/Microsoft-Server-ActiveSync

    but it keeps retriving the shown below xyz one, where xyz is the old domain name where a migration was done to mydomain.com.

    My question is where this URL retrived from? ist ISA or AD or CAS or..?

    however the ActibeSync URL in  CAS server is set to the correct one.

    Thanks

    Attempting to send an Autodiscover POST request to potential Autodiscover URLs.
    
    
    
    ExRCA successfully retrieved Autodiscover settings by sending an Autodiscover POST.
    
    Test Steps
    
    ExRCA is attempting to retrieve an XML Autodiscover response from URL https://autodiscover.mydomain.com/AutoDiscover/AutoDiscover.xml for user YOUREMAIL@mydomain.com.
    
    The Autodiscover XML response was successfully retrieved.
    
    Additional Details
    
    
    Autodiscover Account Settings
    XML response:
    <?xml version="1.0"?>
    <Autodiscover xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns="http://schemas.microsoft.com/exchange/autodiscover/responseschema/2006">
     <Response xmlns="http://schemas.microsoft.com/exchange/autodiscover/mobilesync/responseschema/2006">
     <Culture>en:en</Culture>
     <User>
     <DisplayName>YourEmail</DisplayName>
     <EMailAddress>YourEmail@mydomain.com</EMailAddress>
     </User>
     <Action>
     <Settings>
     <Server>
     <Type>MobileSync</Type>
     <Url>https://mail.xyz.com/Microsoft-Server-ActiveSync</Url>
     <Name>https://mail.xyz.com/Microsoft-Server-ActiveSync</Name>
     </Server>
     </Settings>
     </Action>
     </Response>
    </Autodiscover>
     
    
    
    

    
    
    
    
    
    Sunday, June 17, 2012 6:28 AM

Answers

  • Hello,

    Check the ActieSync virtual directory via ADSIEDIT.

    It’s under:

    Administrative Group->Servers->ServerName->Protocols->Https

    Thanks,

    Simon

    Tuesday, June 19, 2012 6:47 AM

All replies

  • What do you see when you run:

    Get-ActiveSyncVirtualDirectory | FL Server,ExternalURL

    Based on what you see, you can use Set-ActiveSyncVirtualDirectory to fix the URLs.

    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."

    Sunday, June 17, 2012 1:37 PM
  • after running the command it shows the correc url

    Server      : CAS-gfr
    ExternalUrl : https://mail.mydomain.com/Microsoft-Server-ActiveSync

    and I tested the ActiveSync autodiscover again and it still gives the wrong url.

    Is there any other place that can affect this URL ???

    <Url>https://mail.xyz.com/Microsoft-Server-ActiveSync</Url>
    

    thanks
    Monday, June 18, 2012 4:48 AM
  • Sure, the InternalURL property, which applies to domain-joined machines.

    Get-ActiveSyncVirtualDirectory | FL Server,InternalURL,ExternalURL

    You didn't share the entire ActiveSync response.  The part under EXCH applies to internal domain-joined machines, EXPR applies to external or non-domain-joined machines, generally Outlook Anywhere clients.

    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."

    Monday, June 18, 2012 6:11 AM
  • thank you 4 ur reply

    I am sure that the internal and external url property are set correctly on CAS server.

    but how come it's retrieved in xml response to an old url !! is it possible that the publishing rule on ISA affecting this

    Noting that when running the outlook autodiscover the url is correct and running, the issue is only with activesynch autodiscover

    thanks

    Monday, June 18, 2012 10:50 AM
  • As far as I know the only reason an "old" URL would be in the response is because there's still a virtual directory configured with that URL.


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."

    Monday, June 18, 2012 6:50 PM
  • Hello,

    Check the ActieSync virtual directory via ADSIEDIT.

    It’s under:

    Administrative Group->Servers->ServerName->Protocols->Https

    Thanks,

    Simon

    Tuesday, June 19, 2012 6:47 AM