Very Very slow WDS pxe-process RRS feed

  • Question

  • Hello,

    when i try to deploy a VM using WDS/MDT the startup for contacting the WDS-server is very slow :

    The WDS-server is a Server2012R2 (not preview)-server. 

    I have reinstalled WDS already but nothing will help.

    Anybody with a solution?


    Tuesday, October 22, 2013 11:45 AM

All replies

  • Not sure, but how DHCP and gateway have same IP?

    Arnav Sharma | Facebook | Twitter Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Tuesday, October 22, 2013 12:47 PM
  • DHCP/Gateway is not problem. This wasn`t a problem in server2008r2. This is my router.

    This is the exact error which i can`t fix :

    Tuesday, October 22, 2013 12:58 PM
  • I have just created a seperate WDS-server on server 2008r2 instead of Server 2012R2.

    When booting from this servers within the SAME domain and SAME settings the PXE-boot is working!

    Why isn`t the pxe-boot working on server2012R2 :

    Tuesday, October 22, 2013 1:25 PM
  • On server2012R2 there is one extra tab on wds:

    0 en 512 are not working.

    Anybody with an option?


    Tuesday, October 22, 2013 1:35 PM
  • You can post this in server forums.

    Arnav Sharma | Facebook | Twitter Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Wednesday, October 23, 2013 2:54 PM
  • Problem solved by disabling "enable variable windows extension" and set the maximum block size to the maximum.
    • Marked as answer by Mvd12345 Thursday, October 24, 2013 6:45 AM
    • Unmarked as answer by Mvd12345 Friday, November 1, 2013 3:42 PM
    Thursday, October 24, 2013 6:45 AM
  • Bad Luck.

    Still having problems connecting to my server 2012R2 WDS-server.

    Same error as above.

    Anybody having a working situation with server2012-r2 and wds?

    With which settings?


    Saturday, October 26, 2013 9:51 PM
  • Still same issue on Server2012r2--> Failed to restart TFTP.

    When installing WDS on server2008R2 the start of PXE is fast and no errors.

    Howto fix this on server2012R2?


    Sunday, October 27, 2013 7:37 AM
  • Anybody?
    Sunday, October 27, 2013 6:34 PM
  • Anybody with an option?

    Still no solution here...

    Friday, November 1, 2013 3:43 PM
  • Enable WDS Server logging and report back.

    If that does not work, it could be your network is not forwarding the correct PXE requests.

    Can a computer on the same segment connect to the WDS Server? Or is it only computer on different segments.

    Finally, you could do some network sniffing :^

    Keith Garner -

    Monday, November 4, 2013 3:31 AM
  • Hi Keith,

    i have checked your options, but no extra info came out.

    When i enable the WDS-server on a Server 2008R2 with SAME settings, pxe boot is working ok from that server with the same cliënt.

    The only difference between server 2008R2 and Server2012R2 is the option "TFTP" --> "Blocksize" and "Variable Window Extension".

    I think the solution is in this part of WDS, but i didn`t find it.

    Monday, November 4, 2013 7:12 AM
  • Anybody?
    Wednesday, November 6, 2013 7:57 AM
  • As I understand you moved your WDS from server 2008 to server 2012. Did you move MDT stuff as well?
    Wednesday, November 6, 2013 2:35 PM
  • Hi,

    the location of the MDT-server doesn`t matter.

    A separate WDS server (2008R2) is working well, but wds in server2012R2 not..

    Wednesday, November 6, 2013 6:52 PM
  • If MDT doesn't matter why did you post under MDT forum? You should go to Server forum, no?


    OK check your Boot Server IP in your DHCP server:

    - Open your DHCP nodes
    - Go to Server Options container
    - Check the 066 Boot Server Host Name value

    Is there the IP of your Server 2012 WDS ?

    Thursday, November 7, 2013 6:43 AM
  • Hi Acetik,

    my DHCP-server is my router (not microsoft).

    This is working well for years (with Server2008 and Server2008R2) but not with Server2012r2.

    Thursday, November 7, 2013 7:06 AM
  • You should report in the server forum in my sense.
    Thursday, November 7, 2013 10:31 AM
  • I have just tested the following:

    1 MDT2013-server --> Using this litetouch.wim for all servers

    1 Server2008R2 --> No problem with PXE-boot

    1 Server2012--> Specified error from the beginning of this thread

    1 Server2012R2 --> Specified error from the beginning of this thread

    So, the problem is with server 2012 and server2012R2 pxe boot. The only difference in the Interface is the Tab "TFTP". But i didn`t find a solution. Anybody who can test this out?


    Thursday, November 7, 2013 12:56 PM
  • To make sure the router/dhcp-server isn`t the problem, i installed a Microsoft-DHCP-server and did a pxe boot.

    Still same problem :

    So what to now?

    Thursday, November 7, 2013 1:16 PM
  • There are two configuration options for Windows Deployment Services. It can be configured to integrate with Active Directory or be configured as a standalone server.

    May help you

    Thursday, November 7, 2013 2:47 PM
  • I have checked those settings, but these aren`t the problem. These settings are the same as on server 2008R2. From server2008R2 i do not have these pxe-boot problems.
    Thursday, November 7, 2013 2:51 PM
  • On the windows server2012R2 i have enabled ALL windows deployment services-logs (including verbose and admin).

    I can see a lot of traffic between cliënt and host, but i don`t see errors or maybe the problem.

    Only this error :

    [WDSServer] [base\eco\wds\wdsmgmt\src\wdsdirectoryservicesusepolicy.cpp:306] Expression: , Win32 Error=0x2

    Anybody with an option with this kind of logging?


    • Edited by Mvd12345 Thursday, November 7, 2013 3:32 PM
    Thursday, November 7, 2013 3:30 PM
  • We are here to assist you with guidance, if you are still having problems figuring out what the root cause is, then you might have better luck contacting Microsoft Product Support Services. It's good that you have enabled logs, but with timing issues, it's not necessarily the errors, but also the timeouts. What is causing the delay in response? It could be that the PXE server is trying to contact your DC, however your DC is overloaded, so it's slow in responding. For complex issues like this, there is no silver bullet.

    At this point, AcetiK  is correct, if the problem is that the PXE server is not responding, then this is *NOT* a MDT issue, this is a Windows Server WDS issue. Best to post on the Server aliases, or ask Microsoft Support.


    Keith Garner -

    Thursday, November 7, 2013 6:25 PM
  • anybody who did find a solution for this?

    PXE-boot from server2008 is working fast, and from server2012 not...

    Thursday, April 17, 2014 2:09 PM
  • If you are using SCCM 2012
    1. When using SCCM 2012 you just have to add the registry key to the site server and restart the WDS service:

    Name: RamDiskTFTPBlockSize
    Value: 16384 (change radio button to decimal)

    NOTE: It is highly recommend that you increase this setting in multiples of 4096, 8192, 16384, and so forth, but do not exceed a value higher than 16384 or this could cause corruption.

    Friday, March 6, 2015 4:51 PM
  • Take a netmon, it will tell you where we re stuck! make sure only one deployment is going on and collect the tracing from WDS server, if you can share it with me- i can give it a try. 

    Better if we do a port mirroring and look into traces from clients as well. 

    One thing though to check, have you configured TFTP options in DHCP? i.e. options 66 and 67 if your WDS and DHCP are on different subnet (sorry i read through complete thread but could not find one. ) also look at this:

    Mayank Sharma Support Engineer at Microsoft working in Enterprise Platform Support.

    Monday, March 9, 2015 9:21 AM