locked
Why does SharePoint Designer 2007 open from the Site Actions menu? RRS feed

  • Question

  • Hello,

    In all of the site collections in our SharePoint Server 2010 Farms open SharePoint Designer 2007 from the Site Actions menu when I select "Edit with SharePoint Designer".

    Can anyone direct me to what needs to be changed for have SharePoint Designer 2010 open when I select "Edit with SharePoint Designer" from teh Site Actions menu?

    Thanks in Advance.


    Tamara Bredemus SharePoint Minion...working up to Maven

    Tuesday, May 8, 2012 12:11 PM

Answers

  • You can't open and edit a SharePoint 2010 site in SPD 2007, even if you wanted to.  My follow-up question is after opening SPD 2010 from the start menu can you open the site you are trying to open from inside SPD 2010?  if you get the same error message then SharePoint support has been turned off either in Central Admin or in the Site Collection Site settings.  If you can open it in SPD 2010 then the problem is still that your web server options are pointing at SPD.  I assume you installed SPD 2007 first.  So its probably the setting picked up by IE first.  you may have to remove SPD 2007 and then make the changes in IE I mentioned.

    Assuming you can get into the site opening SPD from the start menu.


    Paul Stork SharePoint Server
    MVP Senior Solutions Architect: BlueChip Consulting Group
    Blog: http://dontpapanic.com/blog
    Twitter: Follow @pstork
    Please remember to mark your question as "answered" if this solves your problem.

    • Proposed as answer by Shimin Huang Monday, May 14, 2012 7:15 AM
    • Marked as answer by Shimin Huang Friday, May 18, 2012 6:09 AM
    Tuesday, May 8, 2012 7:57 PM

All replies

  • Open Internet Explorer and Access Tools > Internet Options.  Look for the Programs tab (it might be a slightly different tab name depending on your IE version).  On that tab there is a dropdown that specifies your default HTML editor.  I suspect yours is set to SPD 2007.  If you have SPD 2010 installed you should be able to change it there.  After that close and re-open your browser and the site actions menu should now start to use SPD 2010.

    Paul Stork SharePoint Server
    MVP Senior Solutions Architect: BlueChip Consulting Group
    Blog: http://dontpapanic.com/blog
    Twitter: Follow @pstork
    Please remember to mark your question as "answered" if this solves your problem.

    • Proposed as answer by Paul Turner _ Tuesday, May 8, 2012 12:28 PM
    Tuesday, May 8, 2012 12:24 PM
  • Thanks "Super Fast Answer Man" :)

    I followed your instructions and my Internet Options does have SPD set at the default HTML Editor, however, I think I failed to provide a key clue.

    When I try to open Designer from the browser, SPD 2007 tries to open, but I get this message:

    "This web site has been configured to disallow editing with SharePoint Designer. Contact your web site administrator for more information."

    I can open the site in SPD 2010 from the Start menu, but I prefer to open it from the browser.

    Hope this extra clue helps.

    Thanks again,


    Tamara Bredemus SharePoint Minion...working up to Maven

    Tuesday, May 8, 2012 2:31 PM
  • You can't open and edit a SharePoint 2010 site in SPD 2007, even if you wanted to.  My follow-up question is after opening SPD 2010 from the start menu can you open the site you are trying to open from inside SPD 2010?  if you get the same error message then SharePoint support has been turned off either in Central Admin or in the Site Collection Site settings.  If you can open it in SPD 2010 then the problem is still that your web server options are pointing at SPD.  I assume you installed SPD 2007 first.  So its probably the setting picked up by IE first.  you may have to remove SPD 2007 and then make the changes in IE I mentioned.

    Assuming you can get into the site opening SPD from the start menu.


    Paul Stork SharePoint Server
    MVP Senior Solutions Architect: BlueChip Consulting Group
    Blog: http://dontpapanic.com/blog
    Twitter: Follow @pstork
    Please remember to mark your question as "answered" if this solves your problem.

    • Proposed as answer by Shimin Huang Monday, May 14, 2012 7:15 AM
    • Marked as answer by Shimin Huang Friday, May 18, 2012 6:09 AM
    Tuesday, May 8, 2012 7:57 PM