locked
Formula in Custom Field gets strange values after saving RRS feed

  • Question

  • When I add a formula in a Custom Field then after saving and reopening the Custom Field the formula contains strange values ie:

     [MSPJ190873645] * 0.04 + [MSPJ190873643] * 0.06 + [MSPJ190873650] * 0.18 + [MSPJ190873649] * 0.1 + [MSPJ190873642] * 0.08 + [MSPJ190873641] * 0.12)

    All friendly Custom Field names have been replaced with intrinsic fieldnames and the Custom Field cannot be saved again. I wonder what goes wrong and how this can be fixed so that minor changes can easliy be applied.


    Frank Jutte Winvision (http://www.winvision.nl) Project Manager / EPM Consultant
    Thursday, May 27, 2010 8:06 PM

Answers

  • Thanks Marc. I tried to open Project Pro and then returning to PWA, unfortunately the intrinsic names still show up. Closing PWA and reopening it doesn't solve the problem either. Any other suggestions?
    Frank Jutte Winvision (http://www.winvision.nl) Project Manager / EPM Consultant
    Sunday, May 30, 2010 2:17 PM

All replies

  • Hi Frank,

     

    What you are seeing are the internal names for the custom fields. PWA tends to show those when it can't spin up the Project Professional client to validate the field names (things like it's not configured for the server, or there is an open dialog box will cause it).

    I take it your editing the fields in PWA and in Project Server 2007 (not sure I have been able to get this to occur in 2010)?

    Alex.


    Alex Burton www.epmsource.com
    Thursday, May 27, 2010 8:16 PM
  • Hi Frank, I've seen this in Project Pro 2007 a few times.   If I remember correctly, clearing the Enterprise Global template from the active cache fixed it. 
    Ben Howard [MVP] http://appleparkltd.spaces.live.com/
    Thursday, May 27, 2010 9:59 PM
  • Sorry I had to be more specific: I've seen this behaviour as well in 2007 but the example above is from PWA 2010. I tried to added formula and was able to save it, it also seems to work properly. The issue is that when I want to make adjustments tot the formula and open the CF the formula has these intrinsic names instead of the friendly names I type initialy. Saving the CF without any modifications results in an error: This formula contains references to one or more fields that do not exist in the system. Correct the formula and try again.

    The question is how to prevent changing the friendly names so that modifications can easily be made and saving doesn't result in an error.


    Frank Jutte Winvision (http://www.winvision.nl) Project Manager / EPM Consultant
    Friday, May 28, 2010 7:04 AM
  • Hi Frank,

    What you experience used to be an issue in Project Server 2007 prior to SP1. This has generally been fixed but somethimes I do experience this too event with the latest SP's and CU's.

    I am unsure to why you experience this issue, but the way I handle it is, when I open the formula field and I see that the formula is in non friendly text, I simply cancel the screen > Open Project Professional > return to PWA Server Settings and re-open the formula. Once I have done this the friendly name comes up and you can amend the formula.

    I hope this work around works for you too.


    Marc Soester [MVP]
    Saturday, May 29, 2010 2:00 AM
  • Thanks Marc. I tried to open Project Pro and then returning to PWA, unfortunately the intrinsic names still show up. Closing PWA and reopening it doesn't solve the problem either. Any other suggestions?
    Frank Jutte Winvision (http://www.winvision.nl) Project Manager / EPM Consultant
    Sunday, May 30, 2010 2:17 PM
  • As you build the formulas, copy them to another program so that if you move a formula from one field to another, the field name still works. If you need to modify the formula after you have closed it and the unfriendly fields appear, copy the friendly formula back into project before you start editing. Be sure to copy the modified version back to its safe location. I keep a copy of custom field codes in an Excel file that I use as my IMS Data Dictionary.
    Friday, July 2, 2010 5:33 PM