none
Ack Expected Interchange Status in Interchange/ACK Status in BizTalk 2006 RRS feed

  • Question

  • Gregarious greetings,

    We use BizTalk 2006 here at work.

    Specifically, we use the Version 3.6.2149.10 when I go to Help tab and choose About Microsoft BizTalk Server 2006 Administration.

    When I go to the Help tab and choose About Microsoft Management Console, I see the following:

    Microsoft Management Console 3.0

    Version 5.2 R2 (Build 3790.srv03_sp2_qfe.130703-1535 : Service Pack 2)

    Copyright 1985 - 2006 Microsoft Corporation

    I have been given the task to write some T-SQL so that we can create a SQL Agent job to monitor when we have not received 997 Functional Acknowledgement EDIs for EDIs that we have transmitted, for 850 Purchase Order EDIs and 860 Purchase Order Change EDIs and 824 Application Advice EDIs that we have transmitted.

    I am not asking help with the T-SQL.

    I am trying to understand why the testing 850 Purchase Order EDIs that we are sending (using the TESTING SQL Server database and the TESTING BizTalk 2006) have "Ack Not Expected" in the Interchange Status column when we have not yet sent testing 997 EDIs for them.

    In the Parties for this vendor, in EDI Properties, in the General tab we have checkmarks in the "Active EDI reporting" and "Store transaction set/payload for reporting" checkboxes. In the Edifact Properties section, in the property ACK Processing and Validation Settings, we have checkmarks in the "Functional ACK (Integrated with ACK Reporting)" and "EDI type" and "Extended validation" and "Allow leading and trailing zeroes and spaces" checkboxes. In the X12 Properties section, in the property ACK Processing and Validation Settings, also we have checkmarks in the "Functional ACK (Integrated with ACK Reporting)" and "EDI type" and "Extended validation" and "Allow leading and trailing zeroes and spaces" checkboxes.

    In the results of my T-SQL, I had planned to look for the value 500 in the isaStatusCode column but I see that these testing 850 EDIs that have not had 997 EDIs received for them all have the value 600 in the isaStatusCode column. From documentation on the Internet, the value 500 correlates to the "Ack Expected" status in the Interchange Status column of the Interchange/ACK Status within BizTalk and the value 600 correlates to the "Ack Not Expected" column of the Interchange/ACK Status within BizTalk.

    I will paste below my T-SQL just in case anybody would be interested.

    Could anybody advise why when a 850 Purchase Order EDI has been sent and received the value "Ack Not Expected" shows in the Interchange Status column of the Interchange/ACK Status report/tab? On the Group Hub tab, I clicked in the "EDI Status Reports" section the link named EDI Interchange and Correlated ACK Status.

    I just need to know how I can query the BizTalk database to know if we have not received a 997 EDI for an EDI that we have sent.

    Thanks very much in advance to anyone who answers.

    Witt

    By the way, I have tried researching on the Internet and here are a few examples of the URLs that I have read. No, I cannot put links in here until the forum is able to verify my account. The links are MSDN Microsoft links. I am removing the links now so that I can submit this question.  

    No, I removed the links but still when I try to click Submit it says in red font that body text cannot contain images or links until we are able to verify your account. I do not have any images in here, though I clicked on the Insert Code Block to insert below the SQL.

    Okay, I will remove the T-SQL to see if somehow it helps me to submit this question.

    Tuesday, March 3, 2015 8:28 PM

Answers

All replies

  • ACK not expected - This happens when you don't request a Technical ACK to be sent back. In this case if a TA1 comes back, then the status is updated otherwise it remains the same. Receipt of 997 does not have any effect on this field.

    Source from:

    https://social.msdn.microsoft.com/Forums/en-US/74809251-0ecb-494f-a3a9-cb25ac1530bf/bug-problem-with-edi-status-reporting-interchange-status-ack-not-expected?forum=biztalkediandas2

    Thursday, March 5, 2015 8:35 AM
  • Greetings Birdsven,

    I thank you very much for your reply.

    Do you have any ideas about how we can accomplish our goal of correlating 997s that we receive to the 850 and 860 and 824 EDIs that we have sent to know if we have not received a 997? Do you have any suggestions by chance on the easiest way to collect information about the 997s that we have received to try to match it against what we have sent using the BizTalk database(s)?

    I will click "Mark as answer" to your kind reply because you answered about how the "Ack Not Expected" concerns a technical ack rather than the functional 997 ack.

    Thank you again for replying. Please let me know if by chance you have any ideas or suggestions about how we can use BizTalk database(s) to collection information about the 997s that we have received and match it against the 850/860/824 EDIs that we have sent in order to know if we have not received a 997.

    Witt

    Thursday, March 5, 2015 2:47 PM