none
Hide open with access and export to excel buttons RRS feed

  • Question

  • Hi

    How can I disable Export to Excel and Open with Access buttons from ribbon for a list.

    I have a list of links and the user have right only to view the list. Everything is deactivated in the ribbon but only these 2 buttons are active: Export To Excel and Open with Access.

    Regards,

    Mihai

    Tuesday, January 8, 2013 8:42 PM

Answers

  • There is an alternative solution to remove the buttons, when permissions will not give this kind of control. The locations Ribbon.List.Actions.ExportToSpreadsheet and Ribbon.List.Actions.OpenWithAccess can be made hidden using an approach described in http://msdn.microsoft.com/en-us/library/ff408060(v=office.14).aspx


    SharePoint Developer | @zeemanj | Blog

    Tuesday, January 8, 2013 10:01 PM

All replies

  • You might be able to remove these by not granting this permission to the users: Use Client Integration Features. You can disable them from Site Actions > Site Permissions , Choose Permissions Levels from the ribbon. You will be able to add a new Permission Level or edit an existing one.

    SharePoint Developer | @zeemanj | Blog

    Tuesday, January 8, 2013 9:50 PM
  • Use Client Integration feature is disable for this users. The Only feature that they have is View List.

    Mihai

    Tuesday, January 8, 2013 9:52 PM
  • There is an alternative solution to remove the buttons, when permissions will not give this kind of control. The locations Ribbon.List.Actions.ExportToSpreadsheet and Ribbon.List.Actions.OpenWithAccess can be made hidden using an approach described in http://msdn.microsoft.com/en-us/library/ff408060(v=office.14).aspx


    SharePoint Developer | @zeemanj | Blog

    Tuesday, January 8, 2013 10:01 PM
  • In SharePoint 2013, click on the gear/sprocket icon in the upper right corner, then "Edit page." Click on "Add a Web Part." Click on the "Media and Content" Category, then the "Script Editor" Part. Add the following CSS in the Script Editor box:

    <style type="text/css">

    #Ribbon\.List\.Actions\.ExportToSpreadsheet-Large{display: none;}
    #Ribbon\.List\.Actions\.ExportToSpreadsheet-Medium{display: none;}
    #Ribbon\.List\.Actions\.ExportToSpreadsheet-Small{display: none;}

    #Ribbon\.List\.Actions\.OpenWithAccess-Large{display: none;}
    #Ribbon\.List\.Actions\.OpenWithAccess-Medium{display: none;}
    #Ribbon\.List\.Actions\.OpenWithAccess-Small{display: none;}

    </style>

    Click on the "Insert" button.

    Click on the "PAGE" tab, then "Stop Editing."

    If you end up with the BROWSE tab only (and not ITEMS and LIST), reload the page, then click somewhere in the white area on the screen to make the ITEMS and LIST tabs reappear. I'm using IE 11 if that makes a difference on this unusual behavior.

    • Proposed as answer by jm786876 Wednesday, September 30, 2015 3:15 PM
    Tuesday, May 20, 2014 12:12 AM
  • This works great. But like you say it does make the ITEMS and LIST tabs disappear.  Reloading the page and/or clicking all over the screen doesn't bring them back. 
    Wednesday, September 30, 2015 3:15 PM