locked
Non-Admin ActiveX-install, IE8 & WinXP vs Win7 RRS feed

  • Question

  • At a customer, we were validating Windows7 how it will work with our webpage-embedded ActiveX-controls ".

     

    It seems that at the customer site, the end-users on Windows 7 will not have administrative rights. In this case they will not have the appropriate rights to install an ActiveX control.

     

    The ActiveX-controls are packaged in a CAB-file, together with a configuration file. This configuration file foresees a deployment tag and by using the "InstallScope=user" option, we can install this ActiveX controls on user level.

     

    When we use the same installation on XP/IE8, it does not work anymore. We have to use the "InstallScope=user|machine". But this option seems to have the strange behavior on Windows 7 in the way that a selection popup is presentenced to the user to select an installation for one user or all users. This is something that we want to avoid

     

    Is there somewhere another solution to bypass this strange behavior?

    Thursday, January 19, 2012 3:51 PM

Answers

  • Maybe this info regarding ActiveX installer service and GPO settings can get it working as you want it, http://www.theexperienceblog.com/2007/10/10/windows-vista-activex-installer/. Note that the info was written for Vista and that in Windows 7 it works the same way only that the ActiveX Installer service now is installed by default, but you must enable it (set it to automatic startup).
    Blogging about Windows for IT pros at www.theexperienceblog.com

    • Marked as answer by Leo Huang Friday, February 24, 2012 2:28 AM
    Thursday, January 19, 2012 5:50 PM
  • The suggested solution with the ActiveX installer service and GPO settings solved our problem!

    Tx for the quick and very usefull response.

    Regards,
    Lieven

    • Marked as answer by Lieven Baert Thursday, January 26, 2012 7:01 AM
    Thursday, January 26, 2012 7:01 AM

All replies

  • Maybe this info regarding ActiveX installer service and GPO settings can get it working as you want it, http://www.theexperienceblog.com/2007/10/10/windows-vista-activex-installer/. Note that the info was written for Vista and that in Windows 7 it works the same way only that the ActiveX Installer service now is installed by default, but you must enable it (set it to automatic startup).
    Blogging about Windows for IT pros at www.theexperienceblog.com

    • Marked as answer by Leo Huang Friday, February 24, 2012 2:28 AM
    Thursday, January 19, 2012 5:50 PM
  • Hi Lieven Baert,

     

    Did your issue solved by the suggestion of Andreas Stenhall? Please feel free to give me any update.

     

    Thanks.

     

    Regards, 

    Leo   Huang

    TechNet Subscriber Support

    If you are TechNet Subscription user and have any feedback on our support quality, please send your feedback here.


    Leo Huang

    TechNet Community Support

    Monday, January 23, 2012 6:05 AM
  • We are testing this suggestion. Our packaging team is investigating this solution. I will come back to this thread to give you some feedback.

    Lieven

    Monday, January 23, 2012 7:31 AM
  • If you have tested the suggestion above, please feel free to let know if it works.

     

    Thank you for your cooperation.

     

    Regards,

    Leo   Huang

     

    TechNet Subscriber Support

    If you are TechNet Subscription user and have any feedback on our support quality, please send your feedback here.

     


    Leo Huang

    TechNet Community Support

    Tuesday, January 24, 2012 1:14 AM
  • The suggested solution with the ActiveX installer service and GPO settings solved our problem!

    Tx for the quick and very usefull response.

    Regards,
    Lieven

    • Marked as answer by Lieven Baert Thursday, January 26, 2012 7:01 AM
    Thursday, January 26, 2012 7:01 AM