none
How to disable the "Set as Desktop background"? RRS feed

  • Question

  • Kids in school are always looking to reset our desktops wallpaper with the latest picture they find on the internet. This is a distraction and I  want to know if the feature to disable saving things to the desktop in SteadyState can incorprate the feature "Set as Desktop background"  or make it a seperate check box so the desktop wallpaper can never be changed? 

     

    If you know of a sure  proof way to do this please let me know. I have successfully failed using the run as command and gpedit.msc and enabling the disable change desktop background. this feature is availbale when you right click on any image, we get a graphic properties menu with a fly out.

     

    Any ideas?

    Friday, August 3, 2007 4:32 PM

Answers

  • Hi Aredubbya,

     

    Although SteadyState doesn’t have an option to disable "Set as Desktop background" directly, there is an option to lock the user profile. If this option is selected, changes will be restored at the next logon.

     

    For your reference, we can disable "Set as Desktop background" with one of the following methods:

     

    For Windows XP Professional Edition:

    ---------------

    1. Click Start and then Run. Type "gpedit.msc" without quotes and press Enter.

    2. In Group Policy Editor, go to

     

    Local Computer Policy -> User Configuration -> Administrative Templates -> Control Panel -> Display

     

    3. Locate a setting named "Prevent Changing Wallpaper". Double click to open it.

    4. Select  Enable and click OK.

     

     

    For Windows XP Home Edition

    ---------------

    1. Click Start and then Run. Type "regedit" without quotes and press Enter.

    2. Navigate to the following branch:

     

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\ActiveDesktop

     

    3. Please check if there is the value: NoChangingWallPaper. If so, please double click it and then change its value to 1

     

    Note: If the value name doesn’t exist, we need to create it manually (Right click the blank space and choose New -> DWORD value)

     

    For your reference, you can also copy the following content to a Text Document, and then save it as an Reg file (such as NoChangingWallPaper.reg). Then we can double click the  reg file to import the content to registry:

     

    Windows Registry Editor Version 5.00

     

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\ActiveDesktop]

    "NoChangingWallPaper"=dword:00000001

     

    Best Regards,

     

    Monday, August 6, 2007 7:00 AM
  • You can lock the wallpaper to one of your choice, and this overrides any other settings a user uses.

    Run regedit.
    Navigate to HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System
    Look for a key called, wait for it, Wallpaper.

    If it doesn't exist, create a string with it.
    As the value, set it to the location (local or UNC) of your wallpaper image.

    That works
    Monday, November 19, 2007 8:10 PM
  • This is the method we eventually took, enabling the active desktop and then giving it a fake path for the background.

     

    when you enable active desktop it allows you to set an image as your desktop C:\ Windows\.... and once you find where the default desktop backgrounds you can set them as your default desktop background.

     

    For our lab if we chose the bliss.bmp file at active desktop, the background on the actual writing of all desktop icons (the writing that explains what it is i.e "Internet explorer ") suddenly acquired a blue background, which could not be removed through the performance tab when you right click on my computer propertires. So in the defining path to use the bliss.bmp as the default background, i just replaced the the word bliss with "???" an the background then suddenly matched the background of the writing attached to the icons, a dark blue colour. 

     

    Not a pretty solution but noone has succeessfully changed the desktop  to date now, so that part is good.

     

    Sunday, December 16, 2007 4:20 PM

All replies

  • Hi Aredubbya,

     

    Although SteadyState doesn’t have an option to disable "Set as Desktop background" directly, there is an option to lock the user profile. If this option is selected, changes will be restored at the next logon.

     

    For your reference, we can disable "Set as Desktop background" with one of the following methods:

     

    For Windows XP Professional Edition:

    ---------------

    1. Click Start and then Run. Type "gpedit.msc" without quotes and press Enter.

    2. In Group Policy Editor, go to

     

    Local Computer Policy -> User Configuration -> Administrative Templates -> Control Panel -> Display

     

    3. Locate a setting named "Prevent Changing Wallpaper". Double click to open it.

    4. Select  Enable and click OK.

     

     

    For Windows XP Home Edition

    ---------------

    1. Click Start and then Run. Type "regedit" without quotes and press Enter.

    2. Navigate to the following branch:

     

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\ActiveDesktop

     

    3. Please check if there is the value: NoChangingWallPaper. If so, please double click it and then change its value to 1

     

    Note: If the value name doesn’t exist, we need to create it manually (Right click the blank space and choose New -> DWORD value)

     

    For your reference, you can also copy the following content to a Text Document, and then save it as an Reg file (such as NoChangingWallPaper.reg). Then we can double click the  reg file to import the content to registry:

     

    Windows Registry Editor Version 5.00

     

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\ActiveDesktop]

    "NoChangingWallPaper"=dword:00000001

     

    Best Regards,

     

    Monday, August 6, 2007 7:00 AM
  •  

    For Windows XP Professional Edition:

     

    This does not work, even though in gpedit.msc you can enable the setting named "Prevent Changing Wallpaper", after do this I can go into any local account with limited priviliges, right click on any picture in my pictures and I get the menu option "set as desktop background". Back to square one.

     

    Is there a way to prevent users changing the desktop background?

     

    Rob

    Monday, November 12, 2007 2:21 AM
  • Hi Rob,

     

    Based on my test, the above group policy will disable the "Set as Background" option in IE, and also the related options in the Desktop Properties. The "Set as Desktop Background" option was provided some other programs such as Windows Picture and Fax Viewer. You can try the following steps to disable it:

     

    1. Click Start and then Run.

    2. Type in the following command and press Enter:

     

    regsvr32 /u shimgvw.dll

     

    3. Open "My Pictures" to test again. (To restore changes, run "regsvr32 shimgvw.dll")

     

    If Windows Picture and Fax Viewer is disabled, you may need to configure other program such as Paint or IE as the default picture program.

     

    Regards,

    Tuesday, November 13, 2007 1:58 AM
  • You can lock the wallpaper to one of your choice, and this overrides any other settings a user uses.

    Run regedit.
    Navigate to HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System
    Look for a key called, wait for it, Wallpaper.

    If it doesn't exist, create a string with it.
    As the value, set it to the location (local or UNC) of your wallpaper image.

    That works
    Monday, November 19, 2007 8:10 PM
  • Thanks for Paradox460's sharing!

     

    This configuration can also be found from the following group policy:

     

    Local Computer Policy -> User Configuration -> Administrative Templates -> Desktop -> Active Desktop: 'Active Desktop Wallpaper'

     

    Please understand that Active Desktop doesn't support Desktop Icons' Text Background Transparent feature. Thus the Desktop may seems a little ugly.

     

    Regards,

    Tuesday, November 20, 2007 2:28 AM
  • And can you,in more detail, walk me through that?

     

    Thursday, December 13, 2007 1:05 AM
  • For group policy method (Windows XP Professional Edition), I have included detailed steps below:

     

    1. Click Start and then Run.

    2. Type in gpedit.msc and click OK.

    3. In Group Policy Editor, go to

     

    Local Computer Policy -> User Configuration -> Administrative Templates -> Desktop -> Active Desktop

     

    4. In the right panel, double click 'Active Desktop Wallpaper' to open it.

    5. Select  Enable, configure a picture as wallpaper and choose the wallpaper style.

     

    Note: You may need to log off or restart to let it work.

     

    Regards,

     

    Thursday, December 13, 2007 9:03 AM
  • This is the method we eventually took, enabling the active desktop and then giving it a fake path for the background.

     

    when you enable active desktop it allows you to set an image as your desktop C:\ Windows\.... and once you find where the default desktop backgrounds you can set them as your default desktop background.

     

    For our lab if we chose the bliss.bmp file at active desktop, the background on the actual writing of all desktop icons (the writing that explains what it is i.e "Internet explorer ") suddenly acquired a blue background, which could not be removed through the performance tab when you right click on my computer propertires. So in the defining path to use the bliss.bmp as the default background, i just replaced the the word bliss with "???" an the background then suddenly matched the background of the writing attached to the icons, a dark blue colour. 

     

    Not a pretty solution but noone has succeessfully changed the desktop  to date now, so that part is good.

     

    Sunday, December 16, 2007 4:20 PM
  • You seem very knowledgeable so my I ask you a question? I have the opposite problem, when I right click on my desktop, choose properties and go to the Desktop tab, the 'browse' option is disabled.  I ran spybot and Norton but no virus - adware was detected.  Is there a way to fix this.  Many thanks and kind regards.

    d.

    Saturday, January 12, 2008 9:04 PM
  •  

    Hi,

     

    As I know, this issue is usually caused by spyware or virus. Please make sure the above options are not enabled. You can also try the following:

     

    Suggestion 1: Create a new user account to test.

     

    Suggestion 2: Delete Group Policies

    ===========

    1. Click "Start", go to "Run", type in "regedit" and press Enter.

    2. Locate the following key:

     

    [HKEY_LOCAL_MACHINE\Software\Policies\Microsoft]

     

    3. Highlight Microsoft and click "Delete".

    4. Please delete the following keys:

     

    [HKEY_CURRENT_USER\Software\Policies\Microsoft]

     

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Group Policy Objects]

     

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies

     

    Note: if some keys do not exist, please ignore them.

     

    Have a nice day!

     

    Regards,

    Monday, January 14, 2008 6:23 AM
  • Aredubbya your solution is very very good Smile I had the same problem until now Smile

     

    In GPO I changed:

    User Configuration\Administrative Templates\Control Panel\Display\Prevent changing wallpaper=Enabled
    but the usres can still change background with Windows picture and fax viewer.

     

    Solution:

    Now I set also GPO to this:

    User Configuration\Administrative Templates\Desktop\Active Desktop

    Policy Setting
    Active Desktop Wallpaper

    Enabled

    Wallpaper Name: ???
    Wallpaper Style: Stretch
    Policy Setting
    Disable Active Desktop

    Enabled

    And now users can not change background with "Windows pictures and fax viewer" and right click "Set as desktop background". The options is not grayed, but if user press it, it doesn't happen anything Smile Probably, If I would enable Active Desktop I would see this picture they are setting, but it is disabled, so everything looks totally normal :

     

     

    Thanks !

     

    ThomasV.

    technet.tomazv AT xoxy.net

    Friday, February 1, 2008 9:29 PM
  • I have a problem, I can not change the Background in the Desktop in the Display Properties. It looks like it is lock or disable. I need Enable. Do you know how to do?

    I am waiting for your anwers.

    Thank you

     

    Kemmy1

    Friday, May 30, 2008 4:47 AM
  • Hi Shawn,

     

    How do I enable this group policy for an entire group of users in AD?

     

    Friday, July 18, 2008 4:46 PM
  • Its  working,

     

     

    Thanks  Shawn Shao  MSFT

     

    Wednesday, October 22, 2008 6:32 PM
  • I have the same problem, but i running windows xp home edition, as this computer isn't connected to the network. Could anyone help? I have tryed what has already suggested but users can still right click in internet explorer and set as deskop background.
    Sunday, January 18, 2009 6:06 PM
  • This tip is excellent.
    Friday, April 17, 2009 6:23 AM
  • Hello There,

    I have a mandatory profile and would like to restrict users saving files in desktop, save picture as on desktop, set backgrond on desktop (restrict all change, cadd, modify) in dekstop and disable autohide taskbar. Can someone tell me the registry key for these to disable for users ?

    M

    Thursday, April 29, 2010 10:14 AM
  • hey ,

    Let me suggest a registry tweak to disable your desktop background buddy.

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Active Desktop

    Check its string value "Nochangingwallpaper" change its Dword accordingly.sometimes changing registry values is not good enough so better use tools which minimizes the efforts and are more safe.check advanced system optimizer.use its PC fixer amazing tool using it u can do many things like changing wallpaper and fix many problems like what if identical icons gets created on desktop etc.google! this tool or  can download from http://www.tucows.com/preview/284138/Advanced-System-Optimizer?q=advanced+system+optimizer . hi

    It has many other applications as well but pc fixer is the nicest among them as it fixes almost every problem.

     

    Thanks :-)

    Tuesday, July 13, 2010 9:32 AM