none
Desktop Folder Redirection - Path invalid error when typing path to new location for redirected desktops in Windows 7

    Question

  • I have an issue where I cannot recreate the path to redirect user desktops(Windows 7) to the following location on one of my file servers: \\poli-server3\Profile$\%username%-desktop. Redirected user desktops then get the folder name "jdoe-desktop" or "jsmith-desktop," etc. I have taken over a server support role from someone who created GPOs in our environment. The path above was added at some point to the GPO(see attachment #1), then it was removed and an alternate path was added to redirect desktops to another location on the server which worked fine. However, we wanted to redirect user's desktops back to the original path above and the GPMC says the path is invalid(see attachment #2)....at one point it was added when the GPO was first created and worked fine. Now we are stuck because we can’t use the original path. In ADUC for example, the %username% variable works for adding user profiles, and when I add the path above to start\run on the user's workstation it brings up the user’s desktop folder in Explorer....but the GPMC doesn't like the path. Any ideas? We are stuck in a corner. One option I have to recover is to restore the original GPO that has the original path \\poli-server3\Profile$\%username%-desktop...this works, but I am trying to figure out why %username%-desktop in the path is invalid when it was obviously added at one point. Also, if I want to move the these directories to a new location in the future I am stuck because I can’t add the "%username%-desktop" variable in the text box to point to a new location.

    thanks,

    Alex

    Error after typing in original location

    Original Location

    Thursday, January 21, 2016 1:24 AM

Answers

All replies

  • Change the target folder location from "Create a folder for each user"
    to "Redirect to the following location"... If the first option is
    selected, the Path must not contain user variables because this path is
    applied for ALL users.
     
    Thursday, January 21, 2016 9:38 AM
  • Unlike Windows 2000, you do not need to type in the %username% variable if you select "Create a folder for each user under the root path". The folder redirection code will automatically create a folder for each user, inside the parent folder based on their user name.
     
    So just prepare a root folder with correct NTFS permissions as descripted in the following article, then supply the root path in the group policy:
     
    https://msdn.microsoft.com/en-us/library/cc736916(v=ws.10).aspx
     
    Or as suggested by <Martin> above, choose "Redirect to the following location" instead.
     

    Regards,

    Ethan Hua


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com

    Friday, January 22, 2016 6:12 AM
    Moderator
  • Hi,
     
    Just checking in to see if above information was helpful. Please let us know if you would like further assistance.
     
    Thanks,
     

    Regards,

    Ethan Hua


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com

    Monday, January 25, 2016 2:17 AM
    Moderator
  • Hi,
     
    I'm marking the reply as answer as there has been no update for a couple of days.
     
    If you come back to find it doesn't work for you, please reply to us and unmark the answer.
     

    Regards,

    Ethan Hua


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com

    Friday, January 29, 2016 9:38 AM
    Moderator