locked
Sharepoint 2007 - how to open an EXCEL document on client if EXCEL Services are installed? RRS feed

  • Question

  • Hi,

    we have the Excel Services configured in SSP and activated on farm level.. that is fine, but now.. Sharepoint tries to open all excel documents in the browser instead of sending it to the client.

    This can easily be configured in SP2010 how Office documents are opened (Client or Server), but how can this be controlled with MOSS 2007? I actually do not need the Excelservices in this specific webapplication, so can it be disabled there?

    By the way: the site collection feature - Office Sharepoint Enterprise Site Collection Features - is deactived on Site Collection level.

    Thanks for info.

    Sven

    Wednesday, September 11, 2013 2:23 PM

Answers

  • Hi Daniel,

    sure - this setting is required, but it was already set in my environment. I found the solution to my issue and I never thought it would be this.

    The problem was that people with only read permission were not able to open .XSLX documents locally in their client application anymore. It always opened in the web browser.

    A base permission in permission level "READ" was missing. The base permission "Open items handler" was not checked.

    OpenItems => View the source of documents with server-side file handlers.

    In the browser it is the base permission "open items handler". If you check this box in the read permission then it works perfectly fine.

    Best Regards

    Sven

    Friday, September 13, 2013 7:05 AM

All replies

  • How can I competely remove the Excel services from a webapplication although it is enabled in SSP?
    There are really strange issues that are described here, too.

    http://social.msdn.microsoft.com/Forums/sharepoint/en-US/7ecad5fa-5b48-43bf-9006-b8e0904f926f/excel-file-always-opens-in-excel-services

    • If a user has read permissions he even cannot open the file in the client application. It will only open in the web browser and even this sometimes does not work if the excel file has some specific functions implemented.
    • A user with atleast contribute permissions can access the file with his client application.

    That means that users with read access cannot open the document anymore.

    =>> how to remove the Excel Services from that webapplication???

    • Edited by Sven W Thursday, September 12, 2013 8:10 AM
    Thursday, September 12, 2013 7:15 AM
  • Hi Sven,

    It should be unable to disable the Excel services from a web application.

    I tested that a viewer permission account click the the .xsl extension Excel file link, it will be opened in client application even if the library settings is set as "Display as a Web page".

    But viewer permission account can open .xslx extension Excel file in client application only when library set as "Open in the client application".

    So maybe only .xsl file will work for your requirement, and here is another similar post should be useful.

    http://sharepoint.stackexchange.com/questions/37785/excel-web-access-not-disabled

    Thanks


    Daniel Yang
    TechNet Community Support

    Thursday, September 12, 2013 9:48 AM
    Moderator
  • Hi Daniel,

    thanks for your post, but that does not solve my issue:

    Turns out this was about permissions. When a user is granted only the read (view only) permission in SharePoint this forces the user to use the Excel calculation services. The only way around this is to grant the user at least the contribute permission. In my case this wasnt possible as these were anonymous users. The only 'fix' I found was a workaround, instead of uploading a .xlsx file you upload a .xls file and all is well.

    It does not make sense to save documents in the year 2013 as xls just to avoid this issue.

    Is it somehow possible to force even XSLX documents to be opened in client application even if the user only has read access?

    Best Regards

    Sven

    Thursday, September 12, 2013 10:56 AM
  • Hi Sven,

    The "Open in the client application" option needs to be enabled for the library, then the XSLX documents will be opened in client application when a viewer permission click the file link.

    Thanks


    Daniel Yang
    TechNet Community Support

    Friday, September 13, 2013 3:53 AM
    Moderator
  • Hi Daniel,

    sure - this setting is required, but it was already set in my environment. I found the solution to my issue and I never thought it would be this.

    The problem was that people with only read permission were not able to open .XSLX documents locally in their client application anymore. It always opened in the web browser.

    A base permission in permission level "READ" was missing. The base permission "Open items handler" was not checked.

    OpenItems => View the source of documents with server-side file handlers.

    In the browser it is the base permission "open items handler". If you check this box in the read permission then it works perfectly fine.

    Best Regards

    Sven

    Friday, September 13, 2013 7:05 AM
  • Hi Sven,

    I'm glad to hear that you found the solution, and thank you for sharing what you found.

    Thanks


    Daniel Yang
    TechNet Community Support

    Friday, September 13, 2013 7:40 AM
    Moderator