none
Autocomplete clearing on exit (Outlook 2013 on Exchange 2010).

    Question

  • I have one user whose autocomplete cache is not working. I was thinking it was possibly an Outlook profile corruption issue (as use of the Autocomplete Cache is enabled in the Outlook options), however the entries don't show up in OWA, either.

    SERVER: Microsoft Exchange 2010 SP3
    CLIENT: Outlook 2013
    CACHED EXCHANGE MODE: No

    I'm not sure what all to check. Everything seems to work (remembering entries) until Outlook is closed. The next time it's opened anything that was previously saved is gone.

    Wednesday, April 04, 2018 7:38 PM

Answers

  • I may have it resolved, though not entirely to the user's satisfaction.

    Since the mailbox repair script did not give him his items back, and no new items could be created, I decided to just use the /cleanautocompletecache switch to delete whatever was on the server. Doing this allowed me to add entries to the cache that persisted through closing/restarting Outlook. He has to start over again, but at least it's (hopefully) one time, rather than every day or two.

    Monday, April 16, 2018 7:50 PM

All replies

  • Hi,

    The AutoComplete cache in OWA is separate from it in Outlook client, thus I want to ensure whether it works in OWA or not.

    From your description, I notice that the AutoComplete cache in Outlook works when Outlook opens, and it is cleared after Outlook restarts.
    Can you reproduce it in other Outlook client (other PC)?

    If it only occurs on one special Outlook client, check the Properties of this shortcut and ensure it's not Outlook.exe /CleanAutoCompleteCache. Also, run Outlook with safe mode to test.

    Unless, we may need to repair this effect mailbox by New-MailboxRepairRequest, for example:
    New-MailboxRepairRequest <Mailbox> -CorruptionType SearchFolder,AggregateCounts,ProvisionedFolder,FolderView

    Best Regards,
    Allen Wang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Thursday, April 05, 2018 9:39 AM
    Moderator
  • The mailbox repair request did the trick. He has to rebuild from scratch again, but at least he isn't losing his progress every day. Thanks!
    Monday, April 09, 2018 2:58 PM
  • Thanks for your update.

    Best Regards,
    Allen Wang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Tuesday, April 10, 2018 1:48 AM
    Moderator
  • Looks like I spoke too soon. Today the entries he'd created in Outlook yesterday are gone again.

    I did confirm that his Outlook shortcut was just to outlook.exe and had no switches.

    Tuesday, April 10, 2018 12:29 PM
  • OK, can he reproduce this issue on other PC?
    If it only occurs on one special Outlook client, try to run "Outlook /safe" mode to add nickname cache and reopen it again for testing.
    Also, to prevent other application effect, try to run Windows with clean boot.

    Best Regards,
    Allen Wang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Wednesday, April 11, 2018 1:57 AM
    Moderator
  • Any further help we can do for you?
    If this issue has been solved, would you please post the solution here to share it with us? Thanks.

    Best Regards,
    Allen Wang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Monday, April 16, 2018 1:50 AM
    Moderator
  • Sorry, I've been out of the office for a few days.

    I have confirmed that the autocomplete does not work even in another Outlook installation.  I set up a profile to check his mailbox on my desktop and the autocomplete cache does not persist after closing Outlook and restarting it. It works fine in my profile.

    Monday, April 16, 2018 6:45 PM
  • I may have it resolved, though not entirely to the user's satisfaction.

    Since the mailbox repair script did not give him his items back, and no new items could be created, I decided to just use the /cleanautocompletecache switch to delete whatever was on the server. Doing this allowed me to add entries to the cache that persisted through closing/restarting Outlook. He has to start over again, but at least it's (hopefully) one time, rather than every day or two.

    Monday, April 16, 2018 7:50 PM
  • Great, thanks for your update and sharing.
    Please mark your reply as answer.

    Best Regards,
    Allen Wang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Tuesday, April 17, 2018 3:29 AM
    Moderator