locked
ESD Decryption Patch RRS feed

  • Question

  • Hi People,

    I'm having all kinds of trouble installing this 'ESD Decryption provision in WSUS in Windows Server 2012' patch on my server.

    My WSUS Server

    2012 R2
    SQL Server 2014 as the DB engine
    All patched up to date

    When I run the command suggested;

    “C:\Program Files\Update Services\Tools\wsusutil.exe” postinstall /servicing

    It throws this error;

    --------------------------------------------------

    PS C:\Program Files\Update Services\Tools> .\wsusutil.exe postinstall SQL_INSTANCE_NAME="SWS-WSUS\SQLEXPRESS" CONTENT_DIR=D:\WSUS /Servicing
    Log file is located at C:\Users\xxxxxx\AppData\Local\Temp\tmpF651.tmp
    Post install is starting
    Fatal Error: User does not have permission to alter database 'SUSDB', the database does not exist, or the database is not
    in a state that allows access checks.

    ALTER DATABASE statement failed.

    ---------------------------------------------------

    Cant find anything on the net regarding this error so does anyone have any ideas?.

    Thanks in advance.

    Tuesday, June 21, 2016 11:46 AM

Answers

  • Hi timbo dude,

    1. What is the account when you do the steps? Please use Administrator account.

    2. Try restart the database, check if it could work.

    3. If after doing several things, it still doesn't work, I would suggest reinstalling the WSUS server with a new database.

    Best Regards,

    Anne


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.


    Wednesday, June 22, 2016 8:20 AM