locked
Alerts not working for a single site collection RRS feed

  • Question

  • Hello all. I'm having a rather interesting problem with SharePoint alerts. They work fine for every site collection I've tested....except for one! And this one happens to be a major project so I'm in a major pickle.

    Background info: This one site collection (hereby referred to as problem child) is in the same web application as the other sites that do work. However, Problem Child has its own content database with about 42GB of data. This isn't limited to one person or type of alert. None work on this site. There are less than 100 alerts set up so they haven't reached a threshold. I've run the stsadm setproperty to no avail which isn't surprising because all of the other site collections are alerting fine.

    Has anyone else experienced this issue? I'm really at a lost here. Any help is appreciated.

    Friday, March 4, 2011 5:15 AM

Answers

  • Hi,

    Try the below stsadm commands for the particular site collection in which you find the alerts missing.

    stsadm -o setproperty -propertyname alerts-enabled -propertyvalue false -url  <site collection url>

    stsadm  -o setproperty -propertyname alerts-enabled -propertyvalue true -url <site collection url>

    stsadm  -o setproperty -propertyname job-immediate-alerts -propertyvalue "every 5 minutes"  -url <site collection url>

    This will toggle alert for that site collection

    Please let us know if this will be helpful


    Regards, Pratik Vyas | SharePoint Consultant | http://sharepointpratik.blogspot.com/
    • Marked as answer by Leoyi Sun Monday, March 14, 2011 5:42 AM
    Friday, March 4, 2011 9:11 AM
  • I would suggest to get these properties at first (i.e. use stsadm -o getproperty ...) in order to check the current values before to make any changes which can be unnecessary.

    Also I would suggest to check Sharepoint logs (12/Logs) - often they contain information that alerts were security trimmed and other useful information regarding alerts.


    Blog - http://sadomovalex.blogspot.com
    CAML via C# - http://camlex.codeplex.com
    • Marked as answer by Leoyi Sun Monday, March 14, 2011 5:42 AM
    Friday, March 4, 2011 1:27 PM

All replies

  • Hi,

    Try the below stsadm commands for the particular site collection in which you find the alerts missing.

    stsadm -o setproperty -propertyname alerts-enabled -propertyvalue false -url  <site collection url>

    stsadm  -o setproperty -propertyname alerts-enabled -propertyvalue true -url <site collection url>

    stsadm  -o setproperty -propertyname job-immediate-alerts -propertyvalue "every 5 minutes"  -url <site collection url>

    This will toggle alert for that site collection

    Please let us know if this will be helpful


    Regards, Pratik Vyas | SharePoint Consultant | http://sharepointpratik.blogspot.com/
    • Marked as answer by Leoyi Sun Monday, March 14, 2011 5:42 AM
    Friday, March 4, 2011 9:11 AM
  • I would suggest to get these properties at first (i.e. use stsadm -o getproperty ...) in order to check the current values before to make any changes which can be unnecessary.

    Also I would suggest to check Sharepoint logs (12/Logs) - often they contain information that alerts were security trimmed and other useful information regarding alerts.


    Blog - http://sadomovalex.blogspot.com
    CAML via C# - http://camlex.codeplex.com
    • Marked as answer by Leoyi Sun Monday, March 14, 2011 5:42 AM
    Friday, March 4, 2011 1:27 PM
  • Here is an article explaining the things to look at and fix.

    http://dzeee.net/sharepoint/post/2010/01/17/Alerts-not-working.aspx

    Thanks,
    Dip


    Dip
    http://dzeee.net/sharepoint
    Friday, March 4, 2011 11:37 PM