locked
Can't browse Internet zone when protected mode is ON RRS feed

  • Question

  • Hi,

    Since a few days back a strange problem started ocurring for some users in our domain. Some have IE9 others like me have IE11. Problem is that IE can't browse Internet pages (it just keep loading with the white screen) when Protected mode is ON. Previously there was no problem with this. Other browsers don't have this issue. OS in the company is Win7.

    Thank you.

    Leo.

    Thursday, August 13, 2015 4:19 PM

Answers

  • Hi Leo,

    Could you please include a link(s) (copied from the IE Address bar) to any website you are having problems with, in your questions. This will enable us to visit the sites to make some tests and guesses.

    Protected Mode, on Win7 forces the IE tab process to use a x64 process, so x86 activex controls will not run and are blocked.

    For IE11/Win7 there is also ActiveX filtering which will stop x86 or x64 ActiveX controls from running.

    IE11 also has depreciated the ActiveXControl object which some sites may use for feature detection. From memory, I don't think IE9 had ActiveX filtering, but there are Addons for all versions of IE (Flash block for example) that have a similar functionality. Use Tools>Manage Addons>Show all Addons to locate and find the properties of your installed ActiveX controls and whether or not they have been disabled.

    So I await your re-post with some sample web addresses where the problem is occurring.

    Also, the first step in troubleshooting web browser issues is to test in noAddons mode


    Rob^_^

    Friday, August 14, 2015 12:14 AM

All replies

  • Hi Leo,

    Could you please include a link(s) (copied from the IE Address bar) to any website you are having problems with, in your questions. This will enable us to visit the sites to make some tests and guesses.

    Protected Mode, on Win7 forces the IE tab process to use a x64 process, so x86 activex controls will not run and are blocked.

    For IE11/Win7 there is also ActiveX filtering which will stop x86 or x64 ActiveX controls from running.

    IE11 also has depreciated the ActiveXControl object which some sites may use for feature detection. From memory, I don't think IE9 had ActiveX filtering, but there are Addons for all versions of IE (Flash block for example) that have a similar functionality. Use Tools>Manage Addons>Show all Addons to locate and find the properties of your installed ActiveX controls and whether or not they have been disabled.

    So I await your re-post with some sample web addresses where the problem is occurring.

    Also, the first step in troubleshooting web browser issues is to test in noAddons mode


    Rob^_^

    Friday, August 14, 2015 12:14 AM
  • Other browsers don't have this issue.

    Other browsers don't use Protected Mode so turn off Protected Mode (or use the Trusted Sites zone so you don't affect all your Internet browsing).  Another option would be running iexplore.exe elevated.  That would turn off Protected Mode too but then give your problem site even more authority than might be necessary to just be running as "other browsers" (since typically they are not run elevated).


    Robert Aldwinckle
    ---

    Thursday, September 10, 2015 3:38 PM
    Answerer