locked
MDT v8443 - Not honouring Timezone? RRS feed

  • Question

  • I have managed to get the Deployment process to default to my Timezone (Aus Eastern Standard Time) by adding

    TimeZoneName=AUS Eastern Standard Time

    To the deployment share rules (aka customesettings.ini) but it is not being honoured by the OS deployment.  My current workaround is to set it explicitly in the TS by adding a powershell script (set-MyTimezone.ps1).

    Contents:

    Set-Timezone -Id "AUS Eastern Standard Time"

    Any fix for setting from the rules? 

     

    Monday, February 27, 2017 2:16 AM

All replies

  • Try using TimeZone=255 and see if that works.

    Monday, February 27, 2017 9:59 PM
  • Thanks, I tried it, but it didn't work.

    Why "TimeZone=255" ?  I haven't seen that value anywhere in relation to the "Aus Eastern Standard" time zone.

    Wednesday, March 1, 2017 2:11 AM
  • Is everything else in the customsettings.ini being used? 

    Have you tried setting the timezone in the unattend.xml file?

    Wednesday, March 1, 2017 9:48 PM
  • Yes, tried that. Not being picked up.

    Followed the same format that was in there already in "name of timezone" format and I updated it to the timezone I wanted.

    BTW: Thanks for the pointer to the MSDN "Microsoft Time Zone Index Values" table.  I hadn't found it in my searches.

    Friday, March 3, 2017 1:12 AM
  • Some setting working in the customsettings.ini and some aren't.

    As a general pattern it seems I can switch panels off, but can't switch them on.  Putting the desired at top of list, but switching everywhere doesn't change it either.  Seems to be following first writer wins in rules (when it does work).

    User locale information is always locked, but I can change the value of fields that are greyed out by setting individual fields in the customsettings.ini.

    Some examples......

    Not working
      SkipPackageDisplay=NO
      TimeZone=AUS Eastern Standard Time
      TimeZoneName=AUS Eastern Standard Time
      UILanguage=en-AU
      UserLocale=en-AU
      Systemlocale=en-AU

    Working
      SkipBitLocker=YES
      Joindomain=basscoast.vic.gov.au
      MachineObjectOU=OU=Workstations,DC=Not,DC=Real,DC=org,DC=au
      DomainOUs1=OU=Workstations,DC=Not,DC=Real,DC=org,DC=au
      DomainOUs2=CN=Computers,DC=Not,DC=Real,DC=org,DC=au
      DomainOUs3=OU=Workstations,OU=Archived,DC=Not,DC=Real,DC=org,DC=au

    Friday, March 3, 2017 1:37 AM