none
OSD not working after SCCM 2012 SP1 Upgrade

    Question

  • I have recently upgraded my SCCM 2012 RTM to SP1 and since then I have had a number of issues. Software Updates stopped working but this has been resolved, but now OSD no longer works either.

    I get the error 0x80091007.

    I have removed all content from the distribution point and redistributed it, but I still get the same error each time. I have tried this on more than 1 PC so it is not a hardware issue.

    Any suggestions would be appreciated.

    Thanks

    Richard

    Tuesday, February 19, 2013 4:31 PM

All replies

  • The error 0x80091007 typically corresponds to the client not being able to verify the hash.  What step is it on when it throws this error?  I would suggest you update the deployment type or package that is used for that step.

    Try it again after doing the update, and if it still fails, post the last part of your smsts.log and cas.log.

     

    I hope that helps!

     

    Nash


    Nash Pherson, Senior Systems Consultant
    Now Micro - My Blog Posts
    <-- If this post was helpful, please click "Vote as Helpful".

    Tuesday, February 19, 2013 4:59 PM
  • It gets to the point where it tries to open a multicast session with http://servername/smspkgig and then fails with the error code.

    I have removed and readded the image it is looking for to the distriubution point. I have deleted and remade the task sequence several times.

    I will try and get a copy of the log.

    Thanks

    Richard


    Wednesday, February 20, 2013 11:14 AM
  • So if i get this right, you get the error when the bootimage is downloaded yes? 

    Ive heard stories about the ADK update failing to alter the default boot images in SCCM and that some have been forced to copy the boot WIM files from the ADK folder and re-import them. 



    - Stress is the confusion created in one's mind, to override the basic desire to choke the living %&¤# out of someone, who deserves it the most. Twitter: http://twitter.com/#!/@henrikhoe


    Wednesday, February 20, 2013 11:51 AM
  • <![LOG[Installation of image 2 in package MP100025 failed to complete..
    The hash value is not correct. (Error: 80091007; Source: Windows)]LOG]!><time="12:09:47.663+00" date="02-20-2013" component="ApplyOperatingSystem" context="" type="3" thread="1460" file="installimage.cpp:1732">
    <![LOG[installer.install(), HRESULT=80091007 (e:\nts_sccm_release\sms\client\osdeployment\applyos\installimage.cpp,1787)]LOG]!><time="12:09:47.663+00" date="02-20-2013" component="ApplyOperatingSystem" context="" type="0" thread="1460" file="installimage.cpp:1787">
    <![LOG[Entering ReleaseSource() for C:\_SMSTaskSequence\Packages\MP100025]LOG]!><time="12:09:47.663+00" date="02-20-2013" component="ApplyOperatingSystem" context="" type="1" thread="1460" file="resolvesource.cpp:3616">
    <![LOG[The user tries to release a source directory C:\_SMSTaskSequence\Packages\MP100025 that is either already released or we have not connected to it]LOG]!><time="12:09:47.663+00" date="02-20-2013" component="ApplyOperatingSystem" context="" type="2" thread="1460" file="resolvesource.cpp:3666">
    <![LOG[InstallImage( g_InstallPackageID, g_ImageIndex, targetVolume, ImageType_OS, g_ConfigPackageID, g_ConfigFileName, bOEMMedia, g_RunFromNet ), HRESULT=80091007 (e:\nts_sccm_release\sms\client\osdeployment\applyos\applyos.cpp,509)]LOG]!><time="12:09:47.912+00" date="02-20-2013" component="ApplyOperatingSystem" context="" type="0" thread="1460" file="applyos.cpp:509">
    <![LOG[Process completed with exit code 2148077575]LOG]!><time="12:09:47.912+00" date="02-20-2013" component="TSManager" context="" type="1" thread="1092" file="commandline.cpp:1123">
    <![LOG[!--------------------------------------------------------------------------------------------!]LOG]!><time="12:09:47.912+00" date="02-20-2013" component="TSManager" context="" type="1" thread="1092" file="instruction.cxx:3012">
    <![LOG[Failed to run the action: Apply Operating System.
    The hash value is not correct. (Error: 80091007; Source: Windows)]LOG]!><time="12:09:47.912+00" date="02-20-2013" component="TSManager" context="" type="3" thread="1092" file="instruction.cxx:3103">
    <![LOG[MP server http://AS024.smd.swanseamet.ac.uk. Ports 80,443. CRL=false.]LOG]!><time="12:09:47.912+00" date="02-20-2013" component="TSManager" context="" type="1" thread="1092" file="utils.cpp:5300">
    <![LOG[Setting authenticator]LOG]!><time="12:09:47.928+00" date="02-20-2013" component="TSManager" context="" type="1" thread="1092" file="utils.cpp:5322">
    <![LOG[Set authenticator in transport]LOG]!><time="12:09:47.928+00" date="02-20-2013" component="TSManager" context="" type="0" thread="1092" file="libsmsmessaging.cpp:7751">
    <![LOG[Sending StatusMessage]LOG]!><time="12:09:47.928+00" date="02-20-2013" component="TSManager" context="" type="1" thread="1092" file="libsmsmessaging.cpp:4025">
    <![LOG[Setting message signatures.]LOG]!><time="12:09:47.944+00" date="02-20-2013" component="TSManager" context="" type="0" thread="1092" file="libsmsmessaging.cpp:1297">
    <![LOG[Setting the authenticator.]LOG]!><time="12:09:47.944+00" date="02-20-2013" component="TSManager" context="" type="0" thread="1092" file="libsmsmessaging.cpp:1327">
    <![LOG[CLibSMSMessageWinHttpTransport::Send: URL: AS024.smd.swanseamet.ac.uk:80  CCM_POST /ccm_system/request]LOG]!><time="12:09:47.944+00" date="02-20-2013" component="TSManager" context="" type="1" thread="1092" file="libsmsmessaging.cpp:8621">
    <![LOG[Request was succesful.]LOG]!><time="12:09:47.944+00" date="02-20-2013" component="TSManager" context="" type="0" thread="1092" file="libsmsmessaging.cpp:8956">
    <![LOG[Set a global environment variable _SMSTSLastActionRetCode=-2146889721]LOG]!><time="12:09:47.944+00" date="02-20-2013" component="TSManager" context="" type="0" thread="1092" file="executionenv.cxx:668">
    <![LOG[Set a global environment variable _SMSTSLastActionSucceeded=false]LOG]!><time="12:09:47.944+00" date="02-20-2013" component="TSManager" context="" type="0" thread="1092" file="executionenv.cxx:668">
    <![LOG[Clear local default environment]LOG]!><time="12:09:47.944+00" date="02-20-2013" component="TSManager" context="" type="0" thread="1092" file="executionenv.cxx:807">
    <![LOG[Let the parent group (Install Operating System) decides whether to continue execution]LOG]!><time="12:09:47.959+00" date="02-20-2013" component="TSManager" context="" type="0" thread="1092" file="instruction.cxx:3212">
    <![LOG[The execution of the group (Install Operating System) has failed and the execution has been aborted. An action failed.
    Operation aborted (Error: 80004004; Source: Windows)]LOG]!><time="12:09:47.959+00" date="02-20-2013" component="TSManager" context="" type="3" thread="1092" file="instruction.cxx:2425">
    <![LOG[Failed to run the last action: Apply Operating System. Execution of task sequence failed.
    The hash value is not correct. (Error: 80091007; Source: Windows)]LOG]!><time="12:09:47.959+00" date="02-20-2013" component="TSManager" context="" type="3" thread="1092" file="engine.cxx:214">
    <![LOG[MP server http://AS024.smd.swanseamet.ac.uk. Ports 80,443. CRL=false.]LOG]!><time="12:09:47.959+00" date="02-20-2013" component="TSManager" context="" type="1" thread="1092" file="utils.cpp:5300">
    <![LOG[Setting authenticator]LOG]!><time="12:09:47.975+00" date="02-20-2013" component="TSManager" context="" type="1" thread="1092" file="utils.cpp:5322">
    <![LOG[Set authenticator in transport]LOG]!><time="12:09:47.975+00" date="02-20-2013" component="TSManager" context="" type="0" thread="1092" file="libsmsmessaging.cpp:7751">
    <![LOG[Sending StatusMessage]LOG]!><time="12:09:47.975+00" date="02-20-2013" component="TSManager" context="" type="1" thread="1092" file="libsmsmessaging.cpp:4025">
    <![LOG[Setting message signatures.]LOG]!><time="12:09:47.990+00" date="02-20-2013" component="TSManager" context="" type="0" thread="1092" file="libsmsmessaging.cpp:1297">
    <![LOG[Setting the authenticator.]LOG]!><time="12:09:47.990+00" date="02-20-2013" component="TSManager" context="" type="0" thread="1092" file="libsmsmessaging.cpp:1327">
    <![LOG[CLibSMSMessageWinHttpTransport::Send: URL: AS024.smd.swanseamet.ac.uk:80  CCM_POST /ccm_system/request]LOG]!><time="12:09:47.990+00" date="02-20-2013" component="TSManager" context="" type="1" thread="1092" file="libsmsmessaging.cpp:8621">
    <![LOG[Request was succesful.]LOG]!><time="12:09:47.990+00" date="02-20-2013" component="TSManager" context="" type="0" thread="1092" file="libsmsmessaging.cpp:8956">
    <![LOG[Executing command line: X:\WINDOWS\system32\cmd.exe /k]LOG]!><time="12:09:50.190+00" date="02-20-2013" component="TSBootShell" context="" type="1" thread="792" file="bootshell.cpp:857">
    <![LOG[The command completed successfully.]LOG]!><time="12:09:50.190+00" date="02-20-2013" component="TSBootShell" context="" type="1" thread="792" file="bootshell.cpp:939">
    <![LOG[Successfully launched command shell.]LOG]!><time="12:09:50.190+00" date="02-20-2013" component="TSBootShell" context="" type="1" thread="792" file="bootshell.cpp:430">
    <![LOG[Execution::enExecutionFail != m_eExecutionResult, HRESULT=80004005 (e:\nts_sccm_release\sms\client\tasksequence\tsmanager\tsmanager.cpp,866)]LOG]!><time="12:09:52.780+00" date="02-20-2013" component="TSManager" context="" type="0" thread="1092" file="tsmanager.cpp:866">
    <![LOG[Task Sequence Engine failed! Code: enExecutionFail]LOG]!><time="12:09:52.780+00" date="02-20-2013" component="TSManager" context="" type="3" thread="1092" file="tsmanager.cpp:866">
    <![LOG[****************************************************************************]LOG]!><time="12:09:52.780+00" date="02-20-2013" component="TSManager" context="" type="1" thread="1092" file="tsmanager.cpp:889">
    <![LOG[Task sequence execution failed with error code 80004005]LOG]!><time="12:09:52.780+00" date="02-20-2013" component="TSManager" context="" type="3" thread="1092" file="tsmanager.cpp:890">
    <![LOG[Cleaning Up.]LOG]!><time="12:09:52.780+00" date="02-20-2013" component="TSManager" context="" type="1" thread="1092" file="tsmanager.cpp:637">
    <![LOG[Removing Authenticator]LOG]!><time="12:09:52.780+00" date="02-20-2013" component="TSManager" context="" type="1" thread="1092" file="tsmanager.cpp:648">
    <![LOG[shKey.DeleteValue( c_szRegValue_SecurityToken ), HRESULT=80070002 (e:\nts_sccm_release\sms\framework\ccmutillib\ccmutillib.cpp,1652)]LOG]!><time="12:09:52.780+00" date="02-20-2013" component="TSManager" context="" type="0" thread="1092" file="ccmutillib.cpp:1652">

    Here is a portion of the SMSTS.log

    Wednesday, February 20, 2013 1:12 PM
  • I have compeltely removed all operating systems images from SCCM and added them back in, redistributed them to the DP's and recreated the Task sequences.

    It is still failing at the same spot, any suggestions would be greatly appreciated.

    Thanks

    Richard

    Thursday, February 21, 2013 12:38 PM
  • I have the same issue because of multicast. Just remove multicast from your DP settings and try again (when it's enabled).

    Haven't solve the issue myself yet. Hope it helps!

    Edit: http://henkhoogendoorn.blogspot.nl/2013/02/multicast-error-0x80091007-during.html


    My blogs: Henk's blog and Virtuall | Follow Me on: Twitter | View My Profile on: LinkedIn


    Tuesday, February 26, 2013 1:11 PM
  • If you are using VMWare 5.1 it's probably in the NIC driver.
    When you use the E1000E driver, change it to VMXNET3


    __________________________________________ Willemjan van Laarhoven | http://www.toolzz.com

    Thursday, July 18, 2013 9:31 AM