locked
Server 2012r2 monthly patches killing Hyper-V virtual network interface RRS feed

  • Question

  • I’ll start with the setup: 4 Dell servers running Windows Server2012r2, clustered with a shared SAN (connected via SAS).  1 teamed NIC (#1 and #2) on a Vlan, 1 single NIC(#3) on a different Vlan, and a ‘heartbeat’ NIC on its own switch.  All hosts are configured identically.  Hyper-V has 2 Virtual Switches, Virtual Switch1 with the teamed NIC’s, and Virtual Switch2 with the stand alone NIC.

    Before last week, everything was running flawlessly. We don’t have cluster aware updating configured yet, so when I went to apply patches last Monday I moved VM’s manually, patched the host, rebooted and planned on moving VM’s back. 

    The problem: Once patches were installed and I rebooted, all of the Virtual Switch Interfaces were gone from network and sharing center, and were showing up with ‘unable to load drivers’ under ‘network adapters’ in device manager (little yellow ‘!’ on the icon).  Also worth noting that the ‘Microsoft Hyper-V Network Switch Default Miniport’ network adapter was also giving an ‘unable to load device driver’ error (39). When I right clicked to uninstall and reinstall, nothing happens.  When attempting to open virtual switch manager under Hyper-V Manager, we get an error ‘An error occurred while trying to retrieve a list of virtual switches. The operation on computer ‘localhost’ failed.’.

    We messed around with it for a while, and found the only way to get it back up and running was to wipe the OS and reinstall. Tried uninstalling and reinstalling Hyper-V and it didn’t fix the issue. It WILL NOT be cool to do that every time.  After I got the initial one up and running, I tried updating the next host in the cluster hoping it was a fluke.  It was not. Same issue with that one.

    Did I do something wrong? Is it necessary to use Cluster Aware Updating? I have 2 more hosts to update, and not looking forward to it.

    Monday, July 27, 2015 2:32 PM

Answers

  • Hi ligawatt,

    As you mentioned each time you meet the issue you need to “wipe the OS and reinstall”, it seems like there have nic driver issue, can you try to install the latest NIC driver and firmware then try again, generally we can first ask Dell® to confirm whether your hardware support Server 2012R2.

    More information:

    Virtual Machine Network Adapters

    https://msdn.microsoft.com/en-us/library/windows/hardware/hh598304(v=vs.85).aspx

    I’m glad to be of help to you!


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com

    • Proposed as answer by Alex Lv Friday, July 31, 2015 9:50 AM
    • Marked as answer by Alex Lv Thursday, August 6, 2015 6:03 AM
    Wednesday, July 29, 2015 9:11 AM