none
Opening a SharePoint site in SPD, "Folder Name is Not Valid" RRS feed

  • Question

  • When trying to open a SharePoint 2010 site in SharePoint Designer 2010, I receive a message saying, "Folder Name is Not Valid". It happens when trying to open the site from the local server and the same thing happens when using localhost, 127.0.0.1, server name in the open site box in SPD. Same thing happens on a remote PC.

    Also, if I open SPD2010 on the server and select new blank website I get, "This website must be created on a server running SharePoint services from Microsoft..."

     

    Friday, April 23, 2010 6:56 AM

Answers

  • I had turned off integrated windows authentication in IIS Authentication Settings and was using basic auth because it was messing with my squid proxy. I turned it back on and it works!
    • Marked as answer by Clayton Cobb Tuesday, September 7, 2010 6:46 AM
    Saturday, April 24, 2010 1:57 AM

All replies

  • What URL are you trying to use?  It sounds like you're using the wrong path to open the site.  Also, what happens when you browse to your site and click Site Actions > Edit in SharePoint Designer?  This is the most fool-proof way to open it without the possibility of making a mistake.  Lastly, if this is pre-release software, then it won't work if your site has more than one Binding in IIS.
    SharePoint Architect || Microsoft MVP || My Blog
    • Proposed as answer by Mazin2 Tuesday, April 22, 2014 6:53 AM
    Friday, April 23, 2010 7:27 AM
  • It won't open from within the site by selected Edit in Sharepoint Designer.

    It is a pre-release, I've just done a clean single server install. What do you mean by more than one Binding in IIS?

    • Proposed as answer by t_rentz Sunday, September 9, 2012 3:45 AM
    Saturday, April 24, 2010 1:16 AM
  • As in host headers.  When you create a web application, it sets a random port by default and has no host header.  When you do this, your site is browsed like this: http://myserver:23152 ...or something along those lines.  People often then add another Alternate Access Mapping with a host header on port 80 for friendly browsing like this: http://sharepoint2010/ ...or something like that. To do this requires adding another binding in IIS so that IIS knows to recognize the new host header.  If you have done nothing like this, then it shouldn't be an issue.  The fact that you can't open it from the Site Actions menu means something is jacked up for sure.
    SharePoint Architect || Microsoft MVP || My Blog
    Saturday, April 24, 2010 1:35 AM
  • I had turned off integrated windows authentication in IIS Authentication Settings and was using basic auth because it was messing with my squid proxy. I turned it back on and it works!
    • Marked as answer by Clayton Cobb Tuesday, September 7, 2010 6:46 AM
    Saturday, April 24, 2010 1:57 AM
  • Yeah, I wouldn't recommend doing that with SharePoint.


    SharePoint Architect || Microsoft MVP || My Blog
    Saturday, April 24, 2010 2:04 AM
  • Hi BenMjamin

    I had the same issue when working on my developer maschine.

    on development i usually give me webapplications a simpel hostheader, the i make an entry in the hosts file, and its up and running. ex: http://sp2010branding in the hosts file 127.0.0.1 sp2010branding. Now i can browse the site, but SharePointDesigner wount open it.

    This solved it for me:

    1. into CA
    2. delete the Web application named sp2010brandig
    3. created a new web application named sp2010brandig.dk
    4. change the hosts file entry to: 127.0.0.1 sp2010branding.dk
    5. logged into the new site
    6. under site action, click on edit in sharepoint designer 2010, and happy days.

    Regards

    Carsten B. Larsson

     

     

     

     

    Friday, July 16, 2010 11:44 AM
  • Hi Carsten,

    Can you explain how to change the host file entry to:127.0.0.1 please

    Sunday, August 7, 2011 11:02 PM
  • Hi Clayton,
                I'm doing exactly what you stated and i can't open sharepoint 2013 via sharepoint designer 2012
    Any ideas how i can fix this?

    Cheers in Advance,

    Sunday, December 8, 2013 11:56 PM