none
Shared Library not appearing on Client RRS feed

  • Question

  • Setting up tape library sharing was successful.  No errors reported.  However, after performing the rescan and refresh on both the library and client, the client does not show the tape library.  The rescan/refresh does not result in any error.  What can I check for?  Ideas please?

    Library is a physical machine (2008R2) with iSCSI attached tape drives (HP ML4048.)  All disk-to-disk storage is on the SAN for both the libary and the client.

    Tuesday, July 27, 2010 3:41 PM

Answers

  • Hi,

    I'm not familiar with that tape library, but if it is iSCSI (network) attached then you probaby need to go into it's configuration and grant access to the SCDPM server.   If you open the Microsoft iSCSI initiator on the SCDPM server, can you see the tape library devices ?   Anyways, until you get the tape library and the SCDPM server configured so they can talk to each other (And Device manager on SCDPM sees the changer and tape devices), tape library sharing will not work.


    Regards, Mike J [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.
    Monday, August 2, 2010 10:31 PM
    Moderator

All replies

  • Hi,

    Before enabling tape sharing, did both DPM servers see the library and drives in both device manager and DPM console ?  In order to share a library, both DPM servers must have access to the library, so check the configuration and make sure device manager sees both the changer element and tape drives.  There is also a requirement of the changer and drives to have serial numbers. 


    Regards, Mike J [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.
    Tuesday, July 27, 2010 10:22 PM
    Moderator
  • Thanks for the response!  I have two systems.  First = SCDPM / Second = SCDPM-DR.  SCDPM-DR has the HP MSL4048 tape library directly attached along with its own set of platter drives (SAN).  So, this system has the Medium Changer and my two tape drives listed as expected.  However, SCDPM is my primary server backing everything up to disk (SAN) only.  Each system has been performing great.  However, I can not get SCDPM to see the tape library connected to SCDPM-DR.  SCDPM does not have a Medium Changer Device or the two tape drives listed in device manager.

    As per setup instructions, the Medium Changer should not be enable on the client (in this case SCDPM).  So, now I am a little confused on what "device/s/" should be seen (if any) on SCDPM

    My changer and drives do indeed have serial numbers.  But, no, SCDPM has never seen the tape library connected to SCDPM-DR.  I followed the the setup instructions for sharing and no errors were reported.

    So sorry for my ignorance, oversite, whatever you may call it, but I can use more help.  Please.

    Monday, August 2, 2010 4:53 PM
  • Hi,

    I'm not familiar with that tape library, but if it is iSCSI (network) attached then you probaby need to go into it's configuration and grant access to the SCDPM server.   If you open the Microsoft iSCSI initiator on the SCDPM server, can you see the tape library devices ?   Anyways, until you get the tape library and the SCDPM server configured so they can talk to each other (And Device manager on SCDPM sees the changer and tape devices), tape library sharing will not work.


    Regards, Mike J [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.
    Monday, August 2, 2010 10:31 PM
    Moderator
  • Hello,

    Well dumb, dumb me.. I thought we were using iSCSI tape drives.  Not true.  Our tape library has (2x) SAS drives directly connected to the SCDPM-DR system.  So, now the question becomes can these SAS drives be shared to another server?

    Tuesday, August 3, 2010 7:50 PM
  • Unfortunatly not - Each DPM Client server needs direct access to the tape drives.  You cannot enable tape sharing for locally attached tape libraries.
    Regards, Mike J [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.
    Tuesday, August 3, 2010 9:38 PM
    Moderator