locked
Booting to WinPE disc = 0xc000000f required device is inaccessible RRS feed

  • Question

  • Steps so far:
    1) I prepared a new machine using a clean install of Win7 RTM x64, installed all of our productivity apps, then ran sysprep /generalize /oobe /shutdown
    2) On another machine, I created a WinPE ISO using the Win7 AIK and burned it to a DVD.

    Next step is to capture the image and upload it to a fileserver.  However, I can't even boot into the PE environment.  Every time I try, I get
    Status: 0xc000000f
    Info: The boot selection failed because a required device is inaccessible.

    I've tried creating both x86 and x64 WinPE DVDs -- same result.  Tried several, in fact, to ensure it's not due to a burn error.  I am not doing any customizations to the ISO other than copying the appropriate version of imagex.exe to the root directory.
    Thursday, August 27, 2009 4:24 PM

Answers

  • Just created a x64 WinPE DVD with the Vista AIK and a different set of instructions -- it worked. No idea why. * http://technet.microsoft.com/en-us/library/cc709665%28WS.10%29.aspx
    • Marked as answer by Robinson Zhang Friday, September 4, 2009 1:49 AM
    Thursday, August 27, 2009 9:46 PM

All replies

  • Just created a x64 WinPE DVD with the Vista AIK and a different set of instructions -- it worked. No idea why. * http://technet.microsoft.com/en-us/library/cc709665%28WS.10%29.aspx
    • Marked as answer by Robinson Zhang Friday, September 4, 2009 1:49 AM
    Thursday, August 27, 2009 9:46 PM
  • I know why ... I just tried this using win7AIK, with a default iso, and got the same error you did.

    when it creates the winpe directory, it doesn't actually boot a default boot.wim file in the ISO\sources directory. I was looking through the instructions you had linked to in your reply, and i noticed that with the technet writeup you linked to, you're supposed to :

    copy c:\winpe\winpe.wim C:\winpe\iso\sources\boot.wim (in effect you're overwriting the one that's already there, only with the win7AIK there wasn't one there...)

    so, i copied the winpe.wim into that dir, renamed it to boot.wim, recreated the iso, and it booted.

    I wouldn't have been able to figure it out if you hadn't pointed to the other writeup and mentioned that it was a different instruction set.

    Thanks, and i hope this helps :)
    • Proposed as answer by Squuiid Sunday, September 13, 2009 11:24 PM
    Friday, September 4, 2009 5:27 AM
  • I know why ... I just tried this using win7AIK, with a default iso, and got the same error you did.

    when it creates the winpe directory, it doesn't actually boot a default boot.wim file in the ISO\sources directory. I was looking through the instructions you had linked to in your reply, and i noticed that with the technet writeup you linked to, you're supposed to :

    copy c:\winpe\winpe.wim C:\winpe\iso\sources\boot.wim (in effect you're overwriting the one that's already there, only with the win7AIK there wasn't one there...)

    so, i copied the winpe.wim into that dir, renamed it to boot.wim, recreated the iso, and it booted.

    I wouldn't have been able to figure it out if you hadn't pointed to the other writeup and mentioned that it was a different instruction set.

    Thanks, and i hope this helps :)

    Awesome. Gotta love how the Windows 7 documentation sucks.
    Thanks very much Christopher, this works.
    Sunday, September 13, 2009 11:26 PM
  • This solved my problem.  I had previously attempted to burn multiple CD's (x86, amd64, single processor, multi-processor) and NOTHING worked.  Always received an error.  After doing the copy of winpe.wim into the iso\sources\boot.wim, the winpe disk worked fine.

    Thanks for your help.

    My sanity is now restored.
    Saturday, December 5, 2009 8:24 PM
  • Thank you so much for this.  I'm attempting to study to sit the 70-680 test.  Couldn't get WinPE to boot, figured it had to be an issue with WinPE and VirtualBox.  Tried all kinds of things then finally decided to install the Win7AIK on hardware (rather then virtual) but got the same problem.  Then I searched and ran across this thread.  I'm glad to know that the directions in the study book are wrong. Thankfully I wanted to actually try things and learned the issue with the Win7AIK.  Thanks again for finding the issue.

    Tuesday, December 22, 2009 8:40 PM
  • Man I hate this book already, so many mistakes, I to tried it on diff machines and different combinations, as soon as I found this post and followed the instructions it worked straight away.  They really need to check what they write in the books and make sure the syntax and commands actually work before they publish them, all it does is cause alot of hassle when all we are trying to do is follow instructions.....
    Wednesday, December 30, 2009 1:18 AM
  • Thanks Richard for the link.
    Thanks to all who read and commented.

    It should also be noted that the instructions here are also incorrect:
    http://technet.microsoft.com/en-us/library/cc749311(WS.10).aspx

    Fortunately, someone commented there as well stating:
    "Dont forget to add boot.wim
    The instructions in step two leave out one important step. The sources directory must have a boot.wim file.
    Here is the command:
    xcopy c:\winpe_x86\winpe.wim c:\winpe_x86\iso\sources\boot.wim /y"

    • Proposed as answer by Ahmad Habib Friday, April 12, 2013 10:17 PM
    • Unproposed as answer by Ahmad Habib Friday, April 12, 2013 10:17 PM
    Monday, January 4, 2010 3:48 PM
  • I know why ... I just tried this using win7AIK, with a default iso, and got the same error you did.

    when it creates the winpe directory, it doesn't actually boot a default boot.wim file in the ISO\sources directory. I was looking through the instructions you had linked to in your reply, and i noticed that with the technet writeup you linked to, you're supposed to :

    copy c:\winpe\winpe.wim C:\winpe\iso\sources\boot.wim (in effect you're overwriting the one that's already there, only with the win7AIK there wasn't one there...)

    so, i copied the winpe.wim into that dir, renamed it to boot.wim, recreated the iso, and it booted.

    I wouldn't have been able to figure it out if you hadn't pointed to the other writeup and mentioned that it was a different instruction set.

    Thanks, and i hope this helps :)

    thanks soooo much for your extremely help,thanks for everyone who help to solve our problem,this problem make me highly angry,
    but i haven't problem anymore.
    Wednesday, February 10, 2010 7:04 PM
  • thanks richard ,thanks alot..
    Wednesday, February 10, 2010 9:43 PM
  • Thanx for ur help! it worked for me! it was driving me crazy until I saw ur solution! thanx a lot!
    Tuesday, February 16, 2010 1:17 AM
  • Thanks JuliusPIV.

    Now it works :-)


    Regards Thomas
    Thursday, March 4, 2010 12:54 PM
  • Christopher Mead,

    Thanks that was it.  I figure this is just another hidden 'test' in the Find the Error in Microsoft Documentation game.

    Monday, March 29, 2010 10:08 PM
  • Christopher Mead,

    Thanks that was it.  I figure this is just another hidden 'test' in the Find the Error in Microsoft Documentation game.

    Monday, March 29, 2010 10:08 PM
  • Wow! Thanks! Why hasn't this been fixed in the documentaion? I wasted a dozen or more CD's trying to get this working - x86 and 64 Bit - different DVD burners, different motherboards, etc. Easily 4 hours wasted trying to figure this out! (I even figured out that the .wim file wasn't in the image, but didn't know I'd have to rename the file!
    Wednesday, April 7, 2010 5:53 AM
  • Thanks...I was determined to get this working in the manner described in the book even though I have created winpe boot disks for vista from articles on the internet previously.
    Friday, April 23, 2010 2:52 PM
  • Thanks a lot Christopher! I'm also studying for exam 70-680 and this turned out to be very helpful for me. I just created a brand new user to thank you!
    Thursday, April 29, 2010 5:35 AM
  • Awesome, Thanks a lot Richard and Chris. Using the MS Press 70-680 Training Kit and finding various mistakes along the way.

    Sunday, May 23, 2010 4:24 AM
  • Hi, Many thanks to Richard and Christopher- bit behind the times with this one but this page has helped yet another confused Win7 customer!
    • Proposed as answer by ovonier Tuesday, June 15, 2010 12:57 PM
    Monday, May 24, 2010 10:08 AM
  • Thanks for this - I've spent the best part of a week playing with this assuming the problem was because I was using Virtual PC for my Reference Install or capturing the ISO for the WinPE CDROM rather than actually burning it!

    It didn't help either that the example on Page 68 of the 70-680 Training Kit already contained a typo for the OSCDIMG command used to generate the problematic WinPE CD! The KB aticle here fixes that typo and several others in the same book http://support.microsoft.com/kb/978189

    Tuesday, June 29, 2010 10:59 PM
  • Ok, I must be missing something because I still have the error message. I've copied the .wim file and renamed it and re-burned the ISO several times to no avail. Please someone HELP!

     

    • Proposed as answer by jayruguitar Monday, July 19, 2010 6:34 PM
    Monday, July 12, 2010 10:16 AM
  • Woops, first time posting.

    Run the oscdimg command again to create a new .iso w/ the boot.wim in the sources directory as Chris specified earlier.  Worked for me.  You da man Chris!

    Monday, July 19, 2010 6:35 PM
  • I am studying for the 70-682 exam. Yes, I also had the same problem too until I found this thread. Great , it is working now for me as well. Actually it was also already a little bit suspicious to me that the ISO file has been only 27 MB large.
    Saturday, July 31, 2010 11:05 AM
  • Thanks, Richard for this. I cannot tell you how helpful this was. I had no idea this publication was such ____. I honestly feel lucky to know enough about command-line syntax to have spotted some of the errors in the book previous to this. This problem was driving me insane, and it is not even listed on the publishers site. Hours of my life wasted...
    Friday, August 13, 2010 10:14 PM
  • Mate thank you SO much I've been pulling my hair out with this one!
    Thursday, August 26, 2010 5:47 PM
  • Thanks so much, it worked a treat. :)
    Tuesday, August 31, 2010 9:58 AM
  • Brilliant!
    Friday, September 24, 2010 10:20 AM
  • Thank you amigos! I was going nuts with making so many coasters :P
    Thursday, October 7, 2010 9:21 AM
  • Thank you, like many others I expect, I was tearing my hair out with the 70-680 book p84-85 practice instructions. You have helped a lot, thank you Christopher. :)

    Saturday, October 16, 2010 10:52 PM
  • I had to do something a little different than the suggested fix. I copied the boot.wim to the sources folder in the root of the disk, and not the iso\sources folder. Give it a try.
    Thursday, October 28, 2010 5:49 PM
  • This helped me too. I'm wondering if the Microsoft Press book 70-680 was even edited... not the only thing wrong in it.
    Friday, October 29, 2010 7:28 PM
  • copy c:\winpe\winpe.wim C:\winpe\iso\sources\boot.wim (in effect you're overwriting the one that's already there, only with the win7AIK there wasn't one there...)

    You rock, man! This solved my problem.

    Thank you!!!!!


    Gianluigi Zanettini - http://www.megalab.it
    Sunday, November 14, 2010 10:10 PM
  • THANK YOU! THANK YOU!  THANK YOU!
    Thursday, December 9, 2010 7:46 PM
  • THANKS! much appreciated!
    Monday, February 7, 2011 4:36 AM
  • Thank you All!
    Wednesday, February 9, 2011 4:27 PM
  • Good show chris...

    Thanks

    Vijay,

    Saturday, February 12, 2011 1:41 AM
  • Worked like a charm for me.

     

    At least somebody is getting things right for Microsoft...

    Tuesday, February 15, 2011 7:24 PM
  • I have tried your instructions and copied the winpe.wim file to the iso\sources directory and renamed it boot.wim, and yet when I burn the WinPE boot disk and try to boot from it, I still get the same error.  I admit I'm using a non-genuine version of Windows 7, but I don't think this should make a difference.  Can you tell me what I'm doing wrong??  I'm so frustrated with Microsoft!!!
    Friday, April 15, 2011 7:54 PM
  • Very very very Thank it work.

    Thursday, June 2, 2011 9:37 AM
  • Wow, a classic "fix" goes on forever. I salute you. My frustrating day finally turned bright when this fix worked for me.
    Thursday, June 9, 2011 8:11 PM
  • Christopher and Richard I think you two should be the ones writing these books. Thanks for your help I will be on the look out for errors like this when i get stuck again.
    Wednesday, August 3, 2011 11:23 PM
  • Thanks! This worked! I love you. 
    Wednesday, September 21, 2011 8:43 AM
  • Who ever you work for they have an asset in you. Thanks to you I solved this same problem. Cheers Mate!
    Tuesday, October 25, 2011 8:50 PM
  • Same problem here, thanx for the post.

    It 's very strange that after 2 years Microsoft still using the same documentation in WAIK and in the 70-680 training kit.

    Monday, November 21, 2011 5:02 PM
  • Thanks!!  I thought is was strange that my first .iso was only 29MB.  After copying the winpe.wim to ISO/sources and renaming to boot.wim, I recreated the .iso and it is now over 139MB.
    Wednesday, February 22, 2012 5:50 PM
  • in my case, i have a same problem earlier. rather than copy and renameing in same like.

    i did this manually using graphical mode and burn the iso image.

    this time it works. dont know what was the reason on more think i kept destination image file winpe_x86.iso

    Thursday, March 15, 2012 8:26 AM
  • Many thanks to you two (Christopher and Richard).  Two years later this is still helping people.  Unbelievable!

    Monday, May 7, 2012 8:08 PM
  • yes thanks you very much for this information

    si vous avez l'erreur 0xc000000f

    copier le fichier winpe.wim présent dans c:\winpe\winpe.wim dans C:\winpe\iso\sources\ puis le renommer en boot.wim

    puis créer et graver votre iso

    Wednesday, May 9, 2012 11:25 AM
  • Thank-you dude! I was studying for the 70-682 exam by reading the 70-680 book and thought what the hell is going on with my Windows PE ISO!!!
    Friday, May 25, 2012 11:44 PM
  • Just to say thank you for the help.
    Saved me a headache.

    Se o post ajudou, indique e informe os demais.

    Monday, July 23, 2012 11:00 PM
  • Does this also work if I use the Windows Vista AIK?

    Monday, August 6, 2012 1:07 PM
  • Thank you Chris!

    I'm actually using this in production to capture an image. The dept for the State of FL for which I work won't pony-up for Ghost, so we get to figure out how to use these convoluted Microsoft tools. I suppose there is always Clonezilla!  But then I can't use an unattend file.

    Anyway, for you test takers, here's a question: will the correct test answers be based on the incorrect information that Microsoft supplied in their documentation?


    • Edited by YellowSnow Wednesday, August 8, 2012 3:10 PM typo
    Wednesday, August 8, 2012 3:09 PM
  • I know why ... I just tried this using win7AIK, with a default iso, and got the same error you did.

    when it creates the winpe directory, it doesn't actually boot a default boot.wim file in the ISO\sources directory. I was looking through the instructions you had linked to in your reply, and i noticed that with the technet writeup you linked to, you're supposed to :

    copy c:\winpe\winpe.wim C:\winpe\iso\sources\boot.wim (in effect you're overwriting the one that's already there, only with the win7AIK there wasn't one there...)

    so, i copied the winpe.wim into that dir, renamed it to boot.wim, recreated the iso, and it booted.

    I wouldn't have been able to figure it out if you hadn't pointed to the other writeup and mentioned that it was a different instruction set.

    Thanks, and i hope this helps :)
    Thanks a bunch! You saved my butt there.
    Sunday, August 19, 2012 11:34 AM
  • Thank you, before I started to tear my hear out and eat a bag of pot I decided to google for this and found this thread. Some instructions in the exam book arent right or should be given before. It works now tnx a bunch.
    Monday, September 24, 2012 1:05 PM
  • Wow! Richard and Chris many thanks for this. I am so glad that this thread is still running. I am studying towards my 70-680 which i will be taking in March. When I got to this point in the book everything seemed to be going fine until I had to boot form the disc. I was surprised that the boot image was only 27MB but just figured this must be how it is. This lesson was only supposed to take me 50 minutes but took me a whole day because I was pulling my hair out, putting together new machines to boot from the WinPe disc. Once again many thanks to Richard and Chris!!

    On a more serious note Microsoft seriously need to address this issue! People are willing to spend the extortionate amount of money for the MS Press Books but if the books do not contain the correct information then Microsoft are not living up to their side of the bargain!

    Sunday, February 3, 2013 12:07 PM
  • Thank you!!!
    Wednesday, July 24, 2013 8:42 AM
  • Thank you richard...............

    So many thankssssssssssssssssssssss.............................!!!!!!!!!!!!!!!!!!!!!!!!!!


    Thanks & Regards, Vishal

    Tuesday, August 13, 2013 1:21 PM
  • these steps worked for me...

    In the Deployment Tools Command Prompt window, perform one of the following tasks, and then press ENTER:

    If the reference computer is a 32-bit computer, type copype.cmd x86 C:\winpe_x86.

     

    If the reference computer is a 64-bit computer, type copype.cmd amd64 C:\winpe_amd64.

     

    In the Deployment Tools Command Prompt window, perform one of the following tasks, and then press ENTER:

    If the reference computer is a 32-bit computer, type copy C:\winpe_x86\winpe.wim C:\winpe_x86\ISO\sources\boot.wim.

     

    If the reference computer is a 64-bit computer, type copy C:\winpe_amd64\winpe.wim C:\winpe_amd64\ISO\sources\boot.wim.

     

    In the Deployment Tools Command Prompt window, perform one of the following tasks, and then press ENTER:

    If the reference computer is a 32-bit computer, type copy "C:\Program Files\Windows AIK\Tools\x86\ImageX.exe" C:\winpe_x86\ISO\.

     

    If the reference computer is a 64-bit computer, type copy "C:\Program Files\Windows AIK\Tools\amd64\ImageX.exe" C:\winpe_amd64\ISO\.

    insert a UFD into the computer.

    In the Deployment Tools Command Prompt window, type diskpart, and then press ENTER.

    Perform the following tasks to prepare the UFD to start the reference computer:

    Type list disk, and then press ENTER.

     

    From the list of disks, identify the number of the UFD. It is important that you identify the correct disk, as you will be formatting the disk. Make sure the size and free space match what you expect for the UFD.

     

    Type select disk number, where number is the disk number of the UFD, and then press ENTER.

     

    Type clean, and then press ENTER.

     

    Type create partition primary, and then press ENTER.

     

    Type select partition 1, and then press ENTER.

     

    Type format fs=fat32 quick, and then press ENTER.

     

    Type active, and then press ENTER.

     

    Type exit, and then press ENTER.

     

    Install win7 on new PC

    after that

    C:\Windows\System32\sysprep\sysprep.exe

    In the System Cleanup Action list, select Enter System Audit Mode.

    Select the Generalize check box.

    In the Shutdown Options list, select Reboot.

    Click OK to restart the computer in Audit mode.

    After the computer restarts, Windows 7 automatically logs in as Administrator.

    To remove the temporary user account’s profile

    Click Start, type user profile in the Search box, and then click Configure advanced user profile properties in the search results.

    In the User Profiles dialog box, click the name of the temporary user account you created when you installed Windows 7 on the reference computer, and then click Delete. Click Yes to confirm.

    Click OK to close the User Profiles dialog box.

    To remove the temporary user account

    Click Start, right-click Computer, and then click Manage.

    In the console tree (left pane), click Local Users and Groups.

    In the details pane (middle pane), double-click Users.

    Right-click the name of the temporary account you created when you installed Windows 7 on the reference computer, and then click Delete.

    Click Yes to confirm that you want to delete the temporary user account.

    Click OK to acknowledge that you are deleting an administrator account.

    Close the Computer Management window.

    Open Sysprep. (Windows 7 automatically runs Sysprep when you start the operating system in Audit mode.)

    In the System Cleanup Action list, select Enter System Out-of-Box Experience (OOBE).

    Select the Generalize check box.

    In the Shutdown Options list, select Shutdown.

    Click OK to run Sysprep and shut down the computer.

     

    E:\imagex /compress fast /check /flags “Professional” /capture D:

    E:\install.wim “Windows 7 Professional” “Windows 7 Professional Custom”


    Sai Siva Kumar

    • Proposed as answer by don'zz Tuesday, August 13, 2013 1:25 PM
    Tuesday, August 13, 2013 1:25 PM
  • My computer was trying to boot from a thumb drive i had in the port at shutdown. I had changed some registry values and entries with an app and the computer had gotten confused as to which drive to start from.

    Removing the thumb drive at this point didnt help.

    The real problem was the inability of my keyboard to command the black screen choices. It turned out that all I had to do was plug in the factory keyboard that came with the unit to enable me to command the black screens.

    Windows opened right up!

    I then used the repair option of the original Windows disc.

    The key to all this was the original keyboard so that I could command the black screens. I lost no data whatsoever.



    • Edited by luvitt Tuesday, March 18, 2014 12:27 PM
    • Proposed as answer by luvitt Tuesday, March 18, 2014 12:27 PM
    Tuesday, March 18, 2014 12:26 PM
  • Genius! 
    Monday, March 2, 2015 4:32 PM
  • Hi there,

    After performing the copying of the winpe.wim file and renaming it to boot.wim in the ISO subdirectory, I still receive the 0xc000000f error when attempting to boot from Winpe DVD. I have also burnt the image file to both a DVD+R and CD-R to find out if any particular CD\DVD media might be causing the problem. I have checked both CDs and the boot.wim file was successfully added to the iso image after burning.

    I am using Windows 7 Enterprise trail as I am also trying to use ImageX to create the image of the reference computer as part of my MCTS 70-680 certification.

    Could it be due to the fact that I am using a trail version of Windows 7 Enterprise that this is the reason why I cannot run the WinPE Disk????

    I am using a DELL Optiplex 780.

    Thanks

    Glenn Romain

    Wednesday, February 3, 2016 10:56 PM
  • This worked splendidly. 
    Friday, March 8, 2019 9:17 PM