none
exchange server incoming mail issue from the internet

    Question

  • Hi,

    I have registered a domain under godaddy.com, and I have exchange server 2013. My question is my exchange server can send and receive emails on the same network(local network). I can also be able to send emails to outside the network( to the internet), But I am not able to receive emails from outside the network(from the internet). I have opened the port 25 on my router and given IP address of Exchange server. My firewall didn't block port 25. Still I don't know why I am not receiving emails from the internet. I checked on GoDaddy DNS setting, A record, and MX record seems perfect. Can anybody help what is the reason of this ? can ISP blocks inbound SMTP connection? I can send emails outside network both via smart host and DNS MX record. 

    thanks,

    Friday, June 17, 2016 8:54 AM

Answers

All replies

  • hi, are you receiving any NDR? there may be a chance that the email routing is not happening properly.

    did you check whether your domain is block-listed?

    Friday, June 17, 2016 9:05 AM
  • Please check the MX and DNS for go daddy has been published to internet through mxtoolbox.com.

    You can check the internal email from from internet via www.testexchangeconnectivity.com.

    and yes Whats the NDR message you r getting? Can you send/receive email with in the same domain?

    Friday, June 17, 2016 9:31 AM
  • Hi,

    Agree with yspintu.

    First, you should make sure the MX record could be resolved by others,  

    Then, you can use an outside email account (like hotmail/Gmail..)make a test and check if there is any NDR message. If yes, please post the NDR, that would help us troubleshoot the issue.


    Best Regards,


    Monday, June 20, 2016 9:09 AM
    Moderator
  • As others have saind, ensure your MX records point to your exchange server/routers external IP. Also check your Default Frontend receive connector settings and ensure you haven't denied access under "Scoping"
    Monday, June 20, 2016 12:20 PM