none
Creating project site failed! The activity named WorkflowXaml xyz from scope was not found. RRS feed

  • Question

  • Hello,

    We are running Project Online environment where we have created a custom Project Site Template we call it "PS Template 01" for e.g. to be used for the other projects. We had few SPD 2013 workflows running in the template. Later on we removed the instances of those workflows from all the lists and libraries. When we create a new custom site template called "Engineer PS Template 01" for e.g. from the "PS Template 01" it creates the new template successfully.

    However when we try to create a new project with this new project site template i.e. "Engineer PS Template 01", the Project Site is not created and the queue shows the following error:

        CreateWssSiteContent: Creating project site failed!
     Project Uid=3af370b0-46b9-e711-80e0-00155d585d10, site URL=https://xyz.sharepoint.com/sites/pwa/Project Site Template Engineering, site name=Project Site Template Engineering.
    System.Runtime.InteropServices.COMException (0x8107058A): <nativehr>0x8107058a</nativehr><nativestack></nativestack>Microsoft.Workflow.Client.ActivityNotFoundException: The activity named _WorkflowXaml_1aa4c160_d8ee_4814_be16_9cef3b971b25_ from scope _/spo/5342e813-071c-4ada-b041-bd0af9245d51/1bf2c9f7-1895-42e5-85e5-f9c5b514808f/3ec20712-74f8-499e-936c-2221ddd830bc_ was not found.
    HTTP headers received from the server - ActivityId: 3b33865f-2dbb-4350-9e2e-b9324dec0000.
    NodeId: . Scope: . Client ActivityId : 6943269e-f0b5-4000-7622-5b0a20e66430. ---> System.Net.WebException: The remote server returned an error at Microsoft.SharePoint.Library.SPRequestInternalClass.ApplyWebTemplate(String bstrUrl, String bstrWebTemplateContent, Int32 fWebTemplateContentFromSubweb, Int32 fDeleteGlobalListsWithWebTemplateContent, Int32 fIgnoreMissingFeatures, String& bstrWebTemplate, Int32& plWebTemplateId) at Microsoft.SharePoint.Library.SPRequest.ApplyWebTemplate(String bstrUrl, String bstrWebTemplateContent, Int32 fWebTemplateContentFromSubweb, Int32 fDeleteGlobalListsWithWebTemplateContent, Int32 fIgnoreMissingFeatures, String& bstrWebTemplate, Int32& plWebTemplateId)Microsoft.SharePoint.SPException: Microsoft.Workflow.Client.ActivityNotFoundException: The activity named _WorkflowXaml_1aa4c160_d8ee_4814_be16_9cef3b971b25_ from scope _/spo/5342e813-071c-4ada-b041-bd0af9245d51/1bf2c9f7-1895-42e5-85e5-f9c5b514808f/3ec20712-74f8-499e-936c-2221ddd830bc_ was not found.
    HTTP headers received from the server - ActivityId: 3b33865f-2dbb-4350-9e2e-b9324dec0000. NodeId: . Scope: . Client ActivityId : 6943269e-f0b5-4000-7622-5b0a20e66430. ---> System.Net.WebException: The remote server returned an error ---> System.Runtime.InteropServices.COMException: <nativehr>0x8107058a</nativehr><nativestack></nativestack>Microsoft.Workflow.Client.ActivityNotFoundException: The activity named _WorkflowXaml_1aa4c160_d8ee_4814_be16_9cef3b971b25_ from scope _/spo/5342e813-071c-4ada-b041-bd0af9245d51/1bf2c9f7-1895-42e5-85e5-f9c5b514808f/3ec20712-74f8-499e-936c-2221ddd830bc_ was not found.
    HTTP headers received from the server - ActivityId: 3b33865f-2dbb-4350-9e2e-b9324dec0000. NodeId: . Scope: . Client ActivityId : 6943269e-f0b5-4000-7622-5b0a20e66430. ---> System.Net.WebException: The remote server returned an error at Microsoft.SharePoint.Library.SPRequestInternalClass.ApplyWebTemplate(String bstrUrl, String bstrWebTemplateContent, Int32 fWebTemplateContentFromSubweb, Int32 fDeleteGlobalListsWithWebTemplateContent, Int32 fIgnoreMissingFeatures, String& bstrWebTemplate, Int32& plWebTemplateId) at Microsoft.SharePoint.Library.SPRequest.ApplyWebTemplate(String bstrUrl, String bstrWebTemplateContent, Int32 fWebTemplateContentFromSubweb, Int32 fDeleteGlobalListsWithWebTemplateContent, Int32 fIgnoreMissingFeatures, String& bstrWebTemplate, Int32& plWebTemplateId)
    --- End of inner exception stack trace --- at Microsoft.SharePoint.SPGlobal.HandleComException(COMException comEx) at Microsoft.SharePoint.Library.SPRequest.ApplyWebTemplate(String bstrUrl, String bstrWebTemplateContent, Int32 fWebTemplateContentFromSubweb, Int32 fDeleteGlobalListsWithWebTemplateContent, Int32 fIgnoreMissingFeatures, String& bstrWebTemplate, Int32& plWebTemplateId) at Microsoft.SharePoint.SPWeb.ProvisionWebTemplate(SPWebTemplate webTemplate, String webTemplateToUse, SPFeatureWebTemplate featureWebTemplate, Page page, SPFeatureDependencyErrorBehavior featureDependencyErrorBehavior, ICollection`1& featureDependencyErrors) at Microsoft.SharePoint.SPWeb.ApplyWebTemplate(SPWebTemplate webTemplate, Page page, SPFeatureDependencyErrorBehavior featureDependencyErrorBehavior, ICollection`1& featureDependencyErrors) at Microsoft.SharePoint.SPSite.CreateWeb(String strUrl, String strTitle, String strDescription, UInt32 nLCID, String strWebTemplate, Boolean bCreateUniqueSubweb, Boolean bConvertIfThere, Guid webId, Guid rootFolderId, Boolean createSystemCatalogs, Guid appInstanceId, String appWebDomainId) at Microsoft.SharePoint.SPSite.SPWebCollectionProvider.CreateWeb(String strWebUrl, String strTitle, String strDescription, UInt32 nLCID, String strWebTemplate, Boolean bCreateUniqueSubweb, Boolean bConvertIfThere, Guid appInstanceId) at Microsoft.SharePoint.SPWebCollection.Add(String strWebUrl, String strTitle, String strDescription, UInt32 nLCID, String strWebTemplate, Boolean useUniquePermissions, Boolean bConvertIfThere, Guid appInstanceId) at Microsoft.Office.Project.Server.BusinessLayer.AdminProjectSiteAllocator.CreateSPWeb(ProjectSiteConfigurationInfo configInfo, SPSite topSite):
            WSSCreateSiteFailure (16400). Details: id='16400'
            name='WSSCreateSiteFailure'
            uid='285913e7-47b9-e711-80e0-00155d585d10'
            projectUID='3af370b0-46b9-e711-80e0-00155d585d10'
            workspaceUrl='https://xyz.sharepoint.com/sites/pwa/Project Site Template Engineering/Project Site Template Engineering'
            projectWorkspaceName='Project Site Template Engineering'
            . 
        Queue:
            GeneralQueueJobFailed (26000) - CreateWssSite.CreateWssSiteMessage. Details: id='26000'
            name='GeneralQueueJobFailed'
            uid='295913e7-47b9-e711-80e0-00155d585d10'
            JobUID='fbe679b6-46b9-e711-80e0-00155d585d10'
            ComputerName='1dbc4323-509d-4467-a557-23f4205e6d63'
            GroupType='CreateWssSite'
            MessageType='CreateWssSiteMessage'
            MessageId='1'
            Stage=''
            CorrelationUID='6943269e-f0b5-4000-7622-5b0a20e66430'
            For more details, check the ULS logs on machine 1dbc4323-509d-4467-a557-23f4205e6d63 for entries with JobUID fbe679b6-46b9-e711-80e0-00155d585d10. 

    We do not have any custom workflow activity and no workflow is associated to the list. There aren't any running instances, stop instances etc. of the workflows either.

    Thank you and

    Regards


    Tanzim Akhtar


    • Edited by Tanzim Wednesday, October 25, 2017 7:17 AM
    Wednesday, October 25, 2017 7:14 AM

All replies

  • The workflow that is being referenced is the built in workflow that PWA uses.  The template is referencing something in Issues, Risk or Deliverable web parts and somebody has deleted or modified the fields in one of the Out-of-box versions.   

    I would go back to the original template to get the site creation working first and then rereate template and dont edit or delete field.. Hide the once that are not needed and create new ones.


    Michael Wharton, MVP, MBA, PMP, MCT, MCTS, MCSD, MCSE+I, MCDBA
    Website http://www.WhartonComputer.com
    Blog http://MyProjectExpert.com contains my field notes and SQL queries

    Wednesday, October 25, 2017 10:43 AM
    Moderator
  • Thank you Michael.

    We haven't delete any in built fields of the mentioned lists and the last time we worked on the mentioned lists were 5 months ago. Moreover we have created 6 templates so far from the first custom template and new templates from the last template (completing 6 so far). However for the 7th one it has started giving errors.


    Tanzim Akhtar



    • Edited by Tanzim Wednesday, October 25, 2017 10:57 AM
    Wednesday, October 25, 2017 10:55 AM
  • The error has been resolved Alhamdulillaah.

    We opened the last project site template in SharePoint Designer, published a workflow and then saved the site as template.

    Since the error was mentioning the missing workflow activity, we wanted to see whether the "restart of windows" type of thing works in this situation or not and it worked.

    Note: We will remove the workflow again as we don't want it.

    Thank you all and

    Regards


    Tanzim Akhtar

    Wednesday, October 25, 2017 11:52 AM