locked
Sleep wakes randomly RRS feed

  • Question

  • So, I have Vista Ultimate x64 on my new Core2Duo e6850/Intel DP35DP motherboard.

    The computer goes to sleep and wakes up just fine in S3 sleep mode. The problem I have is that it's randomly turning back on while I'm gone. I check the logs, but I can't figure out what turned the computer back on. I used powercfg -lastwake and get:
    c:\powercfg -lastwake
    Wake History Count - 1
    Wake History [0]
    Wake Source Count - 0

    Which doesn't tell me much of anything. When I use the keyboard or mouse - it at least tells me that but these other events don't tell me why it woke.  I don't have pets, and have actually been sitting in the room when it turns on and can vouch that nothing disturbed the pc.  It tends to turn on at solid intervals - 10:30/12:00/5:00pm, so it seems like scheduled activities.

    I also tried taskschd.msc and looked through the myriad of processes, but a can't find ones that match the times my computer wakes up. I did find a few that were waking things up - Windows Update was one of them and by turning auto updates off, then it slept through those. I turned off the wake on network device, even tried unplugging the lan - but it tends to wake up at noon some days and then sit on all day until I get home (other days it's still off). The bios settings are also blank/disabled for wake at a specific time.  I have also updated the system bios to the latest version (which did fix a variety of sleep problems - but they were ones about not waking up at all.)

    Do I just need to switch to hibernate? But this is kind of lame because I used sleep mode with the exact same config but using a e6600/965OT motherboard without this problem.  It's also REALLY lame there is no logging to tell you what process work your pc up. 

    How can I tell what work the computer up and tell it to stop?
    Getting desperate...
    Sunday, March 9, 2008 9:00 PM

Answers

  •  

    Hi mattpf and joshtee,

     

    Thank you for the reply.

     

    Now let’s perform a Clean Boot to test the issue.

     

    Clean Boot

    ========

    1. Click Start, type "MSCONFIG" (without the quotations) in the Search Bar and Press "Enter" to start the System Configuration Utility.

     

    Note: Please click Continue if the "User Account Control" window pops up.

     

    2. Click the "Services" tab, check the "Hide All Microsoft Services" box and click "Disable All" (if it is not gray).

    3. Click the "Startup" tab, click "Disable All" and click "OK".

    4. Restart the computer and test the issue.

     

    Note: Clean Boot is a troubleshooting step. If some programs have been disabled, we can re-enable them later. If you see the System Configuration Utility, check the box of "Don't show this message" and then click "OK".

     

    Please test this issue in the Clean Boot environment. if the issue disappears, we can use a 50/50 approach to quickly narrow down which entry is causing the issue.

     

    Please also check task scheduler items.

     

    Hope it helps.

     

    Tim Quan - MSFT

    Friday, March 21, 2008 7:55 AM
    Moderator

All replies

  •  

    Hi,

     

    Based on the current situation, please help me collect the following information for research:

     

    Powercfg

    =======

    1.    Click Start -> All Programs -> Accessories.

    2.    Right-click Command Prompt and click Run as administrator.

    3.    Type the following command and press Enter.

     

    Powercfg –lastwake

     

    Please let me know the result.

     

    Event Log

    =======

    1.  Click Start button, input "eventvwr" (without the quotation marks) and press Enter.

    2.  In the left pane, click Windows logs to expand the subfolders.

    3.  Right-click System and click Filter Current Log.

    4.  Choose “Power Troubleshooter” in the “Event sources” dropdown menu and click OK.

    5.  Right-click System and click Save Filtered Log File As…. Choose Desktop in the left list, and save the log file using Powerwake as the name.

     

    I have created a FTP site and you can upload the file to me from the following the following site:

    https://sftus.one.microsoft.com/choosetransfer.aspx?key=5bca1047-facb-49b0-9a4c-a415debe0be2

     

    Password: zfxf*DwTO)5yx

     

    Tim Quan - MSFT

    Tuesday, March 11, 2008 4:31 AM
    Moderator
  • So, when I do powercfg after it wakes up normally via keyboard/mouse I get:

    C:\Users\Matt>powercfg -lastwake
    Wake History Count - 1
    Wake History [0]
      Wake Source Count - 1
      Wake Source [0]
        Type: Device
        Instance Path: USB\ROOT_HUB\4&3aa4f92d&0
        Friendly Name:
        Description: USB Root Hub
        Manufacturer: (Standard USB Host Controller)

    But when it's waken randomly, it does:

    c:\powercfg -lastwake
    Wake History Count - 1
    Wake History [0]
    Wake Source Count - 0

     

    I have uploaded the file as requested.  You'll notice that the 10:00am wakes happen most days and just say 'wake unknown' or something like that.  Those are the one's I can't figure out.  It didn't do it today (Mon 10th); but I did install the latest logitech drivers for my mouse/keyboard.  I have a wireless S520 keyboard, and a G5 mouse.  I'm also using a wireless media center remote (the actual microsoft one).

    Tuesday, March 11, 2008 7:13 AM
  •  

    Hi,

     

    Thank you for the reply and sending me the event log file.

     

    Now I suggest trying the following steps to troubleshoot the issue:

     

    1.    Click Start, type services.msc and press Enter.

    2.    Double-click Network Adapter.

    3.    Right-click your network card and click Properties.

    4.    On the Power Management tab, uncheck the boxes before “Allow this device to wake the computer” and “Only allow management stations to wake the computer.

    5.    Click OK.

     

    If the issue persists, please help me collect the following information:

     

    1.  Click Start -> All Programs -> Accessories.

    2.  Right-click Command Prompt and click Run as administrator.

    3.  Type the following command and press Enter.

     

    Powercfg -devicequery wake_armed

     

    Please let me know the result.

     

    Tim Quan - MSFT

    Wednesday, March 12, 2008 6:08 AM
    Moderator
  • I can only assume you ment go to the Device Manager - not services.msc to check on the power setting of the network adaptor.  I had heard of that problem before (and it was occuring), so I already disabled all the wake on lan features of my network driver (there is only one network driver on the computer).  I also checked the bios settings and the wake on lan features are disabled as well.  I have had this problem even when I physically unplug the network cable - it doesn't seem to make a difference.

    Here's the results of the second part:
    C:\Users\Matt>powercfg -devicequery wake_armed
    Logitech HID-compliant G5 Laser Mouse
    Logitech HID-Compliant Keyboard
    Logitech HID-compliant Cordless Mouse
    High Definition Audio Controller
    eHome Infrared Receiver (USBCIR)

    I checked the onboard audio controller and the ehome infrared reciever - neither had a wake/power tab associated with the driver.  If I wake the computer with the mouse or keyboard, the powercfg -lastwake correctly identifies that I'm using the mouse or keyboard to wake the system.  I only have a logitech s510 wireless keyboard and a USB G5 mouse installed.

    Matt
    Thursday, March 13, 2008 1:58 AM
  •  

    Hi,

     

    Thank you for the reply.

     

    Now let’s try steps below:

     

    1.  Click Start -> All Programs -> Accessories.

    2.  Right-click Command Prompt and click Run as administrator.

    3.  Type the following commands and press Enter.

     

    Powercfg -devicedisablewake “Logitech HID-compliant G5 Laser Mouse”

    Powercfg -devicedisablewake “Logitech HID-Compliant Keyboard”

    Powercfg -devicedisablewake “Logitech HID-compliant Cordless Mouse”

    Powercfg -devicedisablewake “High Definition Audio Controller”

    Powercfg -devicedisablewake “eHome Infrared Receiver”

     

    Hope it helps.

     

    Tim Quan - MSFT

    Thursday, March 13, 2008 3:38 AM
    Moderator
  • Ok,

    I installed the latest driver for my sound card and onboard network card.  The bios, and all the drivers, are now at their newest versions.  I made sure to re-disable all the wake on lan features in the network driver.

    I ran the commands as specified, and everything turned off except for the 3 Logitech devices.  With those I got:
    C:\Users\Matt>Powercfg -devicedisablewake “Logitech HID-compliant G5 Laser Mouse”
    Invalid Parameters -- try "/?" for help

    I think it's picking up the '-' character between HID and compliant and interpreting that as a parameter option.
    I tried all of these as well:
    C:\Users\Matt>Powercfg -devicedisablewake 'Logitech HID-compliant G5 Laser Mouse'
    Invalid Parameters -- try "/?" for help
    C:\Users\Matt>Powercfg -devicedisablewake "Logitech HID compliant G5 Laser Mouse"
    Invalid Parameters -- try "/?" for help
    C:\Users\Matt>Powercfg -devicedisablewake "Logitech?HID compliant G5 Laser Mouse"
    Invalid Parameters -- try "/?" for help
    C:\Users\Matt>Powercfg -devicedisablewake "Logitech*HID compliant G5 Laser Mouse"
    Invalid Parameters -- try "/?" for help
    C:\Users\Matt>powercfg -devicedisablewake *
    Invalid Parameters -- try "/?" for help
    C:\Users\Matt>powercfg -devicedisablewake all
    Invalid Parameters -- try "/?" for help


    So now, I get:
    C:\Users\Matt>Powercfg -devicequery wake_armed
    Logitech HID-compliant G5 Laser Mouse
    Logitech HID-Compliant Keyboard
    Logitech HID-compliant Cordless Mouse

    Ideas?
    Thursday, March 13, 2008 5:50 AM
  • Hi,

     

    I ran "Powercfg -devicequery wake_armed" on my computer and the result was "HID-complaint mouse (003)". Then I ran "Powercfg –devicedisablewake "HID-complaint mouse"" and it worked.

     

    Now I recommand trying "Powercfg –devicedisablewake "HID-complaint Keyboard"" or "Powercfg –devicedisablewake "Logitech HID-complaint Keyboard"" on your computer to test the result.

     

    Hope it helps.

     

    Tim Quan - MSFT

     

    Thursday, March 13, 2008 9:21 AM
    Moderator
  • I'm having a similar issue, though not so random - my system is waking every morning at 7am EST sharp. The only item I see in lastwake (or in the event viewer) is:

     

    Wake Source: RTC

     

    Should I assume that this has to be a software setting somewhere? I don't appear to have any scheduled tasks for that time, but maybe it's time to check again.

     

    Thoughts?

     

    Thanks.

     

    • Proposed as answer by tsengf Friday, April 17, 2009 6:11 AM
    Thursday, March 13, 2008 4:31 PM
  • Huh, I ran it again and got them all to shut off.  Not sure why it didn't work the first time.
    C:\Users\Matt>powercfg -devicequery wake_armed

    C:\Users\Matt>

    However, I'm noticing that it is still waking each morning at exactly 10:00am.  I did find that the windows time syncronizer turned itself back on and was firing at 10:00am - so I turned that back off as well. 

    In looking at the log, and is there any way to match the pid/GUID to a process that woke the computer?  Here is the power event log:

    - <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
    - <System>
      <Provider Name="Microsoft-Windows-Power-Troubleshooter" Guid="{cdc05e28-c449-49c6-b9d2-88cf761644df}" />
      <EventID>1</EventID>
      <Version>0</Version>
      <Level>4</Level>
      <Task>0</Task>
      <Opcode>0</Opcode>
      <Keywords>0x8000000000000000</Keywords>
      <TimeCreated SystemTime="2008-03-12T17:00:24.531Z" />
      <EventRecordID>29115</EventRecordID>
      <Correlation ActivityID="{69D5497B-7E5E-47C7-B47F-998C6526436C}" />
      <Execution ProcessID="1508" ThreadID="776" />
      <Channel>System</Channel>
      <Computer>Matt-PC</Computer>
      <Security UserID="S-1-5-19" />
      </System>
    - <EventData>
      <Data Name="SleepTime">2008-03-12T06:28:29.300Z</Data>
      <Data Name="WakeTime">2008-03-12T17:00:04.757Z</Data>
      <Data Name="SleepDuration">16297</Data>
      <Data Name="WakeDuration">3257</Data>
      <Data Name="DriverInitDuration">2993</Data>
      <Data Name="BiosInitDuration">476</Data>
      <Data Name="HiberWriteDuration">78665</Data>
      <Data Name="HiberReadDuration">0</Data>
      <Data Name="HiberPagesWritten">0</Data>
      <Data Name="Attributes">16403</Data>
      <Data Name="TargetState">4</Data>
      <Data Name="EffectiveState">5</Data>
      <Data Name="WakeSourceType">0</Data>
      <Data Name="WakeSourceTextLength">0</Data>
      <Data Name="WakeSourceText" />
      </EventData>
      </Event>

    Friday, March 14, 2008 3:16 AM
  •  

    Hi mattpf,

     

    Now let’s try the following steps to troubleshoot the issue:

     

    1.   Click Start, type regedit and press Enter.

    2.   Locate to the following key:

     

    HKEY_LOCAL_MACHINE\SOFTWARE\Polices\Microsoft\Windows\WindowsUpdate.

     

    3.   Right-click WindowsUpdate and click Export to back up the registry key.

    4.   Then right-click WindowsUpdate and delete the key.

     

    If the issue persists, please confirm if you have any USB devices such USB external drive connected to the computer. If so, please unplug them to check the result.

     

    Furthermore, please check your scheduled tasks to see if there is a task scheduled to run at the waked time.

     

    Hope it helps.

     

    Tim Quan - MSFT

    Friday, March 14, 2008 11:15 AM
    Moderator
  • Tim,

     

    Not sure if this was a reply to my query or mattpf's... If it was to mine, I don't have a Windows Update key in the path you listed above.

     

    Thanks,

     

    Josh

    Friday, March 14, 2008 12:58 PM
  •  

    Hi joshtee,

     

    Please also try to run “Powercfg -devicequery wake_armed” and let me know the result.

     

    In addition, I have performed a further research on this issue and it seems the Windows Home Server Connector software can be the cause. Please confirm if you have this program installed. If so, please uninstall it and check the result.

     

    If the issue still occurs, please unplug all unnecessary hardware devices such as video card, network card printer and USB external drives to test the issue.

     

    Hope it helps.

     

    Tim Quan - MSFT

    Monday, March 17, 2008 8:06 AM
    Moderator
  • Sorry about the delay, I have been very busy last few days.

    I went to that registry location, and the WindowsUpdate key was not was not present, so there was no need to delete it.  I have all the powercfg wake events turned off (as we did earlier), but it is still waking.  I'll try to unplug all my external devices before leaving tomorrow.  I have an external keyboard/mouse combo, an  eSATA hard drive plugged into the eSata interface, a laser printer (off most of the time),

    What is the best way to check for all scheduled tasks at a specific time.  I haven't found a good way to find those.  The fact it's waking at 10am every time kind of tells me it's a scheduled task...

    Matt
    Wednesday, March 19, 2008 12:25 AM
  • So, I unplugged all USB, eSATA and network cables from my computer after I put it to sleep.  The only thing remaining plugged in was the power cable.  Unfortunately, the computer still woke up during the day.  I get the following:

    C:\Users\Matt>powercfg -lastwake
    Wake History Count - 1
    Wake History [0]
      Wake Source Count - 0

    C:\Users\Matt>

    What is the best way to see all scheduled/program events that are keyed to wake the computer?  I believe it might be ehupdate that is causing it...
    Thursday, March 20, 2008 6:32 AM
  •  

    Thanks for those tips, but unfortunately, a no go... The Powercfg -devicequery wake_armed came back blank, and I don't have Windows Home Server...

     

    No extraneous hardware connected.

     

     

    Thursday, March 20, 2008 1:40 PM
  •  

    Hi mattpf and joshtee,

     

    Thank you for the reply.

     

    Now let’s perform a Clean Boot to test the issue.

     

    Clean Boot

    ========

    1. Click Start, type "MSCONFIG" (without the quotations) in the Search Bar and Press "Enter" to start the System Configuration Utility.

     

    Note: Please click Continue if the "User Account Control" window pops up.

     

    2. Click the "Services" tab, check the "Hide All Microsoft Services" box and click "Disable All" (if it is not gray).

    3. Click the "Startup" tab, click "Disable All" and click "OK".

    4. Restart the computer and test the issue.

     

    Note: Clean Boot is a troubleshooting step. If some programs have been disabled, we can re-enable them later. If you see the System Configuration Utility, check the box of "Don't show this message" and then click "OK".

     

    Please test this issue in the Clean Boot environment. if the issue disappears, we can use a 50/50 approach to quickly narrow down which entry is causing the issue.

     

    Please also check task scheduler items.

     

    Hope it helps.

     

    Tim Quan - MSFT

    Friday, March 21, 2008 7:55 AM
    Moderator
  •  

    Tim,

     

    I disabled all non-MS services, and it still woke up at 7am. *sigh*

     

    I had also checked all task scheduler items previously, and didn't see a thing.

     

    Thanks again for your help.

     

    jt

    Sunday, March 23, 2008 2:41 PM
  • JT,

     

    I tried this, and it seems to be working so far.  Did/do you happen to have a tv tuner card installed?  Some folks here were having trouble with the tv schedule downloader causing wakeups.   I saw that ehSched was always running at 10am when mine would wake up.  So I did this:

     

    start->Run 

    enter "services.msc" in the Open box, it should bring up the list of services on your pc.

     

    Scroll down to "Windows Media Center Scheduler Service"

    Select that service, and in the "General" tab, stop the service, and set the startup type to "disabled"

    Then, select the "Recovery" tab, and for first, second, and subsequent failures, select "Take No Action"

     

    It *seems* to be working, but I've not been home to test it thoroughly for a whole week.  See if that makes a difference for you...

     

    Matt
    Saturday, March 29, 2008 10:23 PM
  • Thanks Matt... Still not sure what the root of the problem was, but once I couldn't uninstall Vista SP1 RC, I had to reinstall Vista, and voila, everything is working (and sleeping) properly. Would have liked to know what the problem was, but at least it's working now...

     

    jt

    Sunday, March 30, 2008 12:48 AM
  • Hi,

    I have similar problems with my notebook HP dv6780ec, Windows Vista Home Premium SP1 . It randomly (automatically) wakes up from hibernation state at approx. 07:40 am.
    I have checked event viewer and have some fillings over the issue:
    1. The next scheduled download of the latest television listings guide (EPG) is 5/9/2008 7:39:41, Logged: 08/05/2008 07:40:18.
    2. The Windows Image Acquisition (WIA) service entered the running state. Logged 08/05/2008 07:40:16
    3. The system has resumed from sleep. Logged: 08/05/2008 07:40:20
    Sleep Time: 07/05/2008 23:19:53
    Wake Time: 08/05/2008 05:40:16
    Wake Source: Unknown
    4. Task Scheduler could not launch task "\Microsoft\Windows\Customer Experience Improvement Program\Consolidator"  as scheduled. Instance "{89194558-47e7-4a9e-b507-6c91ce4e6504}"  is started now as required by the configuration option to start the task when available, if schedule is missed. Logged: 07/05/2008 07:40:22
    5. Wireless security succeeded.
    Network Adapter: Intel(R) PRO/Wireless 3945ABG Network Connection
    Interface GUID: {52597ae1-3e04-4bb7-9c92-14c3c52e0f40}
    Local MAC Address: 00:1F:3C:01:6A:2C
    Network SSID: uk-simple
    BSS Type: Infrastructure
    Peer MAC Address: 00:1C:57:8A:19:B1
    Logged: 07/05/2008 07:40:22.

    There are no external devices connected to the notebook, notebook is not connected to LAN. Besides I have tried to disable the Wireless LAN to cure the problem and didn't succeed.
    Moreover I would like to inform you that I have drivers installed for TV-tuner supplied with the notebook (it is external one), but the TV-tuner is never plugged in during the night.

    I hope you can find the way to cure this problem.
    Many thanks in advance.


    Thursday, May 8, 2008 11:25 PM
  • Hi all!

    Well, it seems this topic has been aged a bit, but I have not seen a solution. I'm having the same issue, where the laptop will "spontaneously" resume from its wake state. Since I carry the laptop with me at all times, it actually caused my harddrive to fail (bumping into things while the laptop was doing stuff on the harddrive)

    Anyway, here's my details, so maybe I can get this solved:

    I'm running Windows Vista Premium SP1 on a HP/Compaq Pressario C742AE (C700 series). The powercfg -lastwake command gives me this:

    Wake History Count - 1
    Wake History [0]
    Wake Source Count - 1
    Wake Source [0]
    Type: Fixed Feature
    Timer Expired (RTC)


    The event viewer gives the same (Wake Source: RTC) at 15:00:07 with these added details:


    SleepTime 2008-09-09T04:59:32.391Z


    WakeTime 2008-09-09T14:00:03.145Z


    SleepDuration 37374


    WakeDuration 3647


    DriverInitDuration 456


    BiosInitDuration 263


    HiberWriteDuration 0


    HiberReadDuration 0


    HiberPagesWritten 0


    Attributes 24594


    TargetState 4


    EffectiveState 4


    WakeSourceType 3


    WakeSourceTextLength 0


    WakeSourceText

    (Yes, that's right... 5 am... I'm a night person ).

    Now the RTC is the Real Time Clock, part of the laptop itself, right? So is this essentially a BIOS issue, rather than with Windows Vista itself?
    Tuesday, September 9, 2008 4:51 PM
  • Hi,

    Just wanted to join the choir on people with Sleep issues in Vista MC.

    I'm also having my share of problems - RTC triggers wakeup, struggling with the user un-friendliness of Task Scheduler.

    My workaround is to use the little software MCE Standby Tool (MST), which acts as a configuration interface on some parameters discussed in this thread. And if it does not correct the root cause, it will limit the damage, by applying a neat function for "shut down within <set time> if no user activity".

    Just installed it on the second Vista mediacenter, to avoid the 3 am wake ups...

    As this thread has +4000 views, it may be an indication to Microsoft that there might be others experiencing similar issues as the 4-5 persons active in this thread.

    /Anders
    Sunday, February 8, 2009 10:46 AM
  • Some BIOSes have a RTC wake option. Disable it.
    Friday, April 17, 2009 6:14 AM
  • I am having the same problem with Win 7 RC 64bit, GA-EP35-DS3P F5 mobo, Radeon HD 4770 gfx with 9.7 drivers, and using the intel 1.07 motherboard raid 0.

    My computer wakes up randomly after being put to sleep, usually within 60 seconds!

    C:\Windows\system32>powercfg -lastwake
    Wake History Count - 1
    Wake History [0]
      Wake Source Count - 0

    It appears Windows does not know the source of the wake event.

    Problem only appeared after I added the Radeon HD4770.

    Its VERY annoying. I have had to disable sleep.
    Friday, July 24, 2009 7:13 AM
  •  

    Hi,

     

    Thank you for the reply.

     

    Now let’s try steps below:

     

    1.  Click Start -> All Programs -> Accessories.

    2.  Right-click Command Prompt and click Run as administrator.

    3.  Type the following commands and press Enter.

     

    Powercfg -devicedisablewake “Logitech HID-compliant G5 Laser Mouse”

    Powercfg -devicedisablewake “Logitech HID-Compliant Keyboard”

    Powercfg -devicedisablewake “Logitech HID-compliant Cordless Mouse”

    Powercfg -devicedisablewake “High Definition Audio Controller”

    Powercfg -devicedisablewake “eHome Infrared Receiver”

     

    Hope it helps.

     

    Tim Quan - MSFT


    Hi.
    I tried this on mine and it said "you do not have permission to enable or disable device wake"
    and yes, it's in admin mode.
    Friday, August 28, 2009 8:55 PM
  • I had the same problem, while I was troubleshooting I accidentally hit the "clear cmos" button on the back of my machine, that fixed the problem, not sure what setting it was but it worked, you might try setting your cmos settings to default.
    • Proposed as answer by IronSmithFE Friday, August 1, 2014 5:08 AM
    Friday, August 1, 2014 5:08 AM