Offline Files - TMP Files getting created and cannot be deleted RRS feed

  • Question

  • Hi,

    I already searched through alot of threads but could not find anyone having the exact same issue.

    We have a Windows Server 2008 R2 Enterprise with SP1 which is hosting a DFS Namespace.

    A customer of us works with his notebook (Win 7 SP 1) and has enabled Offline Files for his personal folder

    in the DFS path. The initial synchronisation seemed to work and no sync errors are reported in Sync Center.

    Now the problem is, everytime he opens a document from his DFS path and saves it, a .tmp file gets

    created there and doesnt disappear. Not even after reboot. As far as i know it happens with Word, Excel and PDF documents.

    If I log on to the server and browse to his path, i cannot see those .tmp files, only he can see it.

    If I try to delete those files from his notebook I get an error "File is no longer located in... Verify the item´s location and try again".

    What I have tried so far:

    If Offline Files get disabled, those .tmp files disappear. On activating they are visible again.

    Tried "Delete temporary files" from Sync Center -> Manage Offline Files -> Disk Usage. Nothing happened.

    I tried to repair Office, didn´t help.

    The only Group Policy Settings we have relating to Offline Files are "Synchronize all offline files before logging off"

    and "Allow or Disallow use of the Offline Files Feature" which is enabled.

    Would be nice if someone can get me into the right direction to fix this issue.

    If more information is needed let me know.

    Tuesday, May 17, 2016 12:34 PM

All replies

  • I have managed to solve the problem by adding a DWORD 32 Bit under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Csc\Parameters named "FormatDatabase" with value 1.

    After that i rebooted the notebook and the .tmp files were gone. I started synchronisation again and

    tried to save some documents, those .tmp files do not get created anymore.

    Tuesday, May 17, 2016 1:38 PM
  • Hi Hadgenen,

    Glad to hear that you have found a solution and thank you for sharing it here, it will be helpful to other community members who have same questions.

    Best regards,

    Carl Fan

    Please mark the reply as an answer if you find it is helpful.

    If you have feedback for TechNet Support, contact

    Wednesday, May 18, 2016 3:10 AM