none
Host Integration Server Application Integration -- Run a COBOL program on AS/400 RRS feed

  • Question

  • I am getting an error while making a connection to AS 400 system. Error is mentioned below. I am not sure, why it is erroring out and not able to figure out whether it is the problem on my end or AS 400 side. Could you please throw in some idea to resolve this. Any help is greatly appreciated.

    HISMDTT0010 The DPCTransport received a reply to a start server request with an incorrect length when processing method biztalkpoc. IP Address: 10.51.3.40, port: 446, reply length was 0 expected length is 0

    Steps followed:

    1) Created a Host Integration Application type project

    2) added .Net Client Library ( Host Language is set as COBOL)

    3) Imported Host definition using the .cblle file provided.

    4) Created an object in TI manager and Remote environment ( Distributed Program Call )

    Test:

    Created a console application and reference .Net Client library created, I am getting the mentioned error when I try to run the application

    What is target Host I need to select in this scenario?

    I am seeing the below mentione din Target Host drop down,

    CICS

    IMS

    System i Distributed Program Call

    System z

    System i

    Wednesday, November 7, 2012 3:55 PM

Answers

  • As a follow-up to this, the password error was resolved as follows:

    The AS/400 was running OS/400 V5R4 and it had the following settings on the AS/400 side:

    - QPWDLVL=0

    - Security Level = 40

    QPWDLVL was changed from 0 to 2 and that resolved the problem.

    Thanks...


    Stephen Jackson - MSFT

    Monday, November 19, 2012 4:48 PM

All replies

  • I changed the port number to 8475, and then it started giving me the following error.

    HISMDTT0008 The DPCTransport received a start server reply indicating a failure while processing method biztalkpoc. IP Address: xx.xx.x.xx, port: 8475, Primary error code 3, Secondary error code 13, error description Pre V2R2 encrypted password

    When I pass in the incorrect password, it gives the following error message

    HISMDTT0008 The DPCTransport received a start server reply indicating a failure while processing method biztalkpoc. IP Address: xx.xx.x.xx, port: 8475, Primary error code 3, Secondary error code 11, error description Password incorrect

    So, I am not sure whether it is the problem with establishing connection or not. I am not getting any clue, what this Pre V2R2 encryption is :(

    Any help is greatly appreciated!!!

    Thursday, November 8, 2012 4:59 PM
  • when I use port 8475,

    HISMDTT0008 The DPCTransport received a start server reply indicating a failure while processing method biztalkpoc. IP Address: xx.xx.x.xx, port: 8475, Primary error code 3, Secondary error code 13, error description Pre V2R2 encrypted password

    when I use port 8476,

    *SIGNON server job 361290/QUSER/QZSOSIGN processing request for user 
      BIZTALKD on 11/08/12 17:13:45 in subsystem QUSRWRK in QSYS. 
    A connection with a remote socket was reset by that socket. 
    Host server communications error occurred on recv() - length - TCP-.  

                            Additional Message Information 
                                                                                   
    Message ID . . . . . . : CPIAD08 Severity . . . . . . . : 40 
    Message type . . . . . : Diagnostic 
    Date sent . . . . . . : 11/08/12 Time sent . . . . . . : 17:14:40 
                                                                                   
    Message . . . . : Host server communications error occurred on recv() - 
      length - TCP-. 
    Cause . . . . . : Error code 3426 was received while processing the recv() - 
      length - TCP- function for the host server communications. 
    Recovery . . . : See any previously listed message(s) to determine the 
      cause of the error; if necessary, correct the error and issue the request 
      again.
    Friday, November 9, 2012 4:15 PM
  • As a follow-up to this, the password error was resolved as follows:

    The AS/400 was running OS/400 V5R4 and it had the following settings on the AS/400 side:

    - QPWDLVL=0

    - Security Level = 40

    QPWDLVL was changed from 0 to 2 and that resolved the problem.

    Thanks...


    Stephen Jackson - MSFT

    Monday, November 19, 2012 4:48 PM
  • Windows Server 2008 is using NTLMV2 security where as iSeries is on NTLM security. Due to this reason QPWDLVL has to be changed to 2 to support extended security. Is there any work around for this with out changing the settings on iSeries and instead change it Windows Server 2008. I tried to change LAN Manager Authentication level , but of no use. Any suggestions?

    Wednesday, April 10, 2013 8:55 PM
  • The NTLM setting on the Windows Server doesn't impact the userid/password being sent to the AS/400 from Transaction Integrator because NTLM authentication is not used in this scenario.

    This is the only time that I have ever seen this come up and we have had customers using TI for many years. When communicating with an AS/400 (iSeries), TI communicates with DPC as outlined in http://msdn.microsoft.com/en-us/library/gg163957.aspx.

    Thanks...


    Stephen Jackson - MSFT

    Wednesday, April 17, 2013 9:52 PM
  • Setting the PWDLVL to 2, which allow for not only a 128 character passphrase but it also allows for case sensative password and allows the new security that Windows is using.

    Windows XP defaults to only use NTLM or NTLMv2 encryptions. Windows 7 changed its default client security policy to use NTLMv2 authentication and has completely disabled the use of LanMan (LM) password encryption. As a result, a case-insensitive password can not be sent from Windows 7.

    This is what I found after doing some research.

    http://www-912.ibm.com/s_dir/SLKBase.nsf/1ac66549a21402188625680b0002037e/6c1e1e33e5a34e3d862570a700576b6a?OpenDocument

    Any suggestions to work around this?


    Thanks, Pavan MCTS-Microsoft Biztalk Windows Server 2010

    Thursday, April 18, 2013 8:34 PM
  • What format of password are you sending to the AS/400?


    Stephen Jackson - MSFT

    Friday, April 19, 2013 8:32 PM
  • It is alpha-numeric password with all upper case

    Thanks, Pavan MCTS-Microsoft Biztalk Windows Server 2010

    Friday, April 19, 2013 8:38 PM
  • Transaction Integrator passes the username and password that is passed to it via a header as part of the DPC communication process. NTLM authentication is not used in this process. I'm not sure why this is impacting the AS/400 password level, but it may have to do with the requirements of DPC on the AS/400. You might want to ping IBM to see if they can address that side of things.

    Thanks...

     


    Stephen Jackson - MSFT

    Monday, April 22, 2013 7:25 PM
  • Hello Steve,

    I am getting an error while making a connection to AS 400 system from BizTalk using Host Apps adapter.

    Steps followed are :

    1) Created a Host Integration Application type project

    2) added .Net Client Library  --> consumed the HIS program (in AS 400 ) which created the schema

    3) Created an object in TI manager and Remote environment ( Distributed Program Call )

    4) we used the schema which gets generated in step no:2, in the BizTalk application and triggered the input to the HIS program using Host Apps adapter.

    we are using port no:8475

    Error is :

    1. HISETBG0001 Application Integrator has intercepted an exception in method AMMGIDR01. Following is the exception description: HISMDTT0006 The DPCTransport received a socket error while attempting to receive user data when processing method AMMGIDR01. IP Address: 172.22.11.16, port: 8475, program name: AMMGIDR01, Error description: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond

    Thanks in Advance

    Monday, June 10, 2013 8:00 AM
  • Hi,

    Are you able to solve this issue?

    I got exactly the same error.


    vaibhav

    Friday, February 3, 2017 5:58 PM