none
set limit for attachment

    Question

  • hi all , 

    how can i set a limit for attachment on exchange email for specific group on Exchange 2013 ? 

    i need to set the limit of attachment not to be more that 50 MB 

    Wednesday, January 13, 2016 12:51 PM

Answers

  • Hi, JavaHeart

    That's command should work for message sent to Distribution group, not the members of distribution group. If you want to limit attachment size of messages sent to members of distribution, then try transport rule.

    Since you want to limit send/receive message, then I edit my transport rule.

    Change the limit back on Organizational Transport setting before testing this rule.

    Best Regards.


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com

    Lynn-Li
    TechNet Community Support

    Monday, January 18, 2016 8:55 AM
    Moderator

All replies

  • You can control the size of the message as a whole and/or individual attachments. You can also control this on several levels - transport config to individual users. Groups included. You can find the overview of available settings here: https://technet.microsoft.com/en-us/library/bb124345(v=exchg.150).aspx

    If you want to set this on all members of particular group, simply expand the group membership and use the Set-Mailbox cmdlets against each individual member.

    Wednesday, January 13, 2016 4:11 PM
  • Hi,

    The only way to configure attachment size limit in exchange 2013 is transport rule.

    If you mean you want to limit the attachment size of messages sent to one specific group, unfortunately, we can't add distribution group to condition "The recipient is..." If in this case, the workaround is to configure the max size limit on this distribution group with the following command:

    Set-DistributionGroup <Identity> -MaxReceiveSize 50MB

    If you mean you want to limit the attachment size of messages sent to members of one one specific group, then you can configure the transport rule like this:

    Best Regards.


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com

    Lynn-Li
    TechNet Community Support

    • Proposed as answer by Shane Jackson Thursday, January 14, 2016 9:38 AM
    Thursday, January 14, 2016 8:58 AM
    Moderator
  • Hi,

    The only way to configure attachment size limit in exchange 2013 is transport rule.

    If you mean you want to limit the attachment size of messages sent to one specific group, unfortunately, we can't add distribution group to condition "The recipient is..." If in this case, the workaround is to configure the max size limit on this distribution group with the following command:

    Set-DistributionGroup <Identity> -MaxReceiveSize 50MB

    If you mean you want to limit the attachment size of messages sent to members of one one specific group, then you can configure the transport rule like this:

    Best Regards.


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com

    Lynn-Li
    TechNet Community Support

    hi lynni , 

    i have set the command as mention above for the Set-DistributionGroup <Identity> -MaxReceiveSize 50MB and no effect the member  of the distributed group are unable to send more than 30 MB , but when change the Organizational Transport setting it works but not only for this group for all company . i need to set only for this group to send and receive 50 MB from owa and outlook .

    Monday, January 18, 2016 6:46 AM
  • For any message size limit, you need to set a value that's larger than the actual size you want enforced. This accounts for the Base64 encoding of attachments and other binary data. Base64 encoding increases the size of the message by approximately 33%, so the value you specify should be approximately 33% larger than the actual message size you want enforced. 

    You can't enable send message size limit for group, you can do it only for every mailbox in this group.

    Set-Mailbox "Debra Garcia" -MaxSendSize 50mb -MaxReceiveSize 50mb


    Monday, January 18, 2016 7:37 AM
  • Hi, JavaHeart

    That's command should work for message sent to Distribution group, not the members of distribution group. If you want to limit attachment size of messages sent to members of distribution, then try transport rule.

    Since you want to limit send/receive message, then I edit my transport rule.

    Change the limit back on Organizational Transport setting before testing this rule.

    Best Regards.


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com

    Lynn-Li
    TechNet Community Support

    Monday, January 18, 2016 8:55 AM
    Moderator