Windows Update error Code 80240016 and Code 80070002 RRS feed

  • Question

  • Hi,

    Windows updates are not getting installed in one of  the Windows 7 Enterprise Edtion 32 bit machine. Downloaded updates and tried to install also did not install. I have followed few methods and it did not help. please help to solve the issue. 

    Uploaded the Windows Update log in the!Aj2wii50lHANhHXE907VrpSPvHyb

    Method 1

    Executed the below command as administrator 

    net stop wuauserv
    ren SoftwareDistribution  SoftwareDistribution.oldd
    net start wuauserv
    Wuauclt.exe /scannow
    wuauclt.exe /resetauthorization
    wuauclt.exe /updatenow
    net start wuauserv

    Method 2

    Executed the below command as administrator 

    sc config winmgmt start= disabled
    net stop winmgmt /y
    cd %windir%\system32\wbem
    ren Repository Repository.old
    sc config winmgmt start= auto
    net start winmgmt

    Regards, Boopathi

    Monday, June 4, 2018 5:52 AM

All replies

  • Hi,

    Have you tried to manually install the updates?

    If still fails, try to use the tool named System Update Readiness Tool, and see if it can repair the corrupted component store. It will generate the log, you can also upload them to the Onedrive


    Download link:

    From the windows update log, I noticed 

    Agent WARNING: WU client fail to launch remote handler process with error 0x80070002
    2018-06-04 06:57:31:650 1072 11cc Agent LogHistory called. idUpdate={E181EAEF-054E-4B52-A00F-503B91461F68}.201, resultMapped=80070002, resultUnMapped=0

    Seems that it is related to corrupted registry or missing packages in component store. For further research, we need more info, please help us collect the cbs log and upload them.

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact

    Tuesday, June 5, 2018 2:55 AM
  • Hi,

    Thanks for your reply, 

    Downloaded System Update Readiness Tool (Windows6.1-KB947821-v34-x86.msu and Windows6.1-kb958690-x86.msu) but it is not getting installed and giving the same error. I have uploaded the CBS log in the below link.!Aj2wii50lHANhHsxjwEj6eKzmexD

    Pleaese check ane help me.

    Regards, Boopathi

    Tuesday, June 5, 2018 9:59 AM
  • Hi,

    Please try running the SFC /SCANNOW from an elevated Admin command prompt and verify if any file system integrity is there. If so then it has to be repaired.

    Also try to run the chkdsk command on systemdrive for any file system error.

    Check in the folder C:\Windows\winsxs if the files "reboot.xml" & "poqexec.log" file exists. If so then first take the ownership of the files first and then remove them from that folder. Reboot the server and then try installing the patches again.




    Tuesday, June 5, 2018 10:40 AM
  • Hi,

    Still getting the same error

    Regards, Boopathi

    Wednesday, June 6, 2018 5:57 AM
  • Hi,

    Which kb did you fail to install?

    According to my research, the error “80240016” usually means “another installation is in process”. The error “0x80070002”means “file not found”, a general code.

    Since we have tried to download and install the update manually, what is the exact error message we have got when we installed the update manually? I believe there should be one error code if you manually installed them.

    I noticed we have ran “sfc” and “checksur”. Did them run well or have we got any error message when we ran them?

    It is suggested that you can uninstall all the 3-party antivirus software.

    1.First of all, we could restart the machine to make all previous updates installed to take effect.

    2.Take the following steps:

    a.Check whether HKEY_LOCAL_MACHINE\COMPONENTS existed. If it is existed, backup and delete it manually.

    b.Check whether pending.xml existed in C:\Windows\WinSXS. Backup and delete.

    c.Check HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\ComponentBased Servicing, press Ctrl+F, search for the KB number we have installed manually.

    If we have found any related registry keys, backup and delete them.

    3.If the issue persists, please help to collect the following log to analyze the issue deeply.

    Event Viewer\Windows Logs\Application, System, Setup

    a.Restart the machine.

    b.Delete previous the cbs.log. (If we got the cbs.log is accessed by other process, open an administrator command line and run “net stop wuauserv”. After clearing the log, run “net start wuauserv”).

    c.Install the update. (Check whether the error occur during the installing process)

    d.If the update was installed correctly, restart the machine to check whether the update was applied correctly.

    e.Restart the machine.

    f.Upload the whole cbs.log (C:\Windows\Logs\CBS) folder

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact

    Thursday, June 7, 2018 9:04 AM
  • What is going on?

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact

    Tuesday, June 12, 2018 8:20 AM
  • Try the link below:

    Every second counts..make use of it. Disclaimer: This posting is provided AS IS with no warranties or guarantees and confers no rights.

    Tuesday, June 12, 2018 9:01 AM
  • Hello Vivian_zhou

    Error code is same which mentioend in the subject. 

    Hello Cguan,

    I am yet to check the Windows update reset tool

    Regards, Boopathi

    Monday, June 18, 2018 3:34 PM