locked
SQL Management Pack Failing on old SQL Agent Jobs RRS feed

  • Question

  • I just got an alert today (10/21) from my SQL Agent Job monitor:

        SQL Server Scheduled Job 'GroomAggregations' (0x60D7D23AF0C10E4CB1CE09A4ED219431) - Status: Failed - Invoked on: 2009-07-09 02:00:00 - Message: The job failed. The Job was invoked by Schedule 13 (Schedule 1). The last step to run was step 1 (Job step 1).

    I don't know why that is, but it is returning to me errors on old jobs that ran a while ago. Explanation? Way to stop this from happening?
    Wednesday, October 21, 2009 2:27 PM

Answers

  • Is this a very old event based alert?  As in - new alert - but really old event?  Look on the alert context tab.

    By chance - did you recently take this server out of maintanence mode?  We are tracking a transient issue where when some servers come out of MM they re-read the entire event log.
    • Marked as answer by Graham Davies Tuesday, November 3, 2009 8:31 AM
    Tuesday, November 3, 2009 2:36 AM

All replies

  • Is this a very old event based alert?  As in - new alert - but really old event?  Look on the alert context tab.

    By chance - did you recently take this server out of maintanence mode?  We are tracking a transient issue where when some servers come out of MM they re-read the entire event log.
    • Marked as answer by Graham Davies Tuesday, November 3, 2009 8:31 AM
    Tuesday, November 3, 2009 2:36 AM
  • Something tells me yes - it was in MM and it finished. I will keep tabs and let you know.
    Tuesday, November 3, 2009 6:53 AM
  • In case that is your issue - the only workaround at this point - is posted at the following location:

    http://blogs.technet.com/operationsmgr/archive/2009/10/07/when-taking-agent-out-of-maintenance-mode-old-events-are-reprocessed-and-new-alerts-generated.aspx

    Resolution: There are three potential workarounds for this issue:

    1. Clear the event log prior to putting a machine into Maintenance Mode.

    2. Manually setup overrides to ignore the events.

    3. Add the following registry key:

    HKLM\Software\Microsoft\Microsoft Operations Manager\3.0\Modules\Global\NT Event Log DS

    Create a DWord value named MaxEventBufferSize and set it to a decimal value of 500000.

    Tuesday, November 3, 2009 1:59 PM