locked
Route ALL voice traffic via external PBX RRS feed

  • Question

  • Hello,

    Is it possible to disable the Lync "internal voice routing" and instead make Lync always send all voice communication via the external pbx? Even if both client a and b are logged in to the same Lync server.


    Tuesday, August 20, 2013 11:58 AM

Answers

  • If you're looking to stop lync from matching a PSTN number to the Line URI of a Lync user, you can add ";ms-skip-rnl" to the end of the user's line uri to prevent the reverse address book lookup. 
    Example: tel:+4031234567;ext=1024;ms-skip-rnl

    You can also look at RCC: http://technet.microsoft.com/en-us/library/gg558658(v=ocs.14).aspx
    • Proposed as answer by Kent-Huang Wednesday, August 21, 2013 3:01 AM
    • Marked as answer by Kent-Huang Monday, August 26, 2013 7:01 AM
    Tuesday, August 20, 2013 2:36 PM
  • Confirm the number coming in from the PBX is being translated to match the line uri of the user exactly.
    • Marked as answer by Kent-Huang Monday, August 26, 2013 7:02 AM
    Wednesday, August 21, 2013 2:26 PM

All replies

  • If you're looking to stop lync from matching a PSTN number to the Line URI of a Lync user, you can add ";ms-skip-rnl" to the end of the user's line uri to prevent the reverse address book lookup. 
    Example: tel:+4031234567;ext=1024;ms-skip-rnl

    You can also look at RCC: http://technet.microsoft.com/en-us/library/gg558658(v=ocs.14).aspx
    • Proposed as answer by Kent-Huang Wednesday, August 21, 2013 3:01 AM
    • Marked as answer by Kent-Huang Monday, August 26, 2013 7:01 AM
    Tuesday, August 20, 2013 2:36 PM
  • Hi Mr-Andersson,
    Is there any result oafter adding ms-skip-rnl to the end of the user's line uri?

    Kent Huang
    TechNet Community Support

    Wednesday, August 21, 2013 3:02 AM
  • Hello, we will try this today and I will get back with the results, thank you for your help.
    Wednesday, August 21, 2013 6:47 AM
  • Yes, this works, only a little too well.

    The call is now routed to the external PBX. Then the PBX routes the call back to the Lync server. But this is where the Lync server once again routes the call back to the PBX instead of sending it to the receiver on the same Lync server via the PBX.

    Also external calls stops working since the Lync server just routes the call (SIP Invite) back to the PBX and so on...

    Do you think it is possible to only set/have this flag on calls which is initiated from the Lync client, and not have it match for "external" calls comming in to the Lync server?

    Maybe by using MSPL to only match Lync initiated SIP Invites?



    • Edited by Mr-Andersson Wednesday, August 21, 2013 12:22 PM
    Wednesday, August 21, 2013 12:21 PM
  • Confirm the number coming in from the PBX is being translated to match the line uri of the user exactly.
    • Marked as answer by Kent-Huang Monday, August 26, 2013 7:02 AM
    Wednesday, August 21, 2013 2:26 PM