locked
VPN won't connect RRS feed

  • Question

  • The regular community answers forum wouldn't accept my post (gave me an error message about the wrong number of characters), so I am visiting here. Hope that's OK.

    I am trying to connect to my home W10 Pro machine with a remote W7 Pro laptop using the Windows VPN. I am sure both the client VPN connection and host incoming connections have been set up correctly. My router forwards port 1723 to the host IP. The router incoming log confirms this. All router VPN pass through options are enabled. The router help page says all common VPN protocols are enabled by default, which I assume includes GRE/protocol 47. The host machine event viewer reports two RemoteAccess 20063 errors on bootup relating to Remote Access Connection Manager, Protocol engine not initiating, rasgreeng.dll and IKEv2. RACM, however, is running and set to auto as are the Remote Access Auto Connection Manager and the Secure Socket Tunneling Protocol services. Connection attempts from the laptop produce no new events in the viewer. Turning off firewalls in the router and host machine and anti-virus protection on the host machine does not help. Nor does rebooting the router, cable modem and both machines.

    On the laptop, when the VPN "type of VPN" property is set to automatic, I get the VPN Error 800 message "The remote connection was not made . . . " and a RasSstp Event ID 1 in the event viewer. When the VPN type is limited to PPTP, I get a VPN Error 807 almost immediately with no new event viewer messages. The RACM is running set to manual. The RAACM is running, set to auto. The SSTPS is running, set to manual. It appears to me the client connection request is getting to the host, but the host is turning a deaf ear. Any suggestions on how to fix this are truly appreciated.

    Best, Bob

    Thursday, November 16, 2017 4:43 PM

Answers

  • Thanks so much for the advice. It's fixed. The problem was a combination of two factors. First, the Windows 10 updates were a problem. They were installed the day before this issue appeared. I could only uninstall one of them and that did not work. Fortunately, another update appeared last night. I installed both it and the removed update, and things got better. The connection was established but could not be completed due to a GRE error - RasMan Event ID 20209 on the host machine.

    Second, in order to test the VPN even though both machines are in the same room, I had to connect my client laptop to an xfinitywifi network in the neighborhood. That arrangement was not working although I could once again, after updating the host, establish a VPN connection with my phone. So, I tethered my laptop via Bluetooth to my phone, turned off the laptop and phone wi-fi and was able to establish a VPN connection through my phone's cellular/mobile network. Apparently, xfiniftywifi does not support GRE/protocol 47. Something to remember when searching for a hotspot.

    I hope this experience helps others in the future.

    Best,

    Bob

    Friday, November 17, 2017 2:37 PM

All replies

  • I need to supplement this information with the fact that I was able to connect to my Colorado W10 host from Austin, TX on November 6 and had not tried to do so again until November 15, when the attempt failed. I changed nothing in either the laptop or desktop configuration in the interim. Also, I can no longer connect my Android phone to the W10 desktop VPN host although I cannot recall just when the last successful phone VPN connection occurred. So, I suspect the culprit is the W10 desktop, most likely an uninvited update installed late November 6 or sometime since.

    Best,

    Bob

    Thursday, November 16, 2017 11:37 PM
  • Yes, Bob, your idea is reasonable.

    Uninstall the latest updates from Control Panel to check result.

    For VPN 800 error, general troubleshooting thread:

    Enable the PPTP Port (TCP 1723) and GRE Port (47) for VPN Connection.

    Now go to VPN Properties > Security > Type of VPN and set VPN Connection type to PPTP.

    Check the VPN IP Address once again and delete “http://” and “/” from the server address.

    Also, try capture a network trace by network monitor, see if it will help to determine the root cause of this issue.

    Regards


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, November 17, 2017 7:35 AM
  • Thanks so much for the advice. It's fixed. The problem was a combination of two factors. First, the Windows 10 updates were a problem. They were installed the day before this issue appeared. I could only uninstall one of them and that did not work. Fortunately, another update appeared last night. I installed both it and the removed update, and things got better. The connection was established but could not be completed due to a GRE error - RasMan Event ID 20209 on the host machine.

    Second, in order to test the VPN even though both machines are in the same room, I had to connect my client laptop to an xfinitywifi network in the neighborhood. That arrangement was not working although I could once again, after updating the host, establish a VPN connection with my phone. So, I tethered my laptop via Bluetooth to my phone, turned off the laptop and phone wi-fi and was able to establish a VPN connection through my phone's cellular/mobile network. Apparently, xfiniftywifi does not support GRE/protocol 47. Something to remember when searching for a hotspot.

    I hope this experience helps others in the future.

    Best,

    Bob

    Friday, November 17, 2017 2:37 PM
  • Glad to hear that this issue has been resolved by you.

    Thank you for sharing, please mark your reply to close this case


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, November 28, 2017 8:45 AM