locked
Office365 Outlook advanced ETW always activated in RDS-farm RRS feed

  • Question

  • We have two remotedesktop servers with Microsoft Office.

    OS: Windows Server 2019
    MSO: 365 ProPlus shared licensing

    Both of the servers have huge I/O-load because of outlook.exe working in userprofile\localappdata\temp\..\outlook logging\OUTLOOK-date-time-v2.etl

    Relevant threads:
    https://support.office.com/en-us/article/what-is-the-enable-logging-troubleshooting-option-0fdc446d-d1d4-42c7-bd73-74ffd4034af5
    https://support.microsoft.com/en-us/help/2862843/how-to-enable-global-and-advanced-logging-for-microsoft-outlook

    No outlook has the "Enable troubleshooting logging"-option selected. No Registry Keys were set. It even happens for a user that I just created with 0 data and 0 mailstore. There was no "debugmode" or anything similar selected when MSO was deployed via xml.

    It happens on both servers. I cannot get it to stop logging. Is there another way?

    We have a similar installation (WinSrv 2016 with one RDS with MSO 2016 Standard). There we do not have any problems with I/O-traffic because of logging

    • Moved by Perry-Pan Thursday, November 21, 2019 2:13 AM
    Wednesday, November 20, 2019 12:02 PM

All replies

  • Does it happen to all clients on RDS? Only happen to Office 365 client?

    How do you deploy the installation of Office 365?

    We can run following command in Command Prompt to check the policy on the client:

    Gpresult /H GPReport.html

    The report will be normally saved in User folder: C:\Users\<username> Check if any policy was enabled to force Outlook logging.

    Besides, if no registry was showing in that path, we can manually create these keys to disable them. Set the value to 0:

    (Important Follow the steps in this section carefully. Serious problems might occur if you modify the registry incorrectly. Before you modify it, back up the registry for restoration in case problems occur.

    Subkey: HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\xx.0\Outlook\Options\Shutdown
    
    DWORD: FastShutdownBehavior
    
    Value: 0


    Subkey: HKEY_CURRENT_USER\Software\Microsoft\Office\xx.0\Outlook\Options\Mail
    
    DWORD: EnableLogging
    
    Value: 0


    Subkey: HKEY_CURRENT_USER\Software\Microsoft\Office\xx.0\Outlook\Options\Mail
    
    DWORD: EnableETWLogging
    
    Value: 0


    Subkey: HKEY_CURRENT_USER\ Software\Microsoft\Office\xx.0\Outlook\Options
    
    DWORD: EnableConflictLogging
    
    Value:  0

    Regards,

    Perry

    • Edited by Perry-Pan Thursday, November 21, 2019 2:32 AM
    • Proposed as answer by Perry-Pan Saturday, November 23, 2019 2:37 AM
    Thursday, November 21, 2019 2:30 AM
  • I'm wondering if there are anything else I can do for you.

    Regards,

    Perry


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Saturday, November 23, 2019 2:38 AM
  • Here I will provide a brief summary of this post for your information.

      

    [Issue Symptom:]

    ====================

    Outlook keeps generating logging files even when "Enable troubleshooting logging" option is not selected.

          

    [Troubleshooting Steps so far:]

    ====================

    1. Check the policy on these clients via following command

    Gpresult /H GPReport.html

    2. Disable logging via registry

         

    [Reference Links:]

    ====================

     https://support.microsoft.com/en-us/help/2862843/how-to-enable-global-and-advanced-logging-for-microsoft-outlook

    • Edited by Perry-Pan Tuesday, November 26, 2019 7:56 AM
    Tuesday, November 26, 2019 7:56 AM