none
Unable to install DPM protection agent (ID:304 and Error 331) RRS feed

  • Question

  • Hi,

    I understand that there are many questions related to installing DPM protection agent, but I can't seem to find any that is similar to what we are facing now.

    We upgraded the DPM to version 4.1.3417.0, but some of the protection agents have problem updating to the new version.

    As such, we thought of reinstalling the protection agents manually.

    The agents were removed, both from the DPM and the protected servers.

    When we try to install the protection agent via the DPM console, we receive the following error message:

    The protection agent operation failed because another agent operation was running on <protected server name> [ID:304]
    Wait for the protection agent operation on <protected server name> to finish, and then try reinstalling the protection agent.

    However, when we checked, there appears to be no apparent DPM processes running on the protected server.

    We even restarted the server that we wish to protect, but ID:304 still comes up.

    Then, we also tried to install the protection agent via the DPM console, but this time without specifying the domain name on the "Select Computers" page.

    However, when we click on "Install" (after entering credentials), the task failed, and the error message is:

    Install protection agent on <protected server name> failed:

    Error 331: The agent operation was skipped because similar operation is already running on <protected server name>.

    Recommended action: Wait for the other operation to finish and then retry the operation.

    As mentioned earlier, the server has been restarted, and there shouldn't be another agent operation running.

    We also tried to install the agent manually, and later to attach it onto DPM.

    We could do this successfully, but the agent status in the DPM console is stuck at "Attempting connection" with no further progress.

    We have also tried the SetDpmServer command, it runs well, gives a positive result, but still we couldn't get the agent status to appear as OK.

    Thank you for helping.


    • Edited by abellim Wednesday, September 11, 2013 11:37 AM
    Wednesday, September 11, 2013 11:37 AM

All replies

  • We are experiencing the exact same issue with one server we are trying to back up.  The interesting is that if we try and install the agent from another DPM server, it too says their is already an installation taking place.  This is after rebooting the client server.  So that leads me to believe that something must be being written to the client server that we are trying to install the DPM agent on.  The question is, what and where is it being written and how do we make it forget?
    Wednesday, September 25, 2013 5:39 PM