locked
App-V 4.6 Standalone Installation RRS feed

  • Question

  • Hi ,

    We are migrating from App-V full infrastructure to Standalone method of installation . Currently the applications are published via App-V managamnet server and not all apps are 100% cached . App-V clients are NLB configured .  When are deploying the same applications through Altiris using.msi .

    Below are the steps we are following for the migration:-

         1:-Deploy the applications via Altiris

         2:-Run the standalone script which updates the below registry keys , changed the EnV Variable from NLB value to different Value (DONOTREMOVE) and Deleted the publishing server from the App-V Client

                      HKLM\...\Configuration\ AllowIndependentFileStreaming 1
                  HKLM\...\Configuration\ RequireAuthorizationIfCached 0
                  HKLM\...\Network\ AllowDisconnectedOperation        1
                  HKLM\...\Network LimitedDisconnectedOperation 0  

    App-V Client version :- 4.6 SP1

    Application details :-  Published application is 4.5 sequenced. For standalone we reimported the application on the 4.6 sequencer and saved the application to support 4.6 SP1 Standalone  .

    When we launch the applications we are getting below error messages:-

    "Host Name resolution failed for the server"

    "The launch was cancelled during authentication"      .

    One of my obervation is,applications deployed via Altiris using .msi file , the cache should be 100% but which is not. When I reinstall the same application manually application works as expected and it is getting 100%.

    why it is not getting 100% cached.?

    Please provide me a solution for errors messages and cache issue during standalone installaion . 

    Thanks

    Vivek


    Sunday, March 24, 2013 2:17 AM

Answers

  • I know there was an issue with the sequencer (at least with version 4.5) and the way that the generated MSI determines the path to the SFT. The SFT file is stored externally next to the MSI.
    I found that when running the MSI manually this works fine but when I deployed via SCCM 2007 the path could not be determined and the SFT was thus not loaded into the cache. There may be a similar issue when deploying via Altiris.

    I thought that this issue did no longer exist with 4.6 but since your sequences were originally created with 4.5, it may be that the problem persists.

    The way I solved this was to create an MST for the created MSI’s. This MST makes the following changes to the MSI:

    It adds a VbScript to the binary table which uses the SOURCEDIR property to set the SFTPATH property.

    VbScript source:

    SftPath = Session.Property("SOURCEDIR") & Session.Property("SFTNAME")
    SftPath = Replace(SftPath, "\", "\\")
    Session.Property("SFTPATH")= SftPath

    It adds a custom action to execute the added script called GetSFTPATH

    It disables the original custom action ‘UpdateSftPath’ which does not correctly set the SFTPATH property.

    It adds the ‘ResolveSource’ default MSI action, just after the original ‘UpdateSftPath’ action in the InstallExecuteSequence of the MSI.

    It also adds the ‘GetSFTPATH’ custom action after the ‘ResolveSource’ action.

    When using this MST together with the MSI I found that deployment of the MSI using SCCM 2007 now correctly added the SFT to the cache.

    Click here to download the MST I created: MST on my Public SkyDrive

    Hope it helps.

    KR,
    Casper









    Wednesday, March 27, 2013 9:42 AM

All replies

  • hello,

    I would remove the environment variable


    Nicke Källén | The Knack| Twitter: @Znackattack

    Sunday, March 24, 2013 7:15 AM
  • You may also need to set the ApplicationSourceRoot property to a valid location (where the packages are stored).

    What is the command line you're using in Altiris Deployment Solution?



    Please remember to click "Mark as Answer" or "Vote as Helpful" on the post that answers your question (or click "Unmark as Answer" if a marked post does not actually answer your question). This can be beneficial to other community members reading the thread.


    This forum post is my own opinion and does not necessarily reflect the opinion or view of my employer, Microsoft, its employees, or other MVPs.

    Twitter: @stealthpuppy | Blog: stealthpuppy.com | The Definitive Guide to Delivering Microsoft Office with App-V

    Sunday, March 24, 2013 10:00 AM
    Moderator
  • We are using windows installer command (msiexec /i <>) for installing the package . When deployed via Altiris application get downloaded to the location machine and then the application gets installed.
    Sunday, March 24, 2013 2:45 PM
  • Still facing the same issue ,In App-V Client , Application Path " local OSD File: " is still has to the old OSD file and not getting replaced with the new application OSD file installed via Altiris.

    When I manually install the Application with system or user context , In App-V Client " local OSD File:" is getting replaced with new OSD file and the application is working as expected .

    Any suggestions...

    Tuesday, March 26, 2013 6:58 AM
  • Hello,

    Quoting myself again;

    hello,

    I would remove the environment variable


    Nicke Källén | The Knack| Twitter: @Znackattack

    Tuesday, March 26, 2013 9:11 AM
  • In addition to the above mentioned, try setting HKLM\...\Network: Online to 0.

    In all other cases, the App-V client still tries to connect to an App-V Management Server for Authorization.

    I think it was Tim Mangan how reported that NOT setting Online to 0 even may cause situations were fully chached applications were not available for users (because the client connected to the Management Server, that reported 'no access' and hence the user was denied access)



    Falko

    Twitter @kirk_tn   |  Blog kirxblog   |  Web kirx.org

    Tuesday, March 26, 2013 10:01 AM
    Moderator
  • Removing of Environment Variable throw-ed an error as the package has %SFT_SOFTGRIDSERVER% . I had to provide value for Env Variable hence retained it.

    Tried Online = 0 also , It displays as disconnected operations mode. My requirement is I should have online=1 as we have separate App-V reporting servers  configured on all the clients . Which will report the App-V application usage in an .XML and upload it to server. To have this functioned Online=1

    My issue is ,Published version of OSD is 4.5 and Package file is .SFT whereas the deployed version of OSD is 4.6 and the package file is appended _1.sft.

    Why the OSD files are not getting replaced with the OSD's of .MSI( which has got the same GUID) when deployed via Altiris.? . If this gets replaced my issue is resolved.

    But manually when i install .OSD files get replaced . Application works.

    Wednesday, March 27, 2013 5:49 AM
  • When just firing up the sequencer-generated MSI on a client machine, it usually nicley replaces the local copies of the OSD files with the new version and imports the new SFT file content right away.

    If you're letting 'a repacking/deployment tool' create the MSIs for you, this might be an issue (for instance SCCM2007 creates own MSIs for App-V applications and does not use the sequencer-generated ones).

    During 'installation', the original packae must not be in use - and the GUID inside the <CODEBASE... > attribut is the one that matters (just to be sure).

    I sometimes see that OSDs are modified 'outside' of the sequencer (with notepad) - in that case, the MSI does contain the old OSD, and not the modified one; but this doesn't seem to be your issue anyway.

    A thing to note is that both, the MSI and the SFT should be located in the same folder locally on the client when launching the MSI. Not sure if Altiris creats local copies of them.



    Falko

    Twitter @kirk_tn   |  Blog kirxblog   |  Web kirx.org

    Wednesday, March 27, 2013 6:53 AM
    Moderator
  • Its a sequencer generated .MSI fle .

    The MSI and the SFT are be located in the same folder locally on the client when launching the MSI.

    Wednesday, March 27, 2013 9:25 AM
  • I know there was an issue with the sequencer (at least with version 4.5) and the way that the generated MSI determines the path to the SFT. The SFT file is stored externally next to the MSI.
    I found that when running the MSI manually this works fine but when I deployed via SCCM 2007 the path could not be determined and the SFT was thus not loaded into the cache. There may be a similar issue when deploying via Altiris.

    I thought that this issue did no longer exist with 4.6 but since your sequences were originally created with 4.5, it may be that the problem persists.

    The way I solved this was to create an MST for the created MSI’s. This MST makes the following changes to the MSI:

    It adds a VbScript to the binary table which uses the SOURCEDIR property to set the SFTPATH property.

    VbScript source:

    SftPath = Session.Property("SOURCEDIR") & Session.Property("SFTNAME")
    SftPath = Replace(SftPath, "\", "\\")
    Session.Property("SFTPATH")= SftPath

    It adds a custom action to execute the added script called GetSFTPATH

    It disables the original custom action ‘UpdateSftPath’ which does not correctly set the SFTPATH property.

    It adds the ‘ResolveSource’ default MSI action, just after the original ‘UpdateSftPath’ action in the InstallExecuteSequence of the MSI.

    It also adds the ‘GetSFTPATH’ custom action after the ‘ResolveSource’ action.

    When using this MST together with the MSI I found that deployment of the MSI using SCCM 2007 now correctly added the SFT to the cache.

    Click here to download the MST I created: MST on my Public SkyDrive

    Hope it helps.

    KR,
    Casper









    Wednesday, March 27, 2013 9:42 AM
  • Casper ,

    I am not able to download the .mst file, can you please send it to email ID kimathi78@gmail.com

    and is this fix application specific ? if so I have 400 apps to be worked on. 

    Wednesday, March 27, 2013 11:17 AM
  • No it is not application specific. It is a generic MST that should work with all App-V created MSI's.

    Sorry about the download link. I put it on my SkyDrive but a direct download link to a file on sky drive seems to only be available for a limited time. I'll have to find a nother way. Meanwhile I e-mailed you the file.

    [EDIT] I've now changed the link to point to my public SkyDrive folder instead of the file directly. This should allow you to download the MST. [/EDIT]


    • Edited by CvdKooij Wednesday, March 27, 2013 1:41 PM
    Wednesday, March 27, 2013 12:30 PM
  • Hi All,

    I am getting this error again for standalone method of installation. 

    Host name resolution failed for the server.

    Error Code :- 4617595-2460410A-40002EE7.

    Thanks

    Indu

    Monday, April 8, 2013 11:02 AM