none
WPAD search domain issue RRS feed

  • Question

  • Hello everyone,

    I am having an issue with WPAD and DNS resoution.  I am currently using DHCP option 252 to send the url for my wpad.dat file.  My test workstation is picking it up and its working.  I do a "what is my ip" from google and i can see that im going through the proxy.  The only catch is short names for internal servers are coming back as unresolvable.  Our intranet is vnet.domain.com.  I can only get to it (and any other internal web resource) by using the FQDN or IP in the url.  The page cant be found otherwise.  the funny thing is if i uncheck automatic discovery in IE and manually put in the IP and port of my proxy server it works fine with the short name.  I have to be missing something in my wpad.dat file since bypassing the .dat file makes everything work great.  Is there a default search domain function im missing?  I have removed WPAD from the Global DNS query blocklist but i don't think this matters since im not using DNS for auto discovery.  My wpad.dat file is pated below.  I think i may also something out of order because the isInNet statement is being ignored and the proxy always goes on even if the client workstation is not in the 10.0.0.0 subnet.

    Any help would be much appreciated.

    Thank You in advance ..



    function FindProxyForURL(url, host)

    {

    //The following URLs will not be proxied

    if
    (

    dnsDomainIs(host, "vcnynt.com")

    || dnsDomainIs(host, "villagecare.org.com")

    || dnsDomainIs(host, "*.vcnynt.com")

    || dnsDomainIs(host, "vnet.vcnynt.com")

    || dnsDomainIs(host, "patch.6nsystems.com")

    )

    return "DIRECT" ;

     else {


    return "PROXY 10.17.2.13:3128" ;





    if (isInNet(myIpAddress(), "10.0.0.0", "255.0.0.0"))

    return "PROXY 10.17.2.13:3128" ;

    // Add new networks by customizing the lines below
    // and removing the ‘//’ comment markers
    // if (isInNet(myIpAddress(), "172.16.1.0", "255.255.255.0"))
    // return "PROXY 10.92.168.0.1:8080" ;


    // If the client is not in one of the above networks
    // No proxy will be used

    return "DIRECT" ;}}

    Thursday, September 4, 2014 4:42 PM

All replies

  • I have simplified my wpd.dat and im still having the same issue .. updates .dat below:

    function FindProxyForURL(url, host)
     {
     if ((isPlainHostName(host) ||
     dnsDomainIs(host, ".vcnynt.com")) &&
     !localHostOrDomainIs(host, "vnet.vcnynt.com") &&
     !localHostOrDoaminIs(host, ".vcnynt.com"))
     return "DIRECT";
     else
     return "PROXY 10.17.2.13:3128";
     }


    Tim Newman

    Thursday, September 4, 2014 5:37 PM
  • One more note. I replicate the issue of local host names not being resolvable if i enter my proxy server manually in IE and uncheck the bypass proxy server for local addresses box.  This tells me the wpad.dat file is not telling IE to bypass local address properly.   if ((isPlainHostName(host)  should take care of this.  I'm not sure why its not.


    Tim Newman

    Thursday, September 4, 2014 6:16 PM