locked
Error when launching or view Exchange 2007 Management console RRS feed

  • Question

  • I perfomed a fresh installation of Exchange 2007 on a windows 2008 server SP2 x64 bit machine. This is the first version of Exchange server ever installed in my domain. There were no previous version installations before.

    After a few later days, I started receiving the following error whenever i launch the EMC :

    The following error(s) were reported while loading topology information:

    get-StorageGroup
    Failed
    Error:
    Property CanEnableLocalCopy cannot be set on this object because it requires the object to have version 0.1 (8.0.535.0) or later. Current version of the object is 0.0 (6.5.6500.0).

    --------------------------------------------------------
    OK
    --------------------------------------------------------

    - If I create a new storage group, its created sucessfully but is not visible in EMC, if I refresh the EMC, i get the above error.

    - I am to be see and create databases and SG thru the exch management shell.

    Could someone tell where should should I look for the cause as there is no events created and there is info or KB on microsoft for this?

    It seems that it talking about Exchange 2003 version (6.5.6500.0), but I never had any exhcange 2003 server in this domain nor it was ever installed. I have no idea from where this coming ? Is this some sort of bug?

     

     


    Regards, Kundan
    • Changed type kundan81 Monday, March 14, 2011 12:05 PM
    Thursday, March 10, 2011 11:26 AM

Answers

  • I finally found out the problem.

    There was a recovery storage created and lying in exchange for months. After I deleted it, the message no longer shows up !!

    I am wondering why would a recovery storage show up such an error.

     


    Regards, Kundan
    • Marked as answer by kundan81 Tuesday, March 15, 2011 11:31 AM
    Tuesday, March 15, 2011 11:31 AM
  • Hi Kundan,

    It seems that your recovery Storage Group was created by using Active Directory Users and Computers Microsoft Management Console (MMC) snap-in instead of using the Exchange Management Console. That's why you are getting this error.

    To resolve the issue, go to ADSIEdit.msc, brouse the recovery storage group having problem, open the property dialog and search for "msExchVersion" attribute. Its current value will be <not set>.

     

    Change it to "4535486012416" for exchange 2007.

    Now perform the operations whatever you were performing earlier. Above mentioned error will no more repeat.

    Thanks,

    Peeyush


    • Proposed as answer by peeyush.jain Thursday, July 21, 2011 10:43 AM
    • Marked as answer by kundan81 Tuesday, May 22, 2012 6:06 AM
    Wednesday, July 20, 2011 5:16 AM

All replies

  • Kundan,

    Did you check the event log if any errors are logged?. Which groupmemberships are assigned to this user?

    Regards,

    Johan


    Exchange-blog: www.johanveldhuis.nl
    Thursday, March 10, 2011 2:32 PM
  • Johan,

    There are no errors logged in event viewer, not even a warning. I am using a domain administrator, it has the group membership of Domain Admins, Builtin, Enterprise Admins, Exchange Organisation, Exchange servers, schema Admins, domain users, Exchange view only.

    Thanks for the help.

     

     


    Regards, Kundan
    Friday, March 11, 2011 6:16 AM
  • Hi Kundan,

    Please run the Exbpa in the Toolbox to do a system check.

    If possible, please log on to the Exchange server using another Exchange admin to open to EMC to test.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, March 15, 2011 2:31 AM
  • I finally found out the problem.

    There was a recovery storage created and lying in exchange for months. After I deleted it, the message no longer shows up !!

    I am wondering why would a recovery storage show up such an error.

     


    Regards, Kundan
    • Marked as answer by kundan81 Tuesday, March 15, 2011 11:31 AM
    Tuesday, March 15, 2011 11:31 AM
  • Hi Kundan,

    It seems that your recovery Storage Group was created by using Active Directory Users and Computers Microsoft Management Console (MMC) snap-in instead of using the Exchange Management Console. That's why you are getting this error.

    To resolve the issue, go to ADSIEdit.msc, brouse the recovery storage group having problem, open the property dialog and search for "msExchVersion" attribute. Its current value will be <not set>.

     

    Change it to "4535486012416" for exchange 2007.

    Now perform the operations whatever you were performing earlier. Above mentioned error will no more repeat.

    Thanks,

    Peeyush


    • Proposed as answer by peeyush.jain Thursday, July 21, 2011 10:43 AM
    • Marked as answer by kundan81 Tuesday, May 22, 2012 6:06 AM
    Wednesday, July 20, 2011 5:16 AM