none
Portal error - service not available RRS feed

  • Question

  • I have setup MIM on SharePoint 2013 with a domain account eg dom\AccntA. After installation when I try to open the portal, I get an error "service not available". I changed web.config to show me a bit more of a meaningfull error:

    --------------------------------------------------

    Object reference not set to an instance of an object.
    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.NullReferenceException: Object reference not set to an instance of an object.

    Source Error:

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

    Stack Trace:


    [NullReferenceException: Object reference not set to an instance of an object.]
       Microsoft.IdentityManagement.WebUI.Controls.UICacheUtils.GetCacheKey(CacheKey key) +266
       Microsoft.IdentityManagement.WebUI.Controls.UICacheUtils.RetrieveFromCache(UserNonSharedKey key) +25
       Microsoft.IdentityManagement.WebUI.Controls.NavigationBarConfigurationModel.RetrieveSiteNodeFromCache() +96
       Microsoft.IdentityManagement.WebUI.Controls.NavigationBarProvider.BuildSiteMap() +87
       Microsoft.SharePoint.WebControls.AspMenu.GetEditableSiteMapProvider(SiteMapDataSource dataSource) +43
       Microsoft.SharePoint.WebControls.AspMenu.AdjustForProviderMaximumDepth() +59
       Microsoft.SharePoint.WebControls.AspMenu.OnPreRender(EventArgs e) +46
       System.Web.UI.Control.PreRenderRecursiveInternal() +175
       System.Web.UI.Control.PreRenderRecursiveInternal() +272
       System.Web.UI.Control.PreRenderRecursiveInternal() +272
       System.Web.UI.Control.PreRenderRecursiveInternal() +272
       System.Web.UI.Control.PreRenderRecursiveInternal() +272
       System.Web.UI.Control.PreRenderRecursiveInternal() +272
       System.Web.UI.Control.PreRenderRecursiveInternal() +272
       System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +6785

    Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.6.1069.1

    --------------------------------------------------

    but it still doesn't mean a thing to me.

    Eventviewer shows an ASP.NET error:

    Event code: 3005
    Event message: An unhandled exception has occurred.
    Event time: 4/29/2016 2:27:24 PM
    Event time (UTC): 4/29/2016 4:57:24 AM
    Event ID: ffba74342d674de691794a14a92f76cf
    Event sequence: 8
    Event occurrence: 2
    Event detail code: 0
     
    Application information:
        Application domain: /LM/W3SVC/39381490/ROOT-1-131063786362477129
        Trust level: Full
        Application Virtual Path: /
        Application Path: C:\inetpub\wwwroot\wss\VirtualDirectories\82cdc9554c-50b9-4a20-bede-f2cd6a8ae01c\
        Machine name: <PORTAL SERVERNAME>
     
    Process information:
        Process ID: 1848
        Process name: w3wp.exe
        Account name: domain\SVC_SharePoint
     
    Exception information:
        Exception type: NullReferenceException
        Exception message: Object reference not set to an instance of an object.
     

    Could it have something to do with the domain\SVC_SharePoint referenced or the fact that it is Microsoft .NET Framework Version:4.0.30319 and ASP.NET Version:4.6.1069.1?

    Thanks

     

    Friday, April 29, 2016 6:15 AM

All replies

  • 1. The portal is not working locally or only from other hosts?

    2. What FIM Service address have you provided to web.config file? Can you ping that address? If you open this address in web browser on port 5725, do you see service answer?

    3. Please double check your Kerberos settings (SPNs, delegation, "A" entries in DNS)? -> the good source to do that is FIM 2010 R2: Kerberos Authentication Setup


    If you found my post helpful, please give it a Helpful vote. If it answered your question, remember to mark it as an Answer.

    Friday, April 29, 2016 11:34 AM
  • Thanks Dominik,

    1) Same result from local (ie from the portal server) and remote.

    2) web.config has the full url (not 'localhost') :5725. When I open that url:5725 I get the info page.

    3) Which account should I be looking at to double check: is that the sharepoint (pool) account and/or the MIM service account.

    Thanks,
    Mick

    Saturday, April 30, 2016 12:53 AM
  • Hi MickeyX13

    Have you performed all the prerequisites before installing the MIM portal? Please see the links below

    Preparing the Domain
    Preparing a Corporate Identity Management Server

    Monday, May 2, 2016 10:23 PM