locked
Getting Access Denied When Running stsadm.exe -o backup -showtree SharePoint 2007 RRS feed

  • Question

  • I am moving my SharePoint 2007 DBs from an old SQL server to a new SQL server.  I am following http://technet.microsoft.com/en-us/library/cc512725(office.12).aspx but have run into a snag.  I am trying to pull the GUID from my backups but when I run stsadm.exe -o backuphistory -directory <UNC PATH> I am told ACCESS DENIED.  I am running this command as a farm admin and have verified both the SQL service and farm accounts have full access to the UNC PATH.  I then tried running stsadm.exe -o backup -showtree and I am told ACCESS DENIED.  Can someone please help me determine why I was able to make it to step 13 in the Microsoft KB article but all of a sudden I am getting ACCESS DENIED messages.  Thank you.
    Wednesday, January 19, 2011 3:02 PM

Answers

All replies

  • Can you run any STSADM commands at all?  If not, you need to turn down User Account Control - see http://blogs.kma-llc.net/microknowledge/2009/08/but-im-an-administrator-why-cant-i-run-stsadmexe.html for more details.

    Good luck!

    Chris


    Chris McNulty MCSE/MCTS/MSA/MVTS http://www.kma-llc.net | blog http://blogs.kma-llc.net/microknowledge | twitter @cmcnulty2000
    • Marked as answer by Leoyi Sun Tuesday, February 8, 2011 6:57 AM
    Wednesday, January 19, 2011 7:20 PM
  • the SP server is not a 2008 server.  but the sql server is.  does that matter?
    Wednesday, January 19, 2011 7:24 PM
  • hi chris, i checked the sql server (WS2K8) and UAC is off. and like i said, the SP server is running WS2K3. Any other ideas what could be going on? Thanks.
    Wednesday, January 19, 2011 7:52 PM