locked
Service Offering Not Shown on Homepage RRS feed

  • Question

  • Hi there,

    I have created a Service Offering and published it, and I have created and assigned a Request Offering to the Service Offering which is also published. I have added the Service Offering to a custom category which has been added to the Service Offering Category List.

    When I navigate to the portal, I do not see the category I created with its associated Service Offering listed on the Category View homepage, however if I select List View, I am able to see the Request Offering listed, however it is listed without its parent Service Offering tag or the Category tag.

    Selecting the Request Offering from the List View allows me to see the associated Service Offering as an associated service which then allows me to drill into the Service Offering.

    Can anyone please explain for me why I'm not able to see it correctly from the homepage? In-case anyone was wondering, this is running in SCSM 2012.

    Thanks
    Richard


    Richard Green, MCSE Windows Server 2003


    • Edited by richardjgreen Wednesday, February 15, 2012 6:09 PM Update
    Wednesday, February 15, 2012 6:08 PM

Answers

  • If you don't add additional language support for the SharePoint (How to Select the Portal Language in SCSM 2012) you should be fine with English US for service requests.

    Andreas Baumgarten | H&D International Group

    Wednesday, February 15, 2012 8:50 PM
  • Hi Richard,

    Did you select a language on your Service Offering?

    If you didn't or selected English (United States), did you create a End User Role ?
    You can create different groups to scope permissions in Library > Groups.
    And can create an New End User Role : Administration > Security > User Roles.
    Make sure to select the group you created earlier.

    Try to get it working without a language selected first (use the blanc language).

    Wednesday, April 18, 2012 9:21 AM
  • I had the same problem today. I fixed it by changing the Service Offering language to the language of the browser that is used to view the portal. 

    Worked like a charm, but it's a bit stupid tho.


    - username
    Wednesday, April 18, 2012 2:40 PM

All replies

  • Maybe this blog post from Travis Wright is helpful:

    FAQ: Why Doesn’t My Request Offering Show up in the Category View of the Service Catalog?

    Maybe the reason is the missing/wrong language setting in the service offering/browser (topic 5 of the list in the blog post)?


    Andreas Baumgarten | H&D International Group

    Wednesday, February 15, 2012 6:58 PM
  • Andreas,

    Thanks, I'll take a look at that.

    Does this mean then, that we will have to create multiple instances of each service and request offering to cater for each language? In our environment, whilst we service five different languages giving us the 'option' make the portal available in multiple languages, our user base is able to speak English in all locations therefore, at least initially, it would be preferable to make the request and service offering available in English only.

    Creating five versions of the same request and service offering but simply chaning the language field to accomodate their OS installation seems like a severe duplication of work. Is it possible to leave the language field blank so that it will be available regardless of language?

    Thanks
    Richard


    Richard Green, MCSE Windows Server 2003

    Wednesday, February 15, 2012 8:41 PM
  • If you don't add additional language support for the SharePoint (How to Select the Portal Language in SCSM 2012) you should be fine with English US for service requests.

    Andreas Baumgarten | H&D International Group

    Wednesday, February 15, 2012 8:50 PM
  • Hi Richard,

    Maybe you have the same problem I and Jeff had (http://social.technet.microsoft.com/Forums/en-US/portals/thread/4c54290c-850e-45b9-b26e-65203e1fd744). My solution was to add not only the service offering, but also the request offering to the Catalog Group I used to publish for my end users. I hope this helps you.

    Johan

    Thursday, March 15, 2012 2:17 PM
  • Hi Richard,

    Did you select a language on your Service Offering?

    If you didn't or selected English (United States), did you create a End User Role ?
    You can create different groups to scope permissions in Library > Groups.
    And can create an New End User Role : Administration > Security > User Roles.
    Make sure to select the group you created earlier.

    Try to get it working without a language selected first (use the blanc language).

    Wednesday, April 18, 2012 9:21 AM
  • I had the same problem today. I fixed it by changing the Service Offering language to the language of the browser that is used to view the portal. 

    Worked like a charm, but it's a bit stupid tho.


    - username
    Wednesday, April 18, 2012 2:40 PM