none
You do not have permission to access \\PC_NAME contact your network administrator to request access RRS feed

  • Question

  • After upgrading a computer to ver 1809 build 17763.316 I cannot connect from other computers on the same network via Windows Explorer. Troubleshooting did not find a solution. I followed the steps outlined at answers.microsoft.com.

    I followed the 3 methods without result. At Method 2 I received the following errors:

    • cannot start the Peer Name Resolution Protocol service on Local Computer Error 0x80630203 Unable to access a key.
    • cannot start the Peer Networking Grouping service n Local Computer Error 1068 The dependency service or group failed to start.

    All other services a running.

    At Method 3 the SMB 1.0/CIFS FIle Sharing support only Client is ON, the others are off. I switched the Server to ON, but no result.

    Can you help me to connect to this computer please.

    Wednesday, February 13, 2019 10:32 AM

All replies

  • Hello stephen_pen,

    Thank you for posting in this forum.

    Before we go further, I would like to confirm the following questions:

    What is the operating system of your other computers?

    Can other machines successfully ping the 1809 machine?

    Have you checked if it is a permission issue?

    Can't you access the 1809 machine via \\Computer Name or can't access the 1809 machine via \\IP address? Or both these two methods not working?

    Please try to turn off the firewall first to see if it works.

    Best Regards,

    Leon


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, February 14, 2019 2:53 AM
  • Hello, Leon

    Here are my answers:

    What is the operating system of your other computers?
      - Windows 10 1803 Build 17134.590
      - Windows 8.1
    All computers have the latest updates.

    Can other machines successfully ping the 1809 machine?
      - Yes.

    Have you checked if it is a permission issue?
      - I have. I want to access the Public folder under \Users. It is accessible locally. Here are my steps: Public-> Properties->Share->Choose people to share with. The permission level of User_name & Everyone is Read/Write; SYSTEM's is Owner. The Network of the folder is \\PC_NAME\Public.
      - Advanced sharing: The Share name of this folder is Public and the box Share this folder is checked. Permissions for Everyone: Allow: Full control, Change and read

    Can't you access the 1809 machine via \\Computer Name or can't access the 1809 machine via \\IP address? Or both these two methods not working?
      - No. The OS replies 'Windows cannot access \\PC_NAME. Contact your network administrator to request access.' I get the same message after entering the \\IP address (accessible by Ping).

    Please try to turn off the firewall first to see if it works.
      -I tried without result - still no permission.

    More information:
    The computer name is visible on all computers under Network. Clicking on any other name opens the all shared folders on the target computer. I have just found a solution. Unlike other OSes in the network version 1809 requires explicitly the path to the shared folder. So in Windows Explorer clicking on \\PC_NAME or \\IP_address says 'No permission'. But entering the path to the shared folder opens it. The firewall state makes no difference.

    Advanced sharing options on the 1809 computer:
      - Private: Network discovery and file and printer sharing are ON.
      - Guest or public: both are OFF. (I can still open the Public folder.)
      - All networks: Public folder sharing is ON; use 128-bit encryption and password protected sharing is OFF.

    In conclusion: The requirement to enter the full path to the shared folder is new in 1809 and a bit frustrating. It may have been done for better protection but it's not convenient. I restarted the 1809 machine and entered \\PC_NAME\Public and it worked.

    I am not sure if this workaround is a solution.

    Best regards

    Stephen Pen

    Thursday, February 14, 2019 6:36 PM
  • Hello Stephen Pen,

    Can you access the share via \\IP address\Public?

    Best Regards,

    Leon


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, February 15, 2019 8:10 AM
  • Hi,

    Enable netmon trace, then start accessing the share and stop the trace.

    Try to analyse the traces using netmon.


    Regards Sajin P S

    Friday, February 15, 2019 8:15 AM
  • Yes, I can open the share in both ways: \\PC_NAME\Public and \\IP_address\Public, but each time it takes 20 seconds to open the share.

    Best regards,

    Stephen Pen

    Friday, February 15, 2019 11:04 AM
  • Thank you for your reply.

    I downloaded MS Network Monitor  but the software is not supported by the new processor.

    I tried to use netsh, but the learning curve is too steep. If you send me details how to trace a shared folder and how to view the results I will do it. Should I learn and use NetShark? You see, networks are not my strength.

    Best regards

    Stephen Pen

    Friday, February 15, 2019 11:33 AM
  • You can not believe how frustrated I have been with this same problem. I have four computers connected by a home network. All computers can see and share with each other except for one problem. Computer #1 (Windows 1809) can not retrieve shared folders from windows 1809 computer #2. I'm told I don't have permission. However, #2 can see and edit shared files from computer #1. So the problem is only one way.

    I have checked and rechecked permissions, security, etc... only to continue banging my head against this stupid brick wall. FINALLY, I typed the exact path to the shared drive and it opened with full editing permissions. But, I still get denied when I click on the computer name under NETWORK.

    All I can say is THANK YOU Stephen Pen for sharing that fix.

    Hey Microsoft! Why can I access all computers by clicking on the name except one? You are, as always, completely unhelpful.

    Thanks again, Stephen! It's not the most convenient but at least my two work computers can access the drives on each computer.

    -CRADSA

    Saturday, February 16, 2019 10:18 PM
  • Thank you, Cradsa for your message.

    I found a solution to the problem, but still not sure if Microsoft will keep it this way or go back to how it was before.

    Anyway, I am really happy this time I was helpful.

    Best regards,

    Stephen Pen

    Monday, February 18, 2019 12:32 AM
  • I spent over three hours with Microsoft Tech Support yesterday on the same problem.

    I have three computers - one desktop, two laptops.  Each went through a recent upgrade from Windows 7 to Windows 10, Build 1809.  The connectivity issues between two computers were numerous. I want to thank David G for giving me his time and enlightening me to some setup issues.  

    We tried many things yesterday - but here is what did NOT work.  I can say this because I have undone those changes and can connect between the computers - with one exception.

    • Passwords are not needed.
    • Credentials are not needed.
    • The "C" drive is not required for sharing.
    • The "Functional Discovery Resource Publication" Service is not working correctly - you must Stop and Restart the service in order for a computer to appear on the network.
    Two of the three computers can talk to each other (bidirectionally) without a problem.  The third computer can see and access folders on the other two computers.  But this third computer denies access to the other two.  Using Stephen's technique, I can now see the folders (and files) on the third computer. So I know the Permissions, Network Advanced Sharing options are ok, etc. 

    So this must be a MAJOR bug for Microsoft (and the 1809 Build) if so many people are experiencing the same thing.I can't begin to tell you the number of hours I have spent on this (along with Microsoft Tech Support).  I am convinced there is something wrong with the third computer's setup; perhaps there is a hidden setting that fixes this or something that must be undone and reset. I have been all over settings, reinstalling NIC drivers, etc.  I just can't find it.

    Thank you Stephen Pen for your efforts!

    Tom Carlos


    Tuesday, April 9, 2019 10:09 PM
  • Update and Success - 

    As notes previously, I was working with three computers, each was a Windows 7 to Windows 10 update.  Two of the computers behaved nicely after the update - one did not.  After struggling for MANY hours, the only resolution was to start with a clean SSD and clean installation of Window 10, Build 1809.  Clearly, the update from Win 7 to Win 10 failed to clear out the ghost entries in either the settings, services, firewall rules, something!! 

    Once I installed the new OS, there are four areas that must be updated in order for the networking to work properly:

    • Ethernet Card and Adapter Settings
    • Changes to "Services” settings
    • Changes to Programs and Features>>Turn Windows Features On or Off settings
    • Firewall Applications
    • Advance Sharing Options
    • Folder Permissions For Sharing / Security
    • Verify all computers are on the same Workgroup

    For the Problem Child (PC) laptop, I compared the new build to a working laptop and made sure the settings were the same.  Since each computer setup is different (yours compared to mine), you would need to be careful regarding how you setup the various windows. The hardest one was the "Services" - as there are 6 key Services that need attention - 

    (1) DHCP Client, (2) DNS Client, (3) Functional Discovery Provider Host, (4) Functional Discovery Resource Publication, (5) SSDP Discovery, and (6) UPnP Device Host.

    Please look for a thread titled Windows 10, Version 1809. Network does not show computers for more information.  Sorry, Technet will not let me post the thread in a link.

    After going through all this, I was finally able to resolve the network visibility and connectivity issues.

    Phew- that was a cumbersome exercise.  I hope this helps someone. 

    Tom


    • Edited by Tom Carlos Monday, April 15, 2019 6:00 PM Forgot an entry
    Monday, April 15, 2019 5:56 PM
  • I've had this same issue since last fall and have tried all the other proposed solutions I've found on the web. It seems like there can be more than one cause for this problem since some solutions work for some people but not others.

    None of the solutions I found on the web worked for me, so on a whim, I manually created Windows Credentials for all the computers on our business network. From the Control Panel, select Credential Manager. Select the tab on the right side that says Windows Credentials. Click on 'Add a Windows credential'. For 'Internet or network address' I entered \\computer-name. I then entered the user name (administrator access) and password for the user on that particular computer. I created a new credential for each computer on our network, and just to be safe, I created a credential for the computer I was on, too. I did the same for every computer on our network. So what I ended up with is 5 computers, each with 5 Windows Credentials, one for each of the other computers and one for itself.

    This finally solved my 'You do not have permission to access...' problem. 


    • Edited by Asbury Tuesday, June 11, 2019 9:14 PM
    Tuesday, June 11, 2019 8:45 PM
  • Asbury:

    I had the same problem on a Home LAN with 3 desktops (2 Win 7 Pro & 1 Win 10 Pro v.1903 build 18362.175) and 2 laptops (1 Win 7 Pro and 1 Win 10 Pro v.1809 build 17763.557). Some could see others bidirectionally, some unidirectionally, and some not at all. Very inconsistent, too - no discernible pattern between 7-7, 7-10, 10-7 or 10-10 machines.

    I tried most (if not all) of the various remedies proposed in this thread, but yours was the *ONLY* solution that worked - every machine can now access every other machine. THANK YOU!


    • Edited by EDColeman3 Thursday, June 27, 2019 8:13 PM
    Thursday, June 27, 2019 8:11 PM
  • As for many others, continuing frustration at network permissions issues that have been part of Windows since when I started with it in the 1980s, yeah I'm old.  Thirty years or so of this and still it is a nightmare.  I spent the better part of a day playing the settings and search game.  You know it well.  Check and set settings with no results, then search, search, search for answers where none are to be found, and then repeat, repeat, repeat.

    This should be easy MS ... one page... what do you want to share and with who, and MS takes it from there. Why are there settings after settings all over the place?  STILL.

    Same issues as many had... one machine on 1709, because it absolutely will not upgrade and will have to be completely redone, and trying to connect with one other machine running 1809, for now.  More to come.  Same silly inconsistencies, one folder works another doesn't even with identical settings.  Or, one minute it is working the next it is not.  And, so forth.  Absolute rubbish and inexcusable.

    MANY THANKS to Asbury who absolutely nailed it on the head.  Great suggestion that worked when all else failed.

    As for MS help around the web, well, it was do this do that and so forth and so on with no results at all.

    MS, it cannot be all that difficult to come up with a network dashboard and maybe, if you would stop trying to push junk and unwanted apps on people, you might just be able to find a room somewhere in Planet Microsoft where you could put a few dozen programmers to work doing just that!

    Sunday, July 7, 2019 9:25 PM
  • i had this problem on 1703 1809 and now 1903. sometimes after initial install it would go away.  Just noticed this in 1903 and solved by entering full remote path.  shared folders on either computer are not showing in computer management/system tools/ shared folders / shares possibly related?? it is showing parent of shared folder with no description videos is shared on both computers. in shares it only shows Users not videos subfolder
    Friday, August 2, 2019 12:19 AM
  • Thank you Stephen Pen, this worked for me too (as a workaround).

    I have a new laptop and tried everything.

    So, old desktop -> new laptop did this:

    \\LAPTOP produced permissions error. But:

    \\LAPTOP\USER just worked as it should and allowed me to browse..

    But new laptop -> old desktop was no problem:

    \\DESKTOP just worked and allowed me to browse.

    This is very frustrating and not good that we need to use a workaround. I had tried all other suggestions here an elsewhere and nothing worked. So it must be a bug. I really hope it gets fixed. I look forward to any news. 


    • Edited by Stephen_C Monday, September 9, 2019 1:24 AM
    Monday, September 9, 2019 1:23 AM
  • I have had the same problem since updating various computers on a network to 1903. I can type in the full share name (\\user-pc\f) and that works, but \\user-pc is usually not visible until I stop and restart the Function Discovery service. Even then I can't browse \\user-pc without getting a "you don't have permission" error. I have done EVERYTHING in this thread multiple times. I'm guessing there are remnants of some previous permissions settings that can't be changed or addressed in 1903. It's maddening. I have spent weeks on this.

    • Edited by dbarrow2019 Wednesday, October 9, 2019 3:39 AM
    Tuesday, October 8, 2019 3:44 PM
  • It seems like this would probably boil down to an incorrect registry setting that lingered from a previously installed Windows version that isn't changed by current settings in some dialog somewhere. I am surprised that some Microsoft genius hasn't pointed out what to change or how to fix it.

    I can connect to shares by typing in the full name: \\computer-name\share, but I can't connect to \\computer-name. It says I don't have permission. This must be some setting that is separate form all the drive and share permissions that have been discussed at length here, and elsewhere.

    Does ANYONE know where the permissions are set for \\computer-name separately from the shared folders?

    Wednesday, October 9, 2019 2:31 PM
  • Same problem here. 

    Everything working fine on a Windows 10 computer with file shares. Then suddenly today, users cannot browse to \\computername. Only full paths to shared folders work - \\computername\share

    Wednesday, October 9, 2019 6:05 PM
  • If it comes down to the difference in permissions between "\\computer-name" and "\\computer-name\share", where is that expressed, stored (in registry) or set via some control panel dialog? It seems like someone at Microsoft would be able to easily answer this. I have several computers. Some are visible in "network" some are not. One of them gives the "you don't have permission" warning pop up, but not when the full share name is typed in. All computers are now 1903 and have the same settings.
    Thursday, October 10, 2019 3:36 AM