Owaauth.dll ISAP Filter causing problems....help!! RRS feed

  • Question

  • Hi,

    Since installing Exchange 2007 on my x64 server, I have not been able to use the OWA feature. Every time I run it my IIS dies.

    This is the error message in the Event Log:

    ISAPI Filter 'C:\Program Files\Microsoft\Exchange Server\ClientAccess\Owa\auth\owaauth.dll' could not be loaded due to a configuration problem. The current configuration only supports loading images built for a x86 processor architecture.

    Does that mean my IIS is running in 32 bit mode instead of 64 bit mode? I don't have any major applications that specifically require 32 bit mode on the server (I think). How do I get this thing working?

    Thursday, August 10, 2006 3:03 PM

All replies

  • Has anyone figured this out?  This is causing problems for me as well.
    Sunday, January 21, 2007 2:31 PM
  • I search and find some information about iis mode.It's look by default x64 IIS is not support x86 mode to run 32 bit application.Configuring IIS to Run 32-bit Applications on 64-bit Windows I'm not sure this article is helpful or not for you.
    Monday, January 22, 2007 2:13 AM
  • Sounds like your IIS is running in 32-bit mode, and--not that I entirely understand why, but--the couple Exchange 2007 64-bit servers I'm working with have had to be in 64-bit mode.

    So, you need to make sure you have the following:
    • IIS must be in 64-bit mode ("cscript.exe %systemdrive%\Inetpub\AdminScriptsadsutil.vbs set W3SVC/AppPools/Enable32BitAppOnWin64 FALSE")
    • 64-bit .NET Framework 2.0 installed (look for the directory "C:\WINDOWS\Microsoft.NET\Framework64")
    • .NET Framework 2.0/ASP.NET 2.0 registered with IIS ("aspnet_regiis.exe -lv" to see registered versions)
    • ASP.NET 2.0 enabled as a Web Service Extension (IIS Manager Console)
    Heh... got all that? Probably most of it is in place. You may just need to switch to 64-bit mode and re-enable the 64-bit version of ASP.NET 2.0. Good luck!
    Monday, January 22, 2007 9:32 PM
  • http://support.microsoft.com/kb/894435

    that is the article that tells you how to switch to 64bit IIS.

    I just tried it and it works now.

    Monday, November 5, 2007 3:25 PM
  • I have also tried this, and as long as IIS7 on a x64 server is running in x64 only, it works. However, all of my COM objects (different web sites, same server) won't run.


    BUT - on my 2008 x64 with Exchange 2007 x64 SP1, if I enable 32-bit applications, OWA fails (owaauth.dll).


    So how does one enable OWA to run in x64, while other web sites will work with 32-bit COM objects?


    Monday, March 10, 2008 9:58 AM
  • Hola a todos (escribo en español porque es mi idioma)

    Yo solucioné el problema ejecutando este comando, con FALSE al final y funciono:

    cscript.exe adsutil.vbs set W3SVC/AppPools/Enable32BitAppOnWin64 "false"

    Espero obtengan el mismo resultado que yo.


    Monday, September 28, 2009 4:09 PM
  • Hi, I'm still having issue after following above solutions. I had Exchange 2007 on Win 2k8 x64.

    I've done the above solutions, plus:

    • Reset IIS
    • Change ASP .NET v2.0 (32bit version) restriction to "Not Allowed"
    • Change MSExchangeOWAAppPool managed pipeline mode -> Integrated (Under IIS Manager -> Application Pools)
    • Enable 32-bit ASP using cscript.exe %systemdrive%\Inetpub\AdminScriptsadsutil.vbs set W3SVC/AppPools/Enable32BitAppOnWin64 1

    All of these actions failed, and EventViewer still logging the same error message as the one OP getting. The strange thing is, OWA is working perfectly, no issue with logging in, sending/receiving emails. I'm just curious about these errors logged by event viewer

    • Proposed as answer by Korena Monday, April 22, 2013 4:30 PM
    • Unproposed as answer by Korena Monday, April 22, 2013 4:30 PM
    Thursday, January 3, 2013 11:19 PM
  • In the Exchange application log you observe:

    The Module DLL C:\Windows\system32\something\whatever.dll failed to load. The data is the error.

    Followed by:

    Could not load all ISAPI filters  Therefore site 'DEFAULT WEB SITE' startup aborted


    On the application pool for the site click on advanced settings:

    Then change the setting pertaining to support for 32-bit applications.

    Then a bunch of other dll files are going to start throwing errors one by one.  You must perform the following procedure for each:

    in this example the error is thrown by kerbauth.dll and reads as follows...

    Module DLL 'C:\Program Files\Microsoft\Exchange Server\V14\Bin\kerbauth.dll' could not be loaded due to a configuration problem. The current configuration only supports loading images built for a x86 processor architecture. The data field contains the error number

    1) in the file "applicationHost.config" located at:

    C:\Windows\System32\inetsrv\config  (SAVE A COPY OF ORIGINAL SO YOU CAN REVERT BACK QUICKLY)

    2) add this line to the area indicated below by using findpreCondition="bitness64"

    Example in my case: This is BEFORE CHANGE:

    <add image="C:\Program Files\Microsoft\Exchange Server\V14\Bin\kerbauth.dll" name="kerbauth">

    And this is after the change, when we add the line as described above:

    <add image="C:\Program Files\Microsoft\Exchange Server\V14\Bin\kerbauth.dll" name="kerbauth" preCondition="bitness64">

    • restart app pool or iis
    • keep returning to the application log in the event viewer to see what dll is unhappy next, perform until red errors related to dll files stop

    Possible step 3)

    3) If a dll like owaauth.dll throws the error you must add the preCondition ="bitness64" to the following area

    <filter enabled="true" name="Exchange OWA Cookie Authentication ISAPI Filter" path="C:Program FilesMicrosoftExchange ServerClientAccessowaauthowaauth.dll" span="span" preCondition="bitness64"/>

    4) then just start the AppPool again and 32 bit application will now work just fine.. and our AppPool wil not be stopped again....

    Koren M. Archibald

    • Edited by Korena Monday, April 22, 2013 4:36 PM
    Monday, April 22, 2013 4:31 PM